You are not logged in.

#1 2009-02-20 11:36:19

NeekO
Member
Registered: 2007-10-28
Posts: 32

[SOLVED] Firefox XPCOM

Hey guys. I'm having a little bit of trouble here smile Yesterday,after turning on Arch and trying to launch FF, this message poped-up: Couldn't load XPCOM.
I've been googling around www, but found no answers nor help regarding this particular error. Before that FF worked fine and then suddenly crashed.
FF is my first-choice browser so i wouldn't like to change it to any other, that's why any ideas would be appreciated.
Thx in advance smile

Last edited by NeekO (2009-02-20 12:02:13)


Oh Snap!!

Offline

#2 2009-02-20 12:01:17

NeekO
Member
Registered: 2007-10-28
Posts: 32

Re: [SOLVED] Firefox XPCOM

Ok, solved that. It seems that some *.so files were missing from xulrunner main folder (dunno how they got lost), but anyhow, i found needed files in some patch,copied what was missing and wuolia smile


Oh Snap!!

Offline

#3 2009-03-05 07:13:33

kilolima
Member
Registered: 2008-01-26
Posts: 49
Website

Re: [SOLVED] Firefox XPCOM

I also had this problem on arch64 but have since swithced to x686.

Last edited by kilolima (2009-03-08 10:33:15)

Offline

#4 2009-07-17 18:11:56

Janusz11
Member
Registered: 2007-05-16
Posts: 76

Re: [SOLVED] Firefox XPCOM

NeekO wrote:

Ok, solved that. It seems that some *.so files were missing from xulrunner main folder (dunno how they got lost), but anyhow, i found needed files in some patch,copied what was missing and wuolia smile

Could you please explain what exactly you did? Because I have now the exact same problem. Now when I build IceCat (with xulrunner-1.9.0.11) the package builds fine. But when I try to start the program it tells me that it "Couldn't load XPCOM.".

Thanks in advance.

Offline

#5 2009-07-17 19:54:24

algorythm
Member
From: /usr/share/zoneinfo/Europe/FIN
Registered: 2009-07-17
Posts: 178

Re: [SOLVED] Firefox XPCOM

I had this problem a couple of days ago with firefox and reinstallation of both firefox and xulrunner solved it.


PC: ASUS Maximus VIII Hero, Intel i7-6700K (4.6 GHz OC), NZXT Kraken X61, 16GB G.Skill DDR4-3200, MSI GTX 1080 Gaming X, Samsung 850 Pro 512GB, WD Black 6TB, Corsair Graphite 780T (Full Tower), be quiet! Dark Power Pro 11 650W (Platinum)
OS: Arch 64-bit / Windows 10 Pro 64-bit
Other: Dell UltraSharp 2560x1440 27", KB: Logitech G910, M: Logitech G502, HS: HyperX Cloud II, I: 100/10M

Offline

#6 2009-07-18 09:18:11

Janusz11
Member
Registered: 2007-05-16
Posts: 76

Re: [SOLVED] Firefox XPCOM

Well, I can use Firefox 3.5 with xulrunner 1.9.1. But I want to run IceCat 3.0.11 and for that I need xulrunner 1.9.0.11. I have the old xulrunner file here and both worked in the past. But when I build and install the IceCat package now I get the above mentioned error message.

Last edited by Janusz11 (2009-07-18 09:19:47)

Offline

#7 2009-07-19 20:08:44

algorythm
Member
From: /usr/share/zoneinfo/Europe/FIN
Registered: 2009-07-17
Posts: 178

Re: [SOLVED] Firefox XPCOM

So did you actually try reinstalling?


PC: ASUS Maximus VIII Hero, Intel i7-6700K (4.6 GHz OC), NZXT Kraken X61, 16GB G.Skill DDR4-3200, MSI GTX 1080 Gaming X, Samsung 850 Pro 512GB, WD Black 6TB, Corsair Graphite 780T (Full Tower), be quiet! Dark Power Pro 11 650W (Platinum)
OS: Arch 64-bit / Windows 10 Pro 64-bit
Other: Dell UltraSharp 2560x1440 27", KB: Logitech G910, M: Logitech G502, HS: HyperX Cloud II, I: 100/10M

Offline

#8 2009-07-20 21:45:42

4internetanonymity
Member
Registered: 2009-07-09
Posts: 13

Re: [SOLVED] Firefox XPCOM

I'm having this problem and I just reinstalled firefox and xulrunner:
pacman -U firefox-3.0.11-1-i686.pkg.tar.gz xulrunner-1.9.0.11-1-i686.pkg.tar.gz

My system is entirely up-to-date minus these two packages. Still getting "Couldn't load XPCOM." I'd upgrade to 3.5 if flash didn't crash it and if three of my plugins were supported. Thanks for your help.

Offline

#9 2009-07-22 00:43:23

coda
Member
Registered: 2008-08-21
Posts: 36

Re: [SOLVED] Firefox XPCOM

NeekO wrote:

Ok, solved that. It seems that some *.so files were missing from xulrunner main folder (dunno how they got lost), but anyhow, i found needed files in some patch,copied what was missing and wuolia smile

What did you do to fix this?

I don't want to use ff 3.5 yet. My system is up-to-date except these two packages >>

I have firefox-3.0.11-1 & xulrunner-1.9.0.11-1

Offline

#10 2009-07-27 16:45:40

NeekO
Member
Registered: 2007-10-28
Posts: 32

Re: [SOLVED] Firefox XPCOM

Well the thing is, when i started getting this error, i tryed launching xulrunner itself and got error about some *.so files missing ( can't remember exactly which ones, it was along time ago ). So i just found a rpm package of xulrunner version i was using at that time (1.9.0.9 or smth like it), extracted it and copyied missing *.so files to xulrunner's dir smile To tell you the truth, i think i remember that those missing files where actually in the original dir, but somehow xulrunner just couldn't make a use of them, so as i said, replacing them worked like a charm for me.. I hope it helps you too...


Oh Snap!!

Offline

#11 2009-07-27 17:30:50

coda
Member
Registered: 2008-08-21
Posts: 36

Re: [SOLVED] Firefox XPCOM

Thanks for the reply, I'll try that out.

Offline

#12 2009-07-29 18:06:36

algorythm
Member
From: /usr/share/zoneinfo/Europe/FIN
Registered: 2009-07-17
Posts: 178

Re: [SOLVED] Firefox XPCOM

You guys don't read. Simple reinstallation of xulrunner would have worked.


PC: ASUS Maximus VIII Hero, Intel i7-6700K (4.6 GHz OC), NZXT Kraken X61, 16GB G.Skill DDR4-3200, MSI GTX 1080 Gaming X, Samsung 850 Pro 512GB, WD Black 6TB, Corsair Graphite 780T (Full Tower), be quiet! Dark Power Pro 11 650W (Platinum)
OS: Arch 64-bit / Windows 10 Pro 64-bit
Other: Dell UltraSharp 2560x1440 27", KB: Logitech G910, M: Logitech G502, HS: HyperX Cloud II, I: 100/10M

Offline

#13 2009-07-29 20:22:12

coda
Member
Registered: 2008-08-21
Posts: 36

Re: [SOLVED] Firefox XPCOM

algorythm wrote:

You guys don't read. Simple reinstallation of xulrunner would have worked.

I read your posts telling us to reinstall, I've tried that, It might of worked for you it hasn't worked for me. I don't know why, Maybe you do, If so do tell, Posting reinstall three times isn't very helpful.

EDIT#1

OK had a look at this today, libjpeg.so.62 was the file missing. I made a backup of it before upgrading. Then copied it into /usr/lib/libjpeg.so.62

Now I don't get the XPCOM error, Not sure if thats a good way to fix it long term, But it works for now.

Last edited by coda (2009-07-30 21:37:34)

Offline

#14 2009-08-01 12:41:32

NeekO
Member
Registered: 2007-10-28
Posts: 32

Re: [SOLVED] Firefox XPCOM

algorythm wrote:

You guys don't read. Simple reinstallation of xulrunner would have worked.

It never worked for me. Replacing missing *.so did the trick. As Coda said i too don't know if it's a good way to deal with such problems, but as long as it works i'm fine with it smile


Oh Snap!!

Offline

#15 2011-03-02 23:45:20

Sarmacid
Member
Registered: 2010-09-13
Posts: 7

Re: [SOLVED] Firefox XPCOM

This just happened to me. Hadn't updated Firefox in a while and after updating I was getting Couldn't load XPCOM error.

Had to update libevent and sqlite for it to work.

Offline

#16 2011-05-29 18:17:54

Angel_LB
Member
From: /Canada/Quebec
Registered: 2007-02-03
Posts: 12

Re: [SOLVED] Firefox XPCOM

Just had the same problem, with xulrunner 2.0.1-1 and Firefox 4.0.1-1.
With a little digging...:

xulrunner
/usr/lib/xulrunner-2.0/xulrunner-bin: /usr/lib/libnss3.so: version `NSS_3.12.9' not found (required by /usr/lib/xulrunner-2.0/libxul.so)

Looking up NSS, I found out...

pacman -Ss nss
extra/nss 3.12.10-1 [1.37 MB] [installed: 3.12.8-1]
    Mozilla Network Security Services

After patching NSS (and nspr as it's a dependency) it worked.

So, re-installing ain't always the solution, looking up the problem is.  Thanks NeekO for mentioning running xulrunner on it's own, helped me solve the issue as well.

Offline

#17 2011-06-19 10:27:54

unexist
Member
From: Germany
Registered: 2008-05-13
Posts: 300
Website

Re: [SOLVED] Firefox XPCOM

Angel_LB wrote:

So, re-installing ain't always the solution, looking up the problem is.  Thanks NeekO for mentioning running xulrunner on it's own, helped me solve the issue as well.

Older thread, but just starting xulrunner helped me to track the error down, too. Thanks. smile

Offline

Board footer

Powered by FluxBB