You are not logged in.

#1 2009-03-03 05:12:51

aegis
Member
Registered: 2008-11-13
Posts: 18

Adobe Air Support

Hi all,

The adobe-air package in AUR is broken...  It looks like Adobe is only supporting rpm and deb based Linux packages.  So does that mean we have to switch to Ubuntu to actually get to use the software based on adobe-air?

Last edited by aegis (2009-03-03 05:13:26)

Offline

#2 2009-03-03 05:26:43

neotuli
Lazy Developer
From: San Francisco, CA
Registered: 2004-07-06
Posts: 1,201
Website

Re: Adobe Air Support

no. it just means you have to write a pkgbuild that extracts the rpm and tarballs it instead. it's been done before.... here's an example: http://aur.archlinux.org/packages.php?ID=14977


The suggestion box only accepts patches.

Offline

#3 2009-03-04 01:12:46

aegis
Member
Registered: 2008-11-13
Posts: 18

Re: Adobe Air Support

neotull, thanks for the reply...  I got Adobe AIR installed from source without doing any pkgbuilds.  I followed the directions found here: http://www.flashinthepan.ca/computer-ti … ntoo-linux

The only problem I had with the last line where you actually run the AIR app...  the last part of the /opt/AIR-DSK/bin/adl line had to be the same root directory in which the application.xml is held.  So, for me, it was /opt/AIR-apps/tweetdeck ...  if you simply put /opt/tweetdeck it would fail with a "initial contect not found" error.

I've got a few AIR apps installed already...  Thanks again.

Offline

#4 2009-04-17 11:51:58

cu3edweb
Member
From: USA
Registered: 2007-10-07
Posts: 291

Re: Adobe Air Support

I got adobe air apps running a few weeks ago but I can't remember the exact process. I used this link:

http://www.flashinthepan.ca/computer-ti … ntoo-linux

Hope that helps

Offline

#5 2009-04-26 07:47:37

xodeus
Member
From: Fredericia, Denmark
Registered: 2009-01-20
Posts: 12
Website

Re: Adobe Air Support

I can tell that it helped sort of for me. But I can't fully run those apps.
When running tweetdeck I only get a gery window with the icons on top.
In the Terminal I get this info:

[mariusz@suedox ~]$ adobe-air/AIR-SDK/bin/adl -nodebug adobe-air/app/META-INF/AIR/application.xml adobe-air/app
I/O warning : failed to load external entity "/etc/opt/Adobe/certificates/crypt//config.xml"
Unable to parse Document: /etc/opt/Adobe/certificates/crypt//config.xml. 
Unknown desktop manager, only Gnome and KDE are supported
.Error: EncryptedLocalStore database access error

Adn see screenshots:
The Tweetdeck window: http://img10.imageshack.us/img10/6269/tweetdeck.png
Tweetdeck Terminal info: http://img10.imageshack.us/img10/7886/tweetdeckterm.png

Can anyone please help?

Offline

#6 2009-04-26 16:19:30

Cheesebaron
Member
From: Denmark
Registered: 2008-10-31
Posts: 65
Website

Re: Adobe Air Support

As it looks now it's not able to run without Gnome or KDE. I searched the web for solutions, but it seems that there are none. Though in XFCE, in the Session and Startup manager, try enable loading of either KDE or Gnome services on startup and see if that helps. If not theres nothing else to do than wait for Adobe to make a version that runs on any GTK/QT based WM/DE.

Offline

#7 2009-04-27 10:40:40

xodeus
Member
From: Fredericia, Denmark
Registered: 2009-01-20
Posts: 12
Website

Re: Adobe Air Support

So I've to run either KDE or Gnome, or are there any other fixes or workarounds?

Offline

#8 2009-04-27 12:59:40

Spider.007
Member
Registered: 2004-06-20
Posts: 1,156

Re: Adobe Air Support

What is broken about the AUR version?

Offline

#9 2009-04-27 17:15:47

xodeus
Member
From: Fredericia, Denmark
Registered: 2009-01-20
Posts: 12
Website

Re: Adobe Air Support

I don't think that something is broken. Just can't get tweetdeck or DestroyTweeter to work.

Offline

#10 2010-02-27 20:54:35

jpt
Member
From: Rochester, NY
Registered: 2008-04-28
Posts: 31
Website

Re: Adobe Air Support

I've had the same problem.  Neither will start hmm

Offline

#11 2010-03-16 10:53:42

cool
Member
Registered: 2008-09-12
Posts: 111
Website

Re: Adobe Air Support

The AUR package is not being updated since Sep,2009 and is flagged out of date. there is a newer version also available. it seems that the original maintainer is no longer interested.

32bit - http://aur.archlinux.org/packages.php?ID=16940
64bit - http://aur.archlinux.org/packages.php?ID=23330

I think these packages should be orphaned, so other people could maintain it.

Last edited by cool (2010-03-16 10:56:32)

Offline

#12 2010-06-29 09:13:34

Spider.007
Member
Registered: 2004-06-20
Posts: 1,156

Re: Adobe Air Support

cool wrote:

The AUR package is not being updated since Sep,2009 and is flagged out of date. there is a newer version also available. it seems that the original maintainer is no longer interested.

32bit - http://aur.archlinux.org/packages.php?ID=16940
64bit - http://aur.archlinux.org/packages.php?ID=23330

I think these packages should be orphaned, so other people could maintain it.

I spend quite a few hours trying to create a better, updated package, but that is quite hard.  Anyone having an updated PKGBUILD is welcome to post it and I will gladly update the package

Offline

#13 2010-06-29 09:50:50

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Adobe Air Support

Moved to AUR sub-forum.

Offline

Board footer

Powered by FluxBB