You are not logged in.

#1 2009-03-07 10:41:06

ohc
Member
Registered: 2008-04-24
Posts: 2

Xorg 1.6 uprade experience (from testing)

Just thought someone here might be interested in my upgrade experience.....

When I first tried to upgrade I got the following problem.

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: xorg-server conflicts with catalyst-utils. Remove catalyst-utils? [Y/n] 
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-screensaver: requires libgl
:: mesa: requires libgl
:: xorg-server: requires libgl
:: capseo: requires libgl
:: catalyst: requires catalyst-utils>=9.2
:: mplayer: requires libgl
:: xine-lib: requires libgl
:: xmms: requires libgl

So after a bit searching (and a bit of thought) I did

pacman -Rns catalyst

and this to force the catalyst-utils removal

pacman -Rnsf catalysts-utils

I then installed the libgl package, to replace the one removed from catalyst-utils

pacman -S libgl

And then tried to upgrade xorg again and got the next problem.

xorg-server: /usr/lib/xorg/modules/extensions/libdri.so exists in filesystem
xorg-server: /usr/lib/xorg/modules/libwfb.so exists in filesystem

So I deleted those files and was able to complete the upgrade successfully. However the I couldn't use the catalyst drivers (haven't investigated AUR yet), so I'm using the xorg driver at the moment. And for most of what I do that may be enough.

But I might look into either the radeonhd driver or catalyst from AUR, time will tell.

Cheers

ohc

Offline

#2 2009-03-07 10:59:36

Arkane
Member
From: Switzerland
Registered: 2008-02-18
Posts: 263

Re: Xorg 1.6 uprade experience (from testing)

Catalyst has no support for Xorg 1.6 yet, and this time the devs decided not to wait for it.

As for the file conflict problem, it's mentioned here, which would also have been a better place to post about your experience.

Last edited by Arkane (2009-03-07 11:02:35)


What does not kill you will hurt a lot.

Offline

#3 2009-03-09 22:22:17

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Xorg 1.6 uprade experience (from testing)

Arkane wrote:

Catalyst has no support for Xorg 1.6 yet, and this time the devs decided not to wait for it.

As for the file conflict problem, it's mentioned here, which would also have been a better place to post about your experience.

Exactly.
Closing this thread to avoid duplicates..

Offline

Board footer

Powered by FluxBB