You are not logged in.

#1 2004-09-10 21:54:57

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Has Anyone Got Audacity To Work?

I just installed the updated Audacity package and I keep getting a "Can't Access Audio Layer" message at program startup.

Anyone have a suggestion on how to fix this?

Lee

Offline

#2 2004-09-10 22:11:58

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Has Anyone Got Audacity To Work?

I get that error when I open it while I'm using the audio server.
You should turn off any program that uses your sound card including arts or esd.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#3 2004-09-11 00:01:56

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

I already tried that and it still gives the same message on startup.

This is a puzzler...:)

Thanks for the reply...:)

Lee

Offline

#4 2004-09-11 00:18:01

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Has Anyone Got Audacity To Work?

Maybe you should configure it first, so that it uses alsa an not oss.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#5 2004-09-11 00:33:50

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

When you say:

"Maybe you should configure it first, so that it uses alsa an not oss."

Are you talking about KDE or are you talking about Audacity?

Happy Friday...:)

Lee

Offline

#6 2004-09-11 00:38:11

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Has Anyone Got Audacity To Work?

About audacity... in it's "preferences" thing. (File --> Preferences)


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#7 2004-09-11 01:17:38

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

You Must Be Seeing Something I'm missing cause I've gone through every item in the Preferences setup and Nowhere do I find any reference to alsa/oss.

If you know of one please enlighten me...:)

Cheers

Lee

Offline

#8 2004-09-11 02:15:53

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Has Anyone Got Audacity To Work?

You are right, there's no alsa/oss. Don't know... it works for me


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#9 2004-09-11 02:33:05

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 226

Re: Has Anyone Got Audacity To Work?

Hello Folks,

I am helping Lee in our Audacity issues. I'm the one that got him ported over to Arch from SuSE. We are both running Arch 0.7 beta, with the latest updates.

X.org, not XFree, and KDE 3.3, not 3.2.3. Kernel 2.6.8.1

As a test, I modified my own .xinitrc and only started twm. Then rebooted to ensure nothing was running.

Audacity reports the same error on my system as it does Lee's same on my daughter's PC, and also on my laptop.

Stopping arts doesn't help either...

The only thing I can think of at this moment is to download the source, and compile it to use the port-19 switch so it uses the experimental alsa, instead of OSS.....

And yes. we have all installed alsa-oss.

It's a tad of a mystery to me, and I'm not a Linux noob....

And BTW: We all LOVE Arch... We've recently ported from SuSE, and the performance is phenominal, so please don't take this issue as a flame or as hostile, or as a complaint...

It's NOT!   big_smile

This is a great distro!... We're just trying to get to the bottom of this one....... :?:

Sincerely and Respectfully,


Dave Babb

Offline

#10 2004-09-12 19:30:30

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

Just to update - Both Dave Babb and I had the same probelem running audacity. We both downloaded the source - and compiled it using the port19 switch and in Dave's case that did the trick. Audacity is now up and running on his system. I unfortunately am still having a problem.
Audacity now loads ok and I can set the preferences and they now save. but when I go to play an exiting file or record a new file I get this error:

"Error while opening sound device. Please check the input device settings and the project sample rate."

Needless to say I've done this and everything looks ok - at this point I'm running out of options.

Anyone have any suggestions on how to fix this?

Cheers

Lee

Offline

#11 2004-09-13 05:32:33

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Has Anyone Got Audacity To Work?

What type of sound card do you have?  What programs and sound servers are you running?

My guess is that something else has taken your sound card and the sound driver won't let more than one thing use it at a time.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#12 2004-09-13 14:20:43

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

Xentac,

hwd and lspci identifies my soundcard as a Ensoniq ES1371 AudioPCI-97 (rev 08). I'm using alsa instead of oss - (all my other sound applications work flawlessly) - and except for KDE there is nothing else running when I try to use audacity and get the errors.

Cheers

Lee

Offline

#13 2004-09-13 16:25:04

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: Has Anyone Got Audacity To Work?

maybe you should try running it on other window manager/desktop, as kde uses arts, and starts it along with other daemons it needs when you login.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#14 2004-09-13 22:50:53

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 226

Re: Has Anyone Got Audacity To Work?

Hello,

This is Dave.

In a previous post, it was mentioned that we had modified out .xinitrc files to use twm as window manager, and then performed a reboot (from bad old habits).

Under twm, audacity still refuses to access the sound card...

Although on my system, under KDE and aRts (set to sleep after 5 seconds), a recompile using the v19 switch, it works perfectly. I walked Lee (over the phone) through the same procedure on his system.... and he's still stuck.

I also agree and suspect we're having an issue specific to Lee's particular sound driver as well................

And yes, I've had Lee pacman in the alsa-utils and alsa-oss packages into his system.

I think as long as Audacity isn't updated to use the newer "standard", which is ALSA, we may be fighting a driver issue, and a loosing battle. Lets switch the direction of this series of posts.

I mean, I've been building a lot of kernels for a long time now, and the kernel configs warn that OSS is depreciated.

Instead of fighting this issue (which may be deeper than we all really want to go), lets focus on making a recomendation of a replacement app with the functionality of Audacity for Lee....

Lee, do you agree?


Dave................

Offline

#15 2004-09-13 23:04:07

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: Has Anyone Got Audacity To Work?

Dave,

At this point I'm wide open to suggestions about other linux audio apps.  Hopefully with simular features.

I've used Audacity for a long time but if the developers keep flogging a dead horse (by continuing to ignore the oss/alsa issue) I don't feel that I can continue to support the app.

So - Has anyone had any good experiences with other linux audio apps that they'd like to pass along?

Cheers

Lee

Offline

Board footer

Powered by FluxBB