You are not logged in.

#1 2009-03-30 22:53:07

raul_nds
Member
From: Lisbon, Portugal
Registered: 2007-06-28
Posts: 258

arora 0.6 doesn't match Qt theme

Maybe it isn't being compiled to the same Qt version? I'm using the latest Qt from [testing]

Offline

#2 2009-03-30 23:28:02

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Offline

#3 2009-03-31 08:02:01

bender02
Member
From: Germany
Registered: 2007-02-04
Posts: 1,328

Re: arora 0.6 doesn't match Qt theme

I had the impression that they had some problems with the oxygen theme/engine, so that's their solution.

Offline

#4 2009-03-31 11:18:26

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: arora 0.6 doesn't match Qt theme

Yeah.
From the commit Pierre linked:

" - KDE's 4.2's Oxygen style has too many issues with Qt 4.5 features that Arora uses and while many of the issues have been fixed for KDE 4.3, KDE 4.2 users get a really ugly Arora."
"Once KDE 4.3 is released this check will be removed."
"If you are still want to use Oxygen add the arguments -style oxygen on the command line."

Last edited by Ranguvar (2009-04-02 20:16:37)

Offline

#5 2009-03-31 14:51:05

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: arora 0.6 doesn't match Qt theme

FYI, QtCurve looks okay on Arora 0.6

Offline

#6 2009-03-31 21:15:32

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

sorry for going OT , but has someone managed   to see flash working in arora? I can't! :-(

Offline

#7 2009-04-01 17:23:02

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: arora 0.6 doesn't match Qt theme

mangus wrote:

sorry for going OT , but has someone managed   to see flash working in arora? I can't! :-(

Yeah flash+arora works fine with Qt version >= 4.5.
First thing I would do is check to see if you are running Qt 4.4, if so,  that's the problem.

Last edited by dalingrin (2009-04-01 17:23:25)

Offline

#8 2009-04-01 21:14:07

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

dalingrin wrote:
mangus wrote:

sorry for going OT , but has someone managed   to see flash working in arora? I can't! :-(

Yeah flash+arora works fine with Qt version >= 4.5.
First thing I would do is check to see if you are running Qt 4.4, if so,  that's the problem.

No way! I run qt 4.5 (provided by kdemod) and I recompile arora , just in case, but still I get a grey box
instead of flash on youtube..I have no clue yikes

Offline

#9 2009-04-01 21:19:50

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 554

Re: arora 0.6 doesn't match Qt theme

mangus wrote:
dalingrin wrote:
mangus wrote:

sorry for going OT , but has someone managed   to see flash working in arora? I can't! :-(

Yeah flash+arora works fine with Qt version >= 4.5.
First thing I would do is check to see if you are running Qt 4.4, if so,  that's the problem.

No way! I run qt 4.5 (provided by kdemod) and I recompile arora , just in case, but still I get a grey box
instead of flash on youtube..I have no clue yikes

What flash are you running?

I'm using Flash straight off the repo, and everything works fine on Arch64/KDEmod stable on Arora

Offline

#10 2009-04-01 22:05:01

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

 
┌─[mangus@tao][23:47]
└─[~]-> pacman -Q flashplugin
flashplugin 10.0.22.87-1

Do I miss something in my install? I'm on i686 for what is worth..until it's supported! tongue

Offline

#11 2009-04-01 22:08:43

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 554

Re: arora 0.6 doesn't match Qt theme

mangus wrote:
 
┌─[mangus@tao][23:47]
└─[~]-> pacman -Q flashplugin
flashplugin 10.0.22.87-1

Do I miss something in my install? I'm on i686 for what is worth..until it's supported! tongue

Same flash here neutral

Are you certain you're running Qt from the KDEmod repos?  If you are, that is probably your problem.  You shouldn't be-you should be running Qt4.5 from Extra...the last Qtmod was 4.4.3-2.

Last edited by Skripka (2009-04-01 22:09:03)

Offline

#12 2009-04-01 23:49:47

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: arora 0.6 doesn't match Qt theme

AFAIK Skripka is right.
I have kdemod + qt4.5 from arch repos

Verify your Qt version by running:
qmake -v

Offline

#13 2009-04-02 09:21:02

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

 
┌─[mangus@tao][11:15]
└─[~]-> qmake -v
QMake version 2.01a
Using Qt version 4.5.0 in /usr/lib

┌─[mangus@tao][11:15]
└─[~/godO]-> pacman -Qi qtmod
Nome           : qtmod
Versione       : 4.5.0-3
URL            : http://www.trolltech.com/products/qt
Licenze        : LGPL
Gruppi         : kdemod  kdemod-complete  kdemod-uninstall  kdemod-minimal
Fornisce       : qt4=4.5.0  qt=4.5.0
Dipende da     : libpng  libxi  mesa  fontconfig  libxrandr  glib2  libtiff  libmng  sqlite3  dbus  libxcursor  libxinerama
Dip. opzionali : postgresql-libs: PostgreSQL support
                 libmysqlclient: MySQL support
                 unixodbc: unixODBC support
                 gconf: qgtkstyle theme support for GTK
Richiesto da   : akonadi  antico-git  automoc4  google-earth  kdemod-google-gadgets-qt  kdemod-kde-common  kdemod-kdelibs
                 kdemod-playground-konversation-kde4-svn  kdemod-shaman  keepassx  mixxx  opera-dev-qt4  phonon  polkit-qt
                 poppler-qt  pyqt  qca  qimageblitz  qmc2  qscintilla  qtmod-tools  qtscriptgenerator  sir  skype  smile
                 smplayer  soprano  strigi  traverso  unetbootin
Conflitti con  : qt4  qt
Sostituisce    : Nessuno
Kb richiesti   : 81832,00 K
Autore         : Unknown Packager
Architettura   : i686
Creato il      : sab 28 mar 2009 19:43:32 CET
Installato il  : mer 01 apr 2009 20:53:38 CEST
Motivo         : Installato esplicitamente
Script install : Si
Descrizione    : A cross-platform application and UI framework - Base libraries and tools

kdemod uses now it's own qtmod package again , it's in kdemod-core repo.
Probably I'll have to check in their forum, I really don't know...

Offline

#14 2009-04-02 15:28:14

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: arora 0.6 doesn't match Qt theme

Just to test, I suggest building your own copy from git. Its very easy.
Run:

git clone git://github.com/Arora/arora.git
cd arora
qmake "CONGIG-=debug" -r
make

See if you get the same results.
Fyi, Arora from git has "click to flash" enabled by default (just like flashblock in firefox)

Offline

#15 2009-04-02 20:10:00

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

dalingrin wrote:

Just to test, I suggest building your own copy from git. Its very easy.
Run:

git clone git://github.com/Arora/arora.git
cd arora
qmake "CONGIG-=debug" -r
make

See if you get the same results.
Fyi, Arora from git has "click to flash" enabled by default (just like flashblock in firefox)

following the git compilation I got a brand new git version of arora , but still it doesn't work...
but thanks to that debug option I got some hints on what's going on..

┌─[mangus@tao][22:03]
└─[~/arora]-> ./arora
Oxygen style has been detected, loading Plastique style.
 - KDE's 4.2's Oxygen style has too many issues with Qt 4.5 features that Arora uses and while many of the issues have been fixed for KDE 4.3, KDE 4.2 users get a really ugly Arora. Once KDE 4.3 is released this check will be removed. If you are still want to use Oxygen add the arguments -style oxygen on the command line.
Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to call gtk_init(0,0);

(<unknown>:3536): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

it's funny how a qt based browser fails on some gtk issue lol
I know , the issue is the flash player that has some problem with my gtk installation..maybe something about the theme , I'll try with a clean user
thanks

Offline

#16 2009-04-02 20:34:34

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: arora 0.6 doesn't match Qt theme

Do you have gtk installed at all? Flash might need it..

Offline

#17 2009-04-02 21:43:19

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: arora 0.6 doesn't match Qt theme

Ranguvar wrote:

Do you have gtk installed at all? Flash might need it..

sadly , yes...:D
btw arora and flash is working with a fresh user , so the problem is probably somewhere between the gtk theme
I use and gtk-qt-engine may be..I wonder why it's only me..doh!

Last edited by mangus (2009-04-02 21:46:09)

Offline

#18 2009-04-02 22:10:32

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: arora 0.6 doesn't match Qt theme

mangus wrote:
Ranguvar wrote:

Do you have gtk installed at all? Flash might need it..

sadly , yes...:D
btw arora and flash is working with a fresh user , so the problem is probably somewhere between the gtk theme
I use and gtk-qt-engine may be..I wonder why it's only me..doh!

Good to hear you're at least making progress now wink

Offline

Board footer

Powered by FluxBB