You are not logged in.

#1 2009-04-08 21:32:50

darenw
Member
From: Portland Oregon
Registered: 2008-07-04
Posts: 79
Website

Kernel reboots right after "Probing EDD"

When booting, the kernel starts to initialize but right after "Probing EDD" it fails, rebooting instead.  If i use the kernel option "edd=off" the "Probing EDD" line doesn't show, but still the kernel reboots at that point.  I'm convinced this is not an EDD-related problem, but trouble with whatever comes next.  FWIW, some googling turned up the idea of trying "hpet=disable" but that made no difference. Tried loading the alternate kernel, got same thing.

What should the kernel be printing after "Probing EDD"?


Potential suspects for the original cause of this problem: i updated with pacman -Syu two days ago which provided a new kernel (2.6.29?), and i've been fiddling with trying to get sound to work again.  Maybe i screwed up the kernel modules or some file in /etc/modules.d/.   Though this is a laptop, i turn it off only rarely.  It's a Gateway 6860FX.


Artist/Physicist, Herder of Pixels, Photons and Electrons

Offline

#2 2009-04-09 06:06:13

darenw
Member
From: Portland Oregon
Registered: 2008-07-04
Posts: 79
Website

Re: Kernel reboots right after "Probing EDD"

SOLVED!   Problem was the need to run lilo after pacman had upgraded the kernel.   

This took a while to figure out - without being able to boot so far as initializing the kernel, a live CD was necessary. Unfortunately the only ones i had were 32-bit distros.  But eventually I managed to run a compatible lilo and thereafter the same kernel boots fine.


Artist/Physicist, Herder of Pixels, Photons and Electrons

Offline

#3 2009-04-09 06:08:37

darenw
Member
From: Portland Oregon
Registered: 2008-07-04
Posts: 79
Website

Re: Kernel reboots right after "Probing EDD"

BTW, from examining the linux source, the next thing after "Probe EDD" is to set the vga mode. Only after that does the kernel print anything that will show up on dmesg or log files.


Artist/Physicist, Herder of Pixels, Photons and Electrons

Offline

#4 2009-06-23 05:15:04

enito
Member
Registered: 2009-02-17
Posts: 50

Re: Kernel reboots right after "Probing EDD"

Hi i have the same trouble of EDD and reboot, only way for fix (this happen when the last kernel upgrades) is go to arch, and make again the pacman -S kernel26. My fstab is

#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

#/dev/cdrom             /media/cd   auto    ro,user,noauto,unhide   0      0
#/dev/dvd               /media/dvd  auto    ro,user,noauto,unhide   0      0
#/dev/dvd2               /media/dvd1  auto    ro,user,noauto,unhide   0      0
#/dev/fd0               /media/fl   auto    user,noauto             0      0

#hds

UUID=5a4ea1d2-287a-48b8-b50c-65a59b1d7ed8 / jfs noatime,defaults 0 1
UUID=87b857ca-275f-4bc4-b48a-72eee660e7f0 swap swap defaults 0 0
UUID=9c1d25b0-6f2a-47c3-aaea-42f12e81a4a2 /home ext4 noatime,barrier=0,defaults 0 1
UUID=41eccea1-fb78-4727-b788-5878698cfcba /mnt/disk ext3 defaults 0 1
UUID=e0b55c91-8614-4dd6-862b-c1635c2158b3 /mnt/disk2 reiserfs defaults 0 1
UUID=decca5e5-88b1-43ea-a9dc-63c384c86cc5 /mnt/disk3 ext3 defaults 0 1
UUID=49f202c3-7b86-4a10-8535-85783a30b9f1 /Movies reiserfs defaults 0 1


and, menu.lst:


and # (0) Arch Linux
title  Arch Linux
root   (hd0,0)
kernel /boot/vmlinuz26 root=/dev/sda1 elevator=deadline
initrd /boot/kernel26.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,0)
kernel /boot/vmlinuz26 edd=off root=/dev/disk/by-uuid/5a4ea1d2-287a-48b8-b50c-65a59b1d7ed8 ro
initrd /boot/kernel26-fallback.img

# (2) Windows
#title Windows
#rootnoverify (hd0,0)
#makeactive
#chainloader +1

any tip, is really welcomed..thx!!

Last edited by enito (2009-06-23 05:15:53)

Offline

Board footer

Powered by FluxBB