You are not logged in.

#1 2009-04-15 14:18:57

Llama
Banned
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

Module fbdev not found[SOLVED]

Hi,

I've got installed xorg and xf86-video-intel, as appropriate (Intel GM965 video card). xorg.conf is absent, as it should. KDE (kdm) won't start at all; startx shows a normal test pattern, mouse (touchpad) working, keyboard working, including arrows, but it wont react on Ctrl-Alt-Backspace. In terminal (Ctrl-Alt-F1) I see the error "(EE) Failed to load module "fbdev" (module does not exist, 0)".

I've tried to put fbdev in rc.conf, section MODULES; sure enough, at boot I see the error "Module fbdev not found". How to make this module present?

BTW, the same xorg and the same xf86-video-intel on the same laptop worked just fine until today; I tried to get rid of KDEmod and install KDE big_smile ...

Last edited by Llama (2009-04-17 09:12:26)

Offline

#2 2009-04-15 14:31:48

Wra!th
Member
Registered: 2009-03-31
Posts: 342

Re: Module fbdev not found[SOLVED]

You need to explicitly install the fbdev video driver/module, not fbdev loadable kernel module(which you would load using rc.conf). That's driver X.org looks for with no config.
CTRL+ALT-Backspace is disabled by default in latest X.org
Add

Option "DontZap" "False"

to your xorg.conf "ServerFlags" section to get it back

Last edited by Wra!th (2009-04-15 14:32:54)


MacGregor DESPITE THEM!
7f 45 4c 46 01 01 01 00 00 00 00 00 00 00 00 00

Offline

#3 2009-04-15 15:05:23

Llama
Banned
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

Re: Module fbdev not found[SOLVED]

Wra!th wrote:

You need to explicitly install the fbdev video driver/module, not fbdev loadable kernel module(which you would load using rc.conf). That's driver X.org looks for with no config.

What package have I to install, then? One would think it's responsiblity of xorg package...

Offline

#4 2009-04-15 15:22:42

Llama
Banned
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

Re: Module fbdev not found[SOLVED]

pacman -S xf86-video-fbdev

But still I'm not happy smile :

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices

Last edited by Llama (2009-04-15 15:23:11)

Offline

#5 2009-04-15 15:55:53

Wra!th
Member
Registered: 2009-03-31
Posts: 342

Re: Module fbdev not found[SOLVED]

Llama wrote:

pacman -S xf86-video-fbdev

But still I'm not happy smile :

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices

WHY do you want to use fbdev as your video driver?! It's really REALLY slow!
Use vesa if you don't want any other driver, other than that just install and use a driver for your specific card
EDIT
I see you have an intel and you installed the intel driver. It's not enough to install the driver, you need to instruct X.org to use it. This is not windows smile
Just make a xorg.conf
"Xorg -configure" and "hwd -xa" (hwd is in AUR) can both do it for you, and edit the resulting xorg.conf, making it use the intel driver.

Last edited by Wra!th (2009-04-15 15:59:20)


MacGregor DESPITE THEM!
7f 45 4c 46 01 01 01 00 00 00 00 00 00 00 00 00

Offline

#6 2009-04-15 16:34:18

Llama
Banned
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

Re: Module fbdev not found[SOLVED]

Thanks! Did you ever read carefully the initial post, though?

BTW, the same xorg and the same xf86-video-intel on the same laptop worked just fine until today; I tried to get rid of KDEmod and install KDE

Something broke; the demand for fbdev is merely an artifact. I just want the intel video functionality back; It used to work yesterday, xorg and all, the same version on the same hardware. I've read the Wiki through and through; it seems absolutely foolproof. Nevertheless, I'm all the more at sea for it.

Last edited by Llama (2009-04-15 16:41:24)

Offline

#7 2009-04-15 19:14:12

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,028

Re: Module fbdev not found[SOLVED]

Llama wrote:

Thanks! Did you ever read carefully the initial post, though?

BTW, the same xorg and the same xf86-video-intel on the same laptop worked just fine until today; I tried to get rid of KDEmod and install KDE

Something broke; the demand for fbdev is merely an artifact. I just want the intel video functionality back; It used to work yesterday, xorg and all, the same version on the same hardware. I've read the Wiki through and through; it seems absolutely foolproof. Nevertheless, I'm all the more at sea for it.

ive got a similar graphics card, and im forced to have an xorg.conf file, otherwise x would not start.

create one with a device section setting up your intel graphics card. first try with EXA and kms disabled.

my device section looks like this:

Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    VendorName  "Intel Corporation"
    BoardName   "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
    BusID       "PCI:0:2:0"
    Option         "AccelMethod"    "EXA"
        Option      "MigrationHeuristic" "greedy"
    Option      "DRI"                    "True"
EndSection

i dont remember how i created xorg. the wiki should provide enough info on how to do it.

Offline

#8 2009-04-15 19:37:36

signor_rossi
Member
Registered: 2007-08-24
Posts: 257

Re: Module fbdev not found[SOLVED]

I created one with 'X -configure'. Don't forget to copy the config file over to '/etc/X11' or to specify it directly on startx.

Offline

#9 2009-04-17 09:11:06

Llama
Banned
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,379

Re: Module fbdev not found[SOLVED]

BTW, the same xorg and the same xf86-video-intel on the same laptop worked just fine until today; I tried to get rid of KDEmod and install KDE...

Sure... My only trouble was my own inability to remove KDEmod properly first. To whom it may concern smile :

# pacman -Rd kdemod-uninstall

As soon as startup sequence got as far as kdm, the absence of qt library, which didn't replace qtmod, felt tongue ...

Actually x86-video-intel can work without xorg.conf big_smile .

...

But the dreaded xorg error messages are not necessarily fatal smile (they are in place, just the same).

Last edited by Llama (2009-04-17 14:10:19)

Offline

#10 2010-12-08 04:17:41

blackcobra
Member
From: Ireland
Registered: 2010-12-07
Posts: 4

Re: Module fbdev not found[SOLVED]

pacman -S xf86-video-fbdev

hey, just like to thank you, did the trick for me!!


Dan

Offline

#11 2010-12-08 07:40:32

bgalakazam
Arch Linux f@h Team Member
From: California, USA
Registered: 2008-09-01
Posts: 76

Re: Module fbdev not found[SOLVED]

I am using Intel 950 with the Intel driver. I get the same error and I don't have xorg.conf file. I can start X and haven't seen any problems besides the error once I quit X.

Do I need to change anything? Everything seems to work.

Offline

#12 2010-12-08 09:47:33

Gusar
Member
Registered: 2009-08-25
Posts: 3,604

Re: Module fbdev not found[SOLVED]

No, you don't need to change anything. If the intel driver loads, that will be used. If you had problems with the intel driver and it didn't load, then the fbdev driver would get loaded as a fallback. Though I don't know if the fbdev X driver even works with KMS, so if you want a fallback driver, install xf86-video-vesa.

Offline

Board footer

Powered by FluxBB