You are not logged in.

#1 2009-04-18 17:38:02

Sarek23
Member
Registered: 2009-04-18
Posts: 5

Win-Key + awesome

Hi!

I just switched over to arch from ubuntu and wanted to try out that awesome window manager awesome. Unfortunately it seems that something with my X keymap is really messed up. For the past day and half I tried almost everything but I don't seem to be able to get that damn Win-Key on my laptop's keyboard running as a modifier.

First, I tried the naive approach to just fire up X with the evdev keyboard driver (so full auto-detection). That did not work. I then tried to setup my hal-policies so that I get the correct keyboard layout (de) and also played with other settings. I did not get it running.

I then tried switching off the whole evdev business and configure keyboard and mouse the old-school way by tweaking xorg.conf. That's what it looks like now:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "XkbLayout" "de"
    Option      "XkbVariant" "nodeadkeys"
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc104"
    Option      "XkbOptions" "altwin:left_meta_win"
EndSection

I tried it with the XkbOptions option and without, tried different XkbModels, still no success.

With xev I figured out that my Win-Key has the keycode 115, so I wrote myself a little .Xmodmaprc:

clear mod4
keycode 115 = Super_L
add mod4 = Super_L

which is loaded by xmodmap before starting awesome.
xmodmap also tells me, that my key bindings are correct:

[sarek@newton ~]$ xmodmap
xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x73),  Super_L (0x74),  Super_L (0x75),  Super_L (0x7f)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x71),  ISO_Level3_Shift (0x7c)

xev also reports that it recognizes me pressing the Win-Key and translating it to Super_L:

KeyPress event, serial 28, synthetic NO, window 0x1200001,
    root 0x79, subw 0x0, time 4223951, (544,-7), root:(545,444),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x1200001,
    root 0x79, subw 0x0, time 4224001, (544,-7), root:(545,444),
    state 0x40, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

For now, I don't have the slightest idea what I might do to make it work. Does anybody have any hints?

Offline

#2 2009-04-18 17:53:50

ap_
Member
From: Finland
Registered: 2008-10-14
Posts: 47

Re: Win-Key + awesome

I know this doesn't help much, but my Win-key didn't work with Awesome 3.2.1 either. It did work in 3.2, and also works fine with wmii, scrotwm and awesome 2.x, which I'm using ATM. So frustrating problem this one.

Last edited by ap_ (2009-04-18 17:54:23)

Offline

#3 2009-04-18 17:54:30

soupcan
Member
From: ?
Registered: 2008-10-25
Posts: 264

Re: Win-Key + awesome

Sarek23 wrote:

Hi!

I just switched over to arch from ubuntu and wanted to try out that awesome window manager awesome. Unfortunately it seems that something with my X keymap is really messed up. For the past day and half I tried almost everything but I don't seem to be able to get that damn Win-Key on my laptop's keyboard running as a modifier.

First, I tried the naive approach to just fire up X with the evdev keyboard driver (so full auto-detection). That did not work. I then tried to setup my hal-policies so that I get the correct keyboard layout (de) and also played with other settings. I did not get it running.

I then tried switching off the whole evdev business and configure keyboard and mouse the old-school way by tweaking xorg.conf. That's what it looks like now:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "XkbLayout" "de"
    Option      "XkbVariant" "nodeadkeys"
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc104"
    Option      "XkbOptions" "altwin:left_meta_win"
EndSection

I tried it with the XkbOptions option and without, tried different XkbModels, still no success.

With xev I figured out that my Win-Key has the keycode 115, so I wrote myself a little .Xmodmaprc:

clear mod4
keycode 115 = Super_L
add mod4 = Super_L

which is loaded by xmodmap before starting awesome.
xmodmap also tells me, that my key bindings are correct:

[sarek@newton ~]$ xmodmap
xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x73),  Super_L (0x74),  Super_L (0x75),  Super_L (0x7f)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x71),  ISO_Level3_Shift (0x7c)

xev also reports that it recognizes me pressing the Win-Key and translating it to Super_L:

KeyPress event, serial 28, synthetic NO, window 0x1200001,
    root 0x79, subw 0x0, time 4223951, (544,-7), root:(545,444),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x1200001,
    root 0x79, subw 0x0, time 4224001, (544,-7), root:(545,444),
    state 0x40, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

For now, I don't have the slightest idea what I might do to make it work. Does anybody have any hints?

After a recent update, my keyboard shortcuts in Awesome are no longer working. This may be related. See if your Super works in another WM.


Arch64/XFCE

Offline

#4 2009-04-18 21:41:03

Sarek23
Member
Registered: 2009-04-18
Posts: 5

Re: Win-Key + awesome

a little chatting in the awesome irc channel gave some new info:

apparently awesome 3.2.1 does not like the newest xcb - so either downgrade to an older xcb or wait for a new awesome version

Offline

#5 2009-04-19 19:58:32

jerryluc
Member
From: Trondheim, Norway
Registered: 2008-05-20
Posts: 95

Re: Win-Key + awesome

for now I've downgraded awesome > 3.2, startup-notification > 0.9-1, xcb-util > 0.3.3-1 and ignoring them in pacman.conf.

Offline

#6 2009-04-20 15:32:44

qubodup
Member
From: Berlin, Germany
Registered: 2008-01-19
Posts: 63
Website

Re: Win-Key + awesome

jerryluc wrote:

for now I've downgraded awesome > 3.2, startup-notification > 0.9-1, xcb-util > 0.3.3-1 and ignoring them in pacman.conf.

did the same. I feel like I re-grown a lost arm now that I have the mod key again.

Offline

#7 2009-04-20 17:15:19

lswest
Member
From: Munich, Germany
Registered: 2008-06-14
Posts: 455
Website

Re: Win-Key + awesome

Someone mentioned in this thread: http://bbs.archlinux.org/viewtopic.php?pid=539699 that the modkey seems to work again once numlock is shut off with the new awesome-git release (which would explain why the above worked on my laptop and not my PC, since I use the numpad on my PC, not my laptop, since it's a condensed keyboard).

Just thought I'd mention it in case it helps.

Last edited by lswest (2009-04-20 17:15:29)


Lswest <- the first letter of my username is a lowercase "L".
"...the Linux philosophy is "laugh in the face of danger". Oops. Wrong one. "Do it yourself". That's it." - Linus Torvalds

Offline

#8 2009-04-20 19:12:44

ap_
Member
From: Finland
Registered: 2008-10-14
Posts: 47

Re: Win-Key + awesome

Thank you! Finally I'm home with Aweome 3.x smile It was the numlock-thing that fixed it.

Offline

#9 2009-04-21 05:44:36

lswest
Member
From: Munich, Germany
Registered: 2008-06-14
Posts: 455
Website

Re: Win-Key + awesome

Glad it works!  Mine isn't working yet, but I'll keep playing around with it tongue


Lswest <- the first letter of my username is a lowercase "L".
"...the Linux philosophy is "laugh in the face of danger". Oops. Wrong one. "Do it yourself". That's it." - Linus Torvalds

Offline

#10 2009-04-21 14:49:57

jerryluc
Member
From: Trondheim, Norway
Registered: 2008-05-20
Posts: 95

Re: Win-Key + awesome

Is it fixed with the new release? awesome 3.2.1b-2

Offline

#11 2009-04-21 15:34:32

lswest
Member
From: Munich, Germany
Registered: 2008-06-14
Posts: 455
Website

Re: Win-Key + awesome

┌─[lswest@Monster:~]-[17:32:43 on 09-04-21]
└─> pacman -Q awesome-git
awesome-git 20090421-1
┌─[lswest@Monster:~]-[17:32:50 on 09-04-21]
└─> awesome -v
awesome v3.2-232-g37071c5 (Accidental Babies)
 • Build: Apr 21 2009 07:44:28 for x86_64 by gcc version 4.3.3 (lswest@Monster)
 • D-Bus support: ✔

The version of Awesome I'm using atm, works fine as long as numlock is disabled (otherwise modkey stops working).  No clue if it's the same as the 3.2.1b2, but you can always give it a try (and disable numlock if you have it active).


Lswest <- the first letter of my username is a lowercase "L".
"...the Linux philosophy is "laugh in the face of danger". Oops. Wrong one. "Do it yourself". That's it." - Linus Torvalds

Offline

#12 2009-05-21 00:11:12

sfauzia
Member
Registered: 2009-01-11
Posts: 88

Re: Win-Key + awesome

I'm having a similar problem with dwm; all of my acpi-configured Fn keys and xbindkeys configured keys work, but not the ones for applications and dwm (both of which use the Ctrl keys and Alt keys, respectively). This would happen every so often with hotplugging enabled, and with hotplugging disabled the modkey does not work at all. I don't use NumLock, but then again my problem is with dwm and not Awesome.

Last edited by sfauzia (2009-05-21 00:11:25)

Offline

Board footer

Powered by FluxBB