You are not logged in.

#1 2009-04-22 20:19:01

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,228
Website

conky font differences under Arch compared to Ubuntu [SOLVED]

I'm using the same basic .conkyrc when I'm booted into Arch as I do when I'm booted Ubuntu.  For some reason, the one under Ubuntu looks different font-wise.  In the screenshot below, Arch has the light blue background while Ubuntu has the slate colored one.  Anyone know what might be causing this?

screenshot2q.png

Here is the first part of the ~/.conkyrc

background no
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

out_to_console no

# X font when Xft is disabled, you can pick one with program xfontsel
#font 7x12
#font 6x10
#font 7x13
#font 8x13
#font 7x12
#font *mintsmild.se*
#font -*-*-*-*-*-*-34-*-*-*-*-*-*-*
#font -artwiz-snap-normal-r-normal-*-*-100-*-*-p-*-iso8859-1

# Use Xft?
use_xft yes

# Xft font when Xft is enabled
xftfont Bitstream Vera Sans Mono:size=8
#own_window_transparent no
#own_window_colour hotpink
# Text alpha when using Xft
xftalpha 0.8

on_bottom yes

# Update interval in seconds
update_interval 2
# Create own window instead of using desktop (required in nautilus)
#own_window no

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# Minimum size of text area
#minimum_size 250 5
maximum_width 258

# Draw shades?
draw_shades no

# Draw outlines?
draw_outline no

# Draw borders around text
draw_borders no

# Stippled borders?
stippled_borders 10

# border margins
border_margin 4

# border width
border_width 1

# Default colors and also border colors
default_color white
default_shade_color white
default_outline_color white

# Text alignment, other possible values are commented
#alignment top_left
#minimum_size 10 10
#alignment top_right
alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
gap_x 12
gap_y 37
# Add spaces to keep things from moving about?  This only affects certain objects.
use_spacer no

# Subtract file system buffers from used memory?
no_buffers yes

# set to yes if you want all text to be in uppercase
uppercase no

EDIT: the solution to this problem is described in post #12.

Last edited by graysky (2009-04-25 14:32:59)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2009-04-23 04:27:16

darthaxul
Member
Registered: 2008-09-24
Posts: 156

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

my guess is ur window manager colors might be different
diffrent distros use custom compiled features, hopefully since Arch is minimalistic, it has lower system-hogging tendancies.
beyond that, have u tried running it with the -o option

Offline

#3 2009-04-23 06:36:23

Ashren
Member
From: Denmark
Registered: 2007-06-13
Posts: 1,226
Website

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

Please check the output of "xdpyinfo | grep dots" it usually should be 96x96 dpi. My bet is that your dpi is wrong. If you're in KDE/Gnome you set the dpi in the DE. If you're using something else one solution is to add "xrandr --screen 0 --dpi 96x96" to your .xinitrc.

Offline

#4 2009-04-23 06:37:14

cb474
Member
Registered: 2009-04-04
Posts: 469

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

I don't know if this is related, but I've noticed that the fonts in gnome-terminal appear differently in Arch, from how they appear in Ubuntu and Debian (which are the same). Ubuntu and Debian also seem consistent with images I've seen on the Gnome website. So it seems like Arch is not using the default Gnome fonts exactly (assuming you're using Gnome). Although when I look at the font packages intalled they appear to be the same, between Arch and Debian. Anyway, I don't know what the answer to this is.

Last edited by cb474 (2009-04-23 06:37:49)

Offline

#5 2009-04-23 06:55:44

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,556

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

may be related to .fonts.conf settings.

Offline

#6 2009-04-23 14:16:58

SomeGuyDude
Member
Registered: 2008-10-09
Posts: 271

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

I think Arch is rendering the font correctly while Ubuntu isn't, ne?


And in the midst of such perfection,
I can't help but feel diseased.

Offline

#7 2009-04-23 15:14:24

thunderogg
Member
From: Rio de Janeiro
Registered: 2008-07-13
Posts: 172

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

Judging from your screenshot, the fonts look much better in Arch. Just look at how the characters are squeezed together in the Ubuntu shot, almost overlapping, specially the numbers. Stupid question: have you got the same fonts installed, and have you got the same font settings?

Last edited by thunderogg (2009-04-23 15:14:52)

Offline

#8 2009-04-23 15:32:28

alienman
Member
From: Mexico
Registered: 2008-07-08
Posts: 106

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

It seems like the fonts aren't the same in each screenshot. I think both distros are rendering the fonts OK but if they are the same, you should look at your preferences in fonts and watch if they are the same in the distros (same dpi; gray scale, best shape, best contrast, etc; same size; i don't know what else).

And I agree, the fonts look better in Arch that it does in Ubuntu for my taste, they look more readable to me.


ISC - Ignacio Marmolejo
ArchLinux & GNOME User.

Offline

#9 2009-04-23 18:35:01

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,228
Website

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

Ashren wrote:

Please check the output of "xdpyinfo | grep dots" it usually should be 96x96 dpi. My bet is that your dpi is wrong. If you're in KDE/Gnome you set the dpi in the DE. If you're using something else one solution is to add "xrandr --screen 0 --dpi 96x96" to your .xinitrc.

Here is the output:

$ xdpyinfo | grep dots
  resolution:    90x88 dots per inch

I'm using Gnome but can't seem to locate a section to change my dpi.  I'm using the nvidia driver (8800GS) but didn't see an area under nvidia-settings to change it either.  I tried that xrandr line you proposed, upon restarting gdm, the setting didn't take:

$ xdpyinfo | grep dots
  resolution:    90x88 dots per inch

Here is my ~/.xinitrc

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

exec gnome-session
xrandr --screen 0 --dpi 96x96

Thanks!

Last edited by graysky (2009-04-23 18:37:22)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#10 2009-04-23 19:02:22

rson451
Member
From: Annapolis, MD USA
Registered: 2007-04-15
Posts: 1,233
Website

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

You'll need to move xrandr above the exec in your .xinitrc or it will not be run before gnome starts.


archlinux - please read this and this — twice — then ask questions.
--
http://rsontech.net | http://github.com/rson

Offline

#11 2009-04-23 19:05:51

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,228
Website

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

rson451 wrote:

You'll need to move xrandr above the exec in your .xinitrc or it will not be run before gnome starts.

Cool... I found this dpi page on the wiki and added that Options "DPI" "96x96" line to my /etc/X11/xorg.conf and now when I restarted gdm, I get:

$ xdpyinfo | grep dots
  resolution:    96x96 dots per inch

The conky fonts still look the same though... hmm

Last edited by graysky (2009-04-23 22:00:38)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#12 2009-04-25 14:22:42

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,228
Website

Re: conky font differences under Arch compared to Ubuntu [SOLVED]

FINALLY: right-click desktop>change desktop background>fonts>details>Resolution

Resolution: [96] dots per inch

Mine was set to 89 dots per inch for some reason.  I upped it to 96 and everything looks 'normal' again.  Hope someone else finds this useful.

Last edited by graysky (2009-04-25 14:28:51)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB