You are not logged in.

#1 2009-05-02 13:41:50

Registered: 2007-07-17
Posts: 221

[SOLVED?] lost network after latest Syu

I did a pacman -Syu today and it seems to have broken my networking. I am unable to ping based on DNS name or IP address. DNS lookup is not working in browsers either. I'm not sure why, but programs are taking forever to load -- similar to what happens when you don't have this in your hosts file: localhost <hostname>

Any idea of what's going on? I'm stuck to where I can't -Syu as a result, but I have a feeling that it'd work if I put the IP of a server in the mirrorlist.

EDIT: Well, that's weird... If I use tor and privoxy, DNS resolving works perfectly. This may be related to my firewall/"modem" rather than my system.

EDIT2: Partially fixed it. The newest package of dnsutils (9.6.0.P1-2) seems to be broken. I reverted to 9.6.0.P1-1 and it's working a little better. There must be another package that's a little broken.

EDIT3: Looks like regular TCP connections work correctly now, but things like ping don't work. It'll resolve the IP address and then never go anywhere. Argh. I'm starting to think that this may have something to do with the netfilter stuff (iptables and such), but it's just a shot in the dark...

EDIT4: I should probably mention that this computer has a static IP, but the other DHCP machines are working.

EDIT5: It should also be noted that I am unable to install anything through yaourt, and pacman is hit-or-miss -- most often miss.

EDIT6: It looks like something broke iptables and/or its config when I -Syu-ed. I did a complete uninstall/reinstall of everything from netfilter, and it looks like my connection is back to normal.

Last edited by mrbug (2009-05-04 14:55:34)

dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)


Board footer

Powered by FluxBB