You are not logged in.

#1 2009-05-24 13:38:48

Elmaron
Member
Registered: 2009-05-02
Posts: 11

X crashes at every second startup

Hi. I'm on an Asus Eee PC 1000H with intel onboard graphics, using xf86-video-intel 2.7.1 for graphics. At maybe every second start of X, it crashes for me.
I am starting X using startx, which executes my local ~/.xinitrc. Here are the contents of .xinitrc:

sleep 5
setxkbmap de -variant deadacute
fluxbox&> /dev/null&
tilda&> /dev/null&
python eee-control-tray&> /dev/null&
rox --rox-session

The special thing about my X startup crashes is that it always happens after those 5 seconds I put in to make sure it truly is that way. This means it crashens when those programs startup. Here the detailed X log containing a backtrace:

X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.29-ARCH i686
Current Operating System: Linux arch 2.6.29-ARCH #1 SMP PREEMPT Sat May 9 12:47:43 UTC 2009 i686
Build Date: 15 April 2009  11:09:10AM

    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 24 12:34:02 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/100dpi").
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/75dpi").
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/100dpi").
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/share/fonts/75dpi").
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    /usr/share/fonts/misc,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x1a40
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@0:2:0) Intel Corporation Mobile 945GME Express Integrated Graphics Controller rev 3, Mem @ 0xf7f00000/524288, 0xd0000000/268435456, 0xf7ec0000/262144, I/O @ 0x0000dc00/8
(--) PCI: (0@0:2:1) Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller rev 3, Mem @ 0xf7f80000/524288
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(WW) "xtrap" will not be loaded unless you've specified it to be loaded elsewhere.
(WW) "record" will not be loaded unless you've specified it to be loaded elsewhere.
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "record" will be loaded even though the default is to disable it.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 2.7.1
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 5.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
    E7221 (i915), 915GM, 945G, 945GM, 945GME, IGD_GM, IGD_G, 965G, G35,
    965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    Mobile Intel® GM45 Express Chipset,
    Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41
(II) Primary Device is: PCI 00@00:02:0
(II) resource ranges after xf86ClaimFixedResources() call:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(II) resource ranges after probing:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] 0    0    0x000a0000 - 0x000affff (0x10000) MS[b]
    [5] 0    0    0x000b0000 - 0x000b7fff (0x8000) MS[b]
    [6] 0    0    0x000b8000 - 0x000bffff (0x8000) MS[b]
    [7] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [8] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
    [9] 0    0    0x000003b0 - 0x000003bb (0xc) IS[b]
    [10] 0    0    0x000003c0 - 0x000003df (0x20) IS[b]
(II) intel(0): Creating default Display subsection in Screen section
    "Screen0" for depth/fbbpp 24/32
(**) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) 945GME
(--) intel(0): Chipset: "945GME"
(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(II) intel(0): Resizable framebuffer: available (0 4)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 8, (OK)
drmOpenByBusid: drmOpenMinor returns 8
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) [drm] DRM interface version 1.3
(II) [drm] DRM open master succeeded.
(II) intel(0): Output VGA1 using monitor section Monitor0
(II) intel(0): Output LVDS1 has no monitor section
(II) intel(0): Output VGA1 disconnected
(II) intel(0): Output LVDS1 connected
(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output LVDS1 using initial mode 1024x600
(==) intel(0): video overlay key set to 0x101fe
(==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
(==) intel(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(==) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] 0    0    0x000a0000 - 0x000affff (0x10000) MS[b]
    [5] 0    0    0x000b0000 - 0x000b7fff (0x8000) MS[b]
    [6] 0    0    0x000b8000 - 0x000bffff (0x8000) MS[b]
    [7] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [8] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
    [9] 0    0    0x000003b0 - 0x000003bb (0xc) IS[b]
    [10] 0    0    0x000003c0 - 0x000003df (0x20) IS[b]
(II) intel(0): [DRI2] Setup complete
(**) intel(0): Kernel mode setting active, disabling FBC.
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 4194303 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): Tiled allocation successful.
(II) UXA(0): Driver registered support for the following operations:
(II)         solid
(II)         copy
(II)         composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): Fixed memory allocation layout:
(II) intel(0): 0x00000000-0xffff4fff: DRI memory manager (4194260 kB)
(II) intel(0): 0x00000000:            end of aperture
(II) intel(0): BO memory allocation layout:
(II) intel(0): 0x00000000:            start of memory manager
(II) intel(0): 0x00c00000-0x00ffffff: front buffer (4096 kB) X tiled
(II) intel(0): 0x00b00000-0x00b09fff: HW cursors (40 kB)
(II) intel(0): 0xffff5000:            end of memory manager
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(II) intel(0): DPMS enabled
(==) intel(0): Intel XvMC decoder disabled
(II) intel(0): Set up textured video
(II) intel(0): direct rendering: DRI2 Enabled
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/i915_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) intel(0): Setting screen physical size to 222 x 130
(II) config/hal: Adding input device Macintosh mouse button emulation
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
    compiled for 1.6.1, module version = 2.2.2
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 4.0
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) config/hal: Adding input device ETPS/2 Elantech Touchpad
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
    compiled for 1.6.0, module version = 1.1.0
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event10"
(II) ETPS/2 Elantech Touchpad: x-axis range 8 - 1144
(II) ETPS/2 Elantech Touchpad: y-axis range 8 - 760
(II) ETPS/2 Elantech Touchpad: device does not report pressure, will use touch data.
(II) ETPS/2 Elantech Touchpad: finger width range 0 - 0
(II) ETPS/2 Elantech Touchpad: buttons: left right middle double triple
(**) Option "TapButton1" "1"
(**) Option "TapButton2" "3"
(**) Option "TapButton3" "2"
(--) ETPS/2 Elantech Touchpad touchpad found
(**) ETPS/2 Elantech Touchpad: always reports core events
(II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD)
(**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
(**) ETPS/2 Elantech Touchpad: (accel) filter chain progression: 2.00
(**) ETPS/2 Elantech Touchpad: (accel) filter stage 0: 20.00 ms
(**) ETPS/2 Elantech Touchpad: (accel) set acceleration profile 0
(--) ETPS/2 Elantech Touchpad touchpad found
(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event9"
(II) Logitech USB-PS/2 Optical Mouse: Found 4 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
(**) Logitech USB-PS/2 Optical Mouse: (accel) filter chain progression: 2.00
(**) Logitech USB-PS/2 Optical Mouse: (accel) filter stage 0: 20.00 ms
(**) Logitech USB-PS/2 Optical Mouse: (accel) set acceleration profile 0
(II) config/hal: Adding input device Asus EeePC extra buttons
(**) Asus EeePC extra buttons: always reports core events
(**) Asus EeePC extra buttons: Device: "/dev/input/event8"
(II) Asus EeePC extra buttons: Found keys
(II) Asus EeePC extra buttons: Configuring as keyboard
(II) XINPUT: Adding extended input device "Asus EeePC extra buttons" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event6"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) AIGLX: Suspending AIGLX clients for VT switch
[xkb] BOGUS LENGTH in write keyboard desc, expected 5948, got 5964

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x813278b]
1: /usr/bin/X(xf86SigHandler+0x51) [0x80dda61]
2: [0xb8018400]
3: /lib/libc.so.6 [0xb7c33842]
4: /lib/libc.so.6(realloc+0x114) [0xb7c345a4]
5: /usr/bin/X(Xrealloc+0x32) [0x8136562]
6: /usr/bin/X(dixAllocatePrivate+0x103) [0x8072973]
7: /usr/bin/X(dixLookupPrivateAddr+0x44) [0x8072a94]
8: /usr/bin/X [0x817be2b]
9: /usr/bin/X [0x817cdff]
10: /usr/bin/X(CompositePicture+0x242) [0x816f172]
11: /usr/bin/X [0x8177476]
12: /usr/bin/X [0x8171cb5]
13: /usr/bin/X(Dispatch+0x33f) [0x808cd3f]
14: /usr/bin/X(main+0x3bd) [0x8071f3d]
15: /lib/libc.so.6(__libc_start_main+0xe6) [0xb7bda6b6]
16: /usr/bin/X [0x8071401]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

The very strange thing on this is that it doesn't happen always and mostly works for the second or sometimes third attempt without any trouble at all.

Offline

#2 2009-05-24 14:19:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: X crashes at every second startup

Have you read the wiki? I don't know you hardware so don't expect any eee-specific help.
Is that log from the crash? How does the good one look like?
Check your xorg.conf & rc.conf.

Let's try that .xinitrc w/ everything commented out because those lines may be causing problems and I'm not sure it's written properly. Just add xterm.

# sleep 5
# setxkbmap de -variant deadacute
# fluxbox&> /dev/null&
# tilda&> /dev/null&
# python eee-control-tray&> /dev/null&
# rox --rox-session
exec xterm

Have you tried it? If not, do it now.
Log into console, run 'startx' w/ everything you can disabled / commented out, so it doesn't interfere (xinitrc, xserverc etc.). Run as vanilla X as you can.

I've had similar problems w/ another distro. I don't know what caused them, maybe they were python-related, but it's just a wild guess.

Offline

#3 2009-05-26 09:54:12

Elmaron
Member
Registered: 2009-05-02
Posts: 11

Re: X crashes at every second startup

Have you tried it? If not, do it now.

I did indirectly by inserting 5 seconds which delays the crash with 5 seconds. An X log without crash looks pretty similar, just without the signal 11 part and the subsequent backtrace.
The problem is, if I comment those lines out my desktop is gone tongue (X without a proper desktop and taskbar is pretty unconvenient) and as the backtrace contains something related to composite pictures I guess it's a driver issue triggered accidentially by one of those programs at startup. I guess someone who knows X very well/an X developer should have a look at the backtrace and find out what is going wrong there...

Last edited by Elmaron (2009-05-26 09:56:04)

Offline

#4 2009-05-26 11:00:25

leo2501
Member
From: Buenos Aires, Argentina
Registered: 2007-07-07
Posts: 637

Re: X crashes at every second startup

the problem is with xorg 7.4 + the 945 intel graphics card... so stop looking for fixes... I tryed the fixes in a looot of thread in the arch and freebsd forums, tryed the accelmethods (XAA EXA UXA) and no xorg at all, KMS ON/OFF, all three drivers in the repos + AUR, and with different results, now im using the intel driver 2.7.1 and UXA, is the combination i found "less" problematic, the thing is that X starts 1 of 6 times of HARD LOCKUPS, so im looking for a way to downgrade all the Xorg related packages + intel driver

look at these threads for example...
http://bbs.archlinux.org/viewtopic.php?id=72715
http://bbs.archlinux.org/viewtopic.php?id=71703

other threads about it...
http://bbs.archlinux.org/viewtopic.php?pid=558149
http://bbs.archlinux.org/viewtopic.php?pid=554923
http://bbs.archlinux.org/viewtopic.php?id=72660

and for my surprise this is happening in freebsd too, because it's a Xorg driver issue

Last edited by leo2501 (2009-05-26 11:35:24)


Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
-- Antoine de Saint-Exupery

Offline

#5 2009-05-26 14:27:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: X crashes at every second startup

@leo2501
Is downgrading the only available solution? "Just" grab / compile an old version of xorg and it's extended family and it works?

Offline

#6 2009-05-26 22:19:44

leo2501
Member
From: Buenos Aires, Argentina
Registered: 2007-07-07
Posts: 637

Re: X crashes at every second startup

i think so, in these days i'll reinstall the OS and install xorg 7.3, then i'll ignorepkg xorg and intel drivers, maybe some other package and then see if the problem persist


Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
-- Antoine de Saint-Exupery

Offline

#7 2009-05-30 17:53:49

leo2501
Member
From: Buenos Aires, Argentina
Registered: 2007-07-07
Posts: 637

Re: X crashes at every second startup

well yesterday i updated xorg-server to 1.6.1.901-1 and the starting X lockup seems to be dissapeared, i restarted the computer a couple of times and i didn't get the lockup, and opengl apps now didn't lockup the computer as well, and even i can switch between VC's and X... A DREAM COME TRUE!! smile lol

im using...
- In xorg.conf:

Section "Device"
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "Mobile 945GME Express Integrated Graphics Controller"
        Option      "AccelMethod"            "UXA"
        BusID       "PCI:0:2:0"
EndSection

- KMS enabled (look in the wiki) this gets the right resolution for my netbook (1024x600) in VC's

- Intel driver is extra/xf86-video-intel 2.7.1-1


Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
-- Antoine de Saint-Exupery

Offline

#8 2009-05-30 17:58:11

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: X crashes at every second startup

Well, if that's the case, maybe sb should broadcast this happy news to all the folks who had this problem.

Offline

#9 2009-05-30 19:09:20

leo2501
Member
From: Buenos Aires, Argentina
Registered: 2007-07-07
Posts: 637

Re: X crashes at every second startup

that would be great, but i wanna test this a little more smile first


Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
-- Antoine de Saint-Exupery

Offline

#10 2009-06-07 13:52:59

leo2501
Member
From: Buenos Aires, Argentina
Registered: 2007-07-07
Posts: 637

Re: X crashes at every second startup

Well testing a little bit more i discovered that i can't use the VGA output of my netbook because it freezes bad and the only way to reset was with a hard reset...

so hope this helps the ones with an intel graphics card to solve their xorg problems

if you have one or (as my case) ALL this random problems
- non starting X
- random freezing X
- freezing when using VGA output
- freezing when using an opengl app
- random black screen with unresponsive system

[SOLVED] wanna reinstall and keep an older xorg
http://bbs.archlinux.org/viewtopic.php? … 32#p565132


Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
-- Antoine de Saint-Exupery

Offline

Board footer

Powered by FluxBB