You are not logged in.

#1 2009-06-08 01:29:26

deadlylife
Member
Registered: 2008-12-24
Posts: 120

X not terminated by ctrl+alt+backspace

Whenever I hit ctrl+alt+backspace, it does not kill X. I have the serverflag DontZap set to false, but it still won't work.

Offline

#2 2009-06-08 04:09:32

HashBox
Member
Registered: 2009-01-22
Posts: 271

Re: X not terminated by ctrl+alt+backspace

I've noticed this lately too, know idea what caused it.

Offline

#3 2009-06-08 04:12:38

wankel
Member
From: Iowa, USA
Registered: 2008-05-30
Posts: 218
Website

Re: X not terminated by ctrl+alt+backspace

Post this in your .xinitrc file:

setxkbmap -option terminate:ctrl_alt_bksp

Good luck fellas

Offline

#4 2009-06-08 06:38:28

Malstrond
Member
From: Germany
Registered: 2009-06-03
Posts: 89

Re: X not terminated by ctrl+alt+backspace

Thanks.
I wonder how long it is before that is disabled too and the next workaround has to be found. lol

Offline

#5 2009-06-08 12:44:53

HashBox
Member
Registered: 2009-01-22
Posts: 271

Re: X not terminated by ctrl+alt+backspace

Thanks wankel, haven't tried this yet but it looks promising.

I'm currently living in the console anyway since Xv or something related starting segfaulting my Xorg sad
I guess I should investigate further but I'm quite happy in the console. Even have a background XD

Offline

#6 2009-06-08 14:36:46

Lexion
Member
Registered: 2008-03-23
Posts: 510

Re: X not terminated by ctrl+alt+backspace

In the versions of X.org-server > 1.6.0 they have disabled 'Zapping'.


urxvtc / wmii / zsh / configs / onebluecat.net
Arch will not hold your hand

Offline

#7 2009-06-08 16:52:26

FreakGuard
Member
Registered: 2008-04-27
Posts: 83

Re: X not terminated by ctrl+alt+backspace

Lexion wrote:

In the versions of X.org-server > 1.6.0 they have disabled 'Zapping'.

> In that discusion it was declared that alt-sysreq-k was "better" [than zap] because
> it's harder to hit accidentally and more reliable due to being implemented
> in the kernel and not X.

... anything more to say?


In each heart, as pure it may be, there is a place of deepest and darkest abyss.
(by Apollo from archlinux.de, translated by a friend of mine who writes http://www.drunkduck.com/Captain_Communism/ )

Offline

#8 2009-06-08 20:14:18

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,684
Website

Re: X not terminated by ctrl+alt+backspace


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#9 2009-06-08 20:20:31

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,028

Re: X not terminated by ctrl+alt+backspace

using the hal method does not work for me sad

EDIT: im happy with alt-sysrq-k tho.....

Last edited by eldragon (2009-06-08 20:23:53)

Offline

#10 2009-06-09 11:45:06

will1911a1
Member
Registered: 2008-04-20
Posts: 59

Re: X not terminated by ctrl+alt+backspace

wankel wrote:

Post this in your .xinitrc file:

setxkbmap -option terminate:ctrl_alt_bksp

Good luck fellas

Thanks, wankel, worked like a charm!

Offline

#11 2009-06-16 10:19:28

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: X not terminated by ctrl+alt+backspace

A late follow-up: none of the methods described in the wiki worked for me. Maybe I got something wrong. But if you are using Gnome, there is now a keyboard option for "killing X", and this is working for me.

Offline

#12 2009-06-16 10:53:18

tkdfighter
Member
From: Switzerland
Registered: 2009-01-28
Posts: 126

Re: X not terminated by ctrl+alt+backspace

I think it would be a good idea if a moderator made this a sticky topic for a few months. It seems to be popping up regularly lately. If you do a search for "ctrl alt backspace" there are plenty of new threads on this.

Offline

#13 2009-06-16 11:23:34

folletto
Member
From: Poland
Registered: 2009-03-31
Posts: 26

Re: X not terminated by ctrl+alt+backspace

allbluedream thanks for that tip, now it works like it should

Offline

#14 2009-08-16 12:29:25

Snub
Member
Registered: 2007-09-09
Posts: 13

Re: X not terminated by ctrl+alt+backspace

None of the workarounds listed on the wiki or this thread are working for me any more. The .xinitrc, the xorg.conf, the hal method, ctrl alt backspace still doesn't respond. I'm using Fluxbox if that helps.

Offline

#15 2009-08-16 12:54:36

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: X not terminated by ctrl+alt+backspace

wankel wrote:

Post this in your .xinitrc file:

setxkbmap -option terminate:ctrl_alt_bksp

Good luck fellas

Thanks wankel, it worked perfectly for me too, (Openbox here).


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#16 2009-08-16 14:10:12

hrobeers
Member
From: Belgium
Registered: 2008-11-05
Posts: 79

Re: X not terminated by ctrl+alt+backspace

Before ctrl+alt+backspace worked for me but now it seems to be changed to

SHIFT+BACKSPACE !!!!

This is really irritating, because I did this a few times by accident. Are there others with this problem?

Offline

#17 2009-08-16 23:20:30

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: X not terminated by ctrl+alt+backspace

shift + backspace has no effect on my system.


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#18 2009-08-17 04:23:40

wankel
Member
From: Iowa, USA
Registered: 2008-05-30
Posts: 218
Website

Re: X not terminated by ctrl+alt+backspace

No problem guys, glad to hear its working out for most of you smile

hrobeers, try this:
xmodmap -e "keycode 22 = BackSpace BackSpace Terminate_Server"

Offline

#19 2009-08-17 13:35:12

scv5
Member
Registered: 2008-10-19
Posts: 109

Re: X not terminated by ctrl+alt+backspace

i thought you could put this in your xorg.conf and it would work? (not able to test right now)

Section "ServerFlags"
      Option          "DontZap"               "false"
EndSection

Offline

#20 2009-08-17 13:42:36

Nepherte
Member
From: Singapore
Registered: 2008-09-09
Posts: 427
Website

Re: X not terminated by ctrl+alt+backspace

scv5 wrote:

i thought you could put this in your xorg.conf and it would work? (not able to test right now)

Section "ServerFlags"
      Option          "DontZap"               "false"
EndSection

In addition you need to add either:

<merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

to the keyboard fdi file or run

setxkbmap -option terminate:ctrl_alt_bksp

as is indicated in the wiki.

Offline

#21 2009-08-17 17:25:58

wankel
Member
From: Iowa, USA
Registered: 2008-05-30
Posts: 218
Website

Re: X not terminated by ctrl+alt+backspace

The dont zap thing doesnt work anymore, so you only need to use one of the options that Nepherte has mentioned.

Offline

#22 2009-08-17 17:45:01

hatten
Arch Linux f@h Team Member
From: Sweden, Borlange
Registered: 2009-02-23
Posts: 736

Re: X not terminated by ctrl+alt+backspace

> In that discusion it was declared that alt-sysreq-k was "better" [than zap] because
> it's harder to hit accidentally and more reliable due to being implemented
> in the kernel and not X.

Isn't it smarter to start using this one instead of ctrl-alt-backspace if they are going to get rid of all workarounds? Or is there any differences between the two commands?

Offline

#23 2009-09-07 19:32:51

orjanp
Member
From: Tromsoe, Norway
Registered: 2004-07-03
Posts: 347

Re: X not terminated by ctrl+alt+backspace

None of the above works for me. What can be done?


Ørjan Pettersen

Offline

#24 2009-09-07 23:44:23

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: X not terminated by ctrl+alt+backspace

I only needed to put the following in my .xinitrc:

setxkbmap -option terminate:ctrl_alt_bksp &

With no editing or additions anywhere else & it works perfectly. I use Openbox if it matters.

I don't agree that "Ctrl + Alt + Backspace" is easy to hit accidentally, I have never done it since 1986! 
I don't know why this change was made? 
Either way I can live with it & will adapt when I have no other choice. smile

Last edited by handy (2009-09-07 23:44:40)


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#25 2009-09-09 04:45:36

Goico
Member
Registered: 2009-09-06
Posts: 16

Re: X not terminated by ctrl+alt+backspace

I prefer using alt + ctrl + bksp .. but I have to confess. I did press those keys accidentally once!
I was using mc on a gnome-terminal, alt + ctrl and a letter to find a directory. Hit the wrong key ... guess what I did next -.-


But I still have alt + ctrl + bksp enabled!

Offline

Board footer

Powered by FluxBB