You are not logged in.

#1 2003-06-26 21:42:40

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

man pages...

hey guys!

i got a problem with all of my man pages. they all look this way:

UMASK(2)                   Linux Programmer's Manual                  UMASK(2)

ESC[1mNAMEESC[0m
       umask - set file creation mask

ESC[1mSYNOPSISESC[0m
       ESC[1m#include <sys/types.h>ESC[0m
       ESC[1m#include <sys/stat.h>ESC[0m

       ESC[1mmode_t umask(mode_t ESC[4mESC[22mmaskESC[24mESC[1m);ESC[0m

ESC[1mDESCRIPTIONESC[0m
       ESC[1mumask ESC[22msets the umask to ESC[4mmaskESC[24m & 0777.

i've reinstalled man-pages, but it doesn't change anything...
the installation is very old (0.3 with pacman -Syu). the problem is fixed on all other systems. it happens just on this one... any ideas?

regards,
moritz

Offline

#2 2003-06-27 00:16:06

hApy
Member
From: Victoria, BC
Registered: 2003-04-13
Posts: 194
Website

Re: man pages...

I think it's probably your terminal settings.... try either changing them in your terminal program or changing your $TERM variable. Mine is "xterm-color", try that?

Hapy.

Offline

#3 2003-06-27 00:16:40

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: man pages...

i believe if you reinstall groff it should work. apeiro can verify this.


AKA uknowme

I am not your friend

Offline

#4 2003-06-27 01:05:25

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: man pages...

Yea, you'll need to log out and then log back in again to inherit the new $LESS environment variable.

Or you can just type this:

# export LESS=-R

Offline

#5 2003-06-27 07:39:16

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: man pages...

just log out and log in won't work, but export LESS=-R does!

Thank you! big_smile

Offline

#6 2003-06-27 10:37:36

Gyroplast
Member
From: Germany
Registered: 2002-09-03
Posts: 166
Website

Re: man pages...

Just for the record.. exactly this problem and it's solution can be found in the unofficial FAQ. *hint* *hint* wink

Something I cannot quite understand, tho, is why this problem exists in the first place? What's going wrong that this export line isn't included in the default profile?

Gyro


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert

Offline

#7 2003-06-27 14:14:45

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: man pages...

it was in mine


AKA uknowme

I am not your friend

Offline

#8 2003-06-27 15:30:33

Moritz
Member
From: Cologne, NRW, Germany
Registered: 2002-10-12
Posts: 166

Re: man pages...

Gyroplast wrote:

Just for the record.. exactly this problem and it's solution can be found in the unofficial FAQ. *hint* *hint* wink

What about publishing news when updating the FAQ.
I've read it some/long time ago........... lol

Offline

#9 2003-06-27 19:45:33

Gyroplast
Member
From: Germany
Registered: 2002-09-03
Posts: 166
Website

Re: man pages...

Yeah, probably a good idea, but since the last update has been on Thu May 22 09:45:11 2003, the FAQ simply isn't new right now. wink


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert

Offline

#10 2004-02-10 21:24:11

rshetye
Member
Registered: 2004-02-10
Posts: 11

Re: man pages...

for the record:

I use tcsh and not bash. I ran into the same problems. Here are the changes I needed in my .tcshrc file

# Arch linux specific stuff
setenv TERM "xterm-color"
setenv LESS "-R"

Also, arch-linux does not use (the older) termcap [ /etc/termcap ]. It uses the newer terminfo. [ /usr/share/terminfo/*/* ] . "man terminfo" for guidance.
The 'setenv TERM "xterm-color"' setting enables colour in gvim, vim etc. instead of the ugly monochromatic-underlined-las-vegas-style-blinking interface that you see with 'setenv TERM "xterm"'.
The 'setenv LESS "-R"' setting deals with the ESC chars and gives you clean man pages.

On a side note:
Moved my Pentium 3 server from gentoo to arch-linux, and was up and running in less than a day. very impressive except hosts.allow and hosts.deny bit me in the @ss for some time. Still keep gentoo on my laptop around for bleeding-edge-state-of-the-art cvs-access to Gnome.
Debian sucks. Its like a 1950's record, sure it works but its so dusty and out of date.
Gentoo failed me when it came to binary-based releases. Arch fills that gap more than easily. Only thing I DONT use pacman for is kernels, currently building my own. Will try that out some time.
Thanks everyone for a great distro and a great forum. Your attention to user-feedback mechanisms is the best in the industry (open-source or otherwise).

Please add openbox stuff to the repository. I am running openbox with bbpager on my server and would like access to obconf and other openbox tools.
--
George W. Bush: noun, Biological Weapon of Mass Destruction. (see also: Axis of Stupidity)

Offline

#11 2004-02-10 21:44:30

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 454
Website

Re: man pages...

There also seem to be issues with non-standard, i.e. other than bash, shells. For instance, I use zsh and have to manually add my PATH to my zshrc.  I ~thought~ that had been what my problem was with $LESS as well, and though I tried hacking /etc/profile, I didn't do a good job--results were rather funny actually.

Scott

Offline

#12 2004-02-10 21:52:14

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: man pages...

rshetye wrote:

Please add openbox stuff to the repository. I am running openbox with bbpager on my server and would like access to obconf and other openbox tools.

i think there may be some openbox tools in the TURs or staging.


AKA uknowme

I am not your friend

Offline

#13 2004-02-11 02:49:00

rshetye
Member
Registered: 2004-02-10
Posts: 11

Re: man pages...

thanks for the tip, sarah31.

putting it all in one thread so that anyone with my kind of system finds all the answers in one place.

for the record:

TUR = Trusted-User Repositories
What is a TUR ? e.g. http://tur.berlios.de/mission.php

TUR settings are added to /etc/pacman.conf e.g. http://tur.berlios.de/repos.php - also contains list of packages hosted by each TUR. After going thru this list of packages, I've decided to add deepfreeze's TUR and the staging area to my /etc/pacman.conf so that I get access to obconf and some other things that I want.

[deepfreeze]
Server = ftp://ftp.berlios.de/pub/tur/deepfreeze

[staging]
Server = ftp://ftp.berlios.de/pub/tur/staging

This means that I've decided to trust deepfreeze, and anyone else who has access to berlios' staging area - make your own decisions carefully.

Offline

#14 2004-03-08 19:44:06

tbuitenh
Member
Registered: 2004-03-08
Posts: 55

Re: man pages...

I have the same problem, but only in xterm, not on the console.
/etc/profile does contain the line

export LESS=-R

.
I also put that line in my .bashrc , which helped. Is there a way to do this for all users without editing all their .bashrcs?
Manual pages also contain junk when viewed with xman. export LESS=-R does not solve this (of course not, xman doesn't use less!).

As this is my first post, I'd like to say Arch is better than I expected from a 0.x version. Much better.


I wish life was as simple as editing config files

Offline

#15 2004-03-08 19:52:44

tbuitenh
Member
Registered: 2004-03-08
Posts: 55

Re: man pages...

I added this line to /etc/X11/xdm/Xsession:

source /etc/profile

Of course xman still looks like ****. Any ideas how to fix that?


I wish life was as simple as editing config files

Offline

Board footer

Powered by FluxBB