You are not logged in.

#1 2004-10-16 15:31:12

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

KDE, aRts, and the recent flac update

Good morning,

I am running kde 3.3.1. No issues. I performed a pacman -Syu recently, and the flac package was updated.

At this point, I lost my sound, specifically aRts is not running in KDE. So KDE native apps that use aRts, such as noatun, and the KDE sounds that are specific to KDE events, do not work now.

The sound system (alsa) is still working though. Non-KDE apps generate sound perfectly, even when launched from within KDE. Last night I watched "The Day After Tomorrow" with xine, ...no sound issues. But KDE is voiceless.

Checked the obvious such as sound settings, mute, ran alsamixer in a console and verified that something wasn't muted, and verified that my default levels had not been misadjusted...

Thinking I had a system problem, I started gnome (2.8). It has it's own system sounds with no issues, so my problem appears to be KDE specific.

Any ideas anyone?


Dave..........

Offline

#2 2004-10-16 17:14:06

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: KDE, aRts, and the recent flac update

Hmm... Kaboodle and Noatun load fine and can produce sound here. Juk and amarok, however, won't load because of a missing library libflac.so.4.

Offline

#3 2004-10-16 17:14:17

kritoke
Member
From: Texas, USA
Registered: 2003-08-01
Posts: 211
Website

Re: KDE, aRts, and the recent flac update

I just booted into kde to check something and I am having this problem as well after this latest update.  Trying to set kde to use any sound system brings up a crash in knotify.

Kritoke


http://counter.li.org/ Registered Linux User #318963 kritoke@jabber.org

Offline

#4 2004-10-16 18:36:06

luke
Member
From: US
Registered: 2004-06-22
Posts: 54

Re: KDE, aRts, and the recent flac update

same problem here with the missing library libflac.so.4. and amaroK

Offline

#5 2004-10-16 23:54:33

lpratt
Member
From: Upstate New York
Registered: 2004-09-06
Posts: 16

Re: KDE, aRts, and the recent flac update

Gentlemen,

Sorry for being so late to chime but I've been busy trying to skull out XML all day and haven't had a chance to check the forum before this.

I did the upgrade last night but didn't notice the problem with the KDE system sounds till I read this thread (I'm now using XFce 95% of the time). Like the rest xmms and other sound apps work - just no system sounds. Everything else appears to running peachy...:)

Lee

Offline

#6 2004-10-17 02:27:52

cascat
Member
Registered: 2004-02-24
Posts: 62

Re: KDE, aRts, and the recent flac update

I had the same problems after upgrading flac.  Create a link in /usr/lib:  libFLAC.so.4 ->libFLAC.so.6.0.1.  This solved the aforementioned problems.

Offline

#7 2004-10-17 11:23:15

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Re: KDE, aRts, and the recent flac update

cascat wrote:

I had the same problems after upgrading flac.  Create a link in /usr/lib:  libFLAC.so.4 ->libFLAC.so.6.0.1.  This solved the aforementioned problems.

thank you!
that did solve this problem smile


To err is human... to really foul up requires the root password.

Offline

#8 2004-10-17 14:37:38

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

Re: KDE, aRts, and the recent flac update

Hello All,

Thank you for the reply. The suggested fix works.


For those that may be new to linux, here is the exact things to do.


Log in as root.

cd /usr/lib
cp -s libFLAC.so.6.0.1 libFLAC.so.4
cd

logout of your root account, and then login to your user account.

KDE's voice will be back.

Thanks!


Dave........

Offline

#9 2004-10-17 19:42:59

Mith
Member
From: out there
Registered: 2004-10-05
Posts: 163

Re: KDE, aRts, and the recent flac update

cascat wrote:

I had the same problems after upgrading flac.  Create a link in /usr/lib:  libFLAC.so.4 ->libFLAC.so.6.0.1.  This solved the aforementioned problems.

creating a link.
that would be "ln -s" and not "cp -s", imho


ArchLinux (x86_64) w/ kdemod

Offline

#10 2004-10-17 20:25:13

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: KDE, aRts, and the recent flac update

That's not an opinion, it's a fact wink

Offline

#11 2004-10-17 20:37:53

soniX
Member
From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: KDE, aRts, and the recent flac update

man cp

-s, --symbolic-link
makes symbolic links insted of copying

my guess is that

cp -s == ln -s

so in that case...
they are both equal

Offline

#12 2004-10-18 01:10:25

dcbdbis
Member
From: Aurora, Colorado
Registered: 2004-09-10
Posts: 215

Re: KDE, aRts, and the recent flac update

Folks,

ln and cp -s do the same thing.

Both are equally correct. It purely a matter of personal preference on which you use..

Don't you just love Linux? big_smile


Dave.............

Offline

#13 2004-10-18 04:21:09

Mith
Member
From: out there
Registered: 2004-10-05
Posts: 163

Re: KDE, aRts, and the recent flac update

: >>
and again learned something new! is there a better way to start a new day?? tongue
[ just updated libFLAC and good thing I read this thread since the problem is not fixed yet.. does the libFLAC maintainer read this forum? ]


ArchLinux (x86_64) w/ kdemod

Offline

#14 2004-10-18 13:37:54

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: KDE, aRts, and the recent flac update

I was not aware of that. Almost everyone uses ln I guess

Offline

Board footer

Powered by FluxBB