You are not logged in.

#1 2009-07-04 15:36:37

Andy Mack
Member
Registered: 2008-06-16
Posts: 133

[Solved]Firefox 3.5 Fonts gone wrong

Since the upgrade to 3.5 my firefox fonts have messed up. Seems to be a problem with hinting not being taken from gnome font preferences no-more.
I updated cairo and applied the lcd patch to it myself but firefox fonts still remain the same.

I have read ppl on ubuntu have had the same problem but the fix found there wont work with arch.

Any ideas?

Last edited by Andy Mack (2009-07-15 15:47:42)

Offline

#2 2009-07-04 15:39:56

uastasi
Member
From: Salento - Italy
Registered: 2007-11-27
Posts: 247

Re: [Solved]Firefox 3.5 Fonts gone wrong

I have the same problem. Fonts are not well rendered as they used to be before.
What's this ubuntu fix? We could eventually find a way to make it work with Arch too.

Here's a bug opened, but I'm not sure it's the same trouble.

Last edited by uastasi (2009-07-04 15:41:31)


Till the last battle, till the last bottle.
aur - twitter

Offline

#3 2009-07-04 16:27:54

Andy Mack
Member
Registered: 2008-06-16
Posts: 133

Re: [Solved]Firefox 3.5 Fonts gone wrong

This is the ubuntu fix...

$sudo rm /etc/fonts/conf.d/10-hinting-slight.conf
$sudo rm /etc/fonts/conf.d/10-no-sub-pixel.conf
$sudo ln -s /etc/fonts/conf.available/10-hinting-medium.conf /etc/fonts/conf.d/.
$sudo ln -s /etc/fonts/conf.available/10-sub-pixel-rgb.conf /etc/fonts/conf.d/.
$sudo dpkg-reconfigure fontconfig

Offline

#4 2009-07-04 16:50:03

Knives
Member
Registered: 2008-12-26
Posts: 25

Re: [Solved]Firefox 3.5 Fonts gone wrong

Andy Mack, can you post the conf. inside 10-hinting-medium.conf and 10-sub-pixel-rgb.conf?

i believe that using the same config used in ubuntu, it should work in arch too.

Offline

#5 2009-07-04 18:17:50

catweazle
Member
From: Germany
Registered: 2006-12-14
Posts: 24

Re: [Solved]Firefox 3.5 Fonts gone wrong

I grabbed 10-hinting-medium.conf from a Ubuntu system we have here at work and installed it. It did not have 10-sub-pixel-rgb.conf, but arch does. I symlinked both to /etc/fonts/conf.d/ , logged out, restarted X, logged back in, no change. sad

Here is the contents of 10-hinting-medium.conf. Maybe somebody else can try and has success?

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!--  Use Medium Hinting -->
  <match target="font">
    <edit name="hintstyle" mode="assign"><const>hintmedium</const></edit>
  </match>
</fontconfig>

Offline

#6 2009-07-04 18:27:58

Andru
Member
From: Zhitomir(Ukraine)
Registered: 2008-09-07
Posts: 23
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

catweazle
Deleting 10-no-sub-pixel.conf and 10-hinting-medium.conf helped me smile Maybe you forgot configure ~/.fonts.conf?

<?xml version='1.0'?>
<match target="pattern" >
 <edit mode="assign" name="hinting" >
  <bool>true</bool>
 </edit>
 <edit mode="assign" name="hintstyle" >
  <const>hintfull</const>
 </edit>
 <edit mode="assign" name="autohint" >
  <bool>false</bool>
 </edit>
 <edit mode="assign" name="antialias" >
  <bool>true</bool>
 </edit>
 <edit mode="assign" name="rgba" >
  <const>rgb</const>
 </edit>
</match>

Offline

#7 2009-07-04 19:36:24

Andy Mack
Member
Registered: 2008-06-16
Posts: 133

Re: [Solved]Firefox 3.5 Fonts gone wrong

After reading another post I renamed ~/.fonts.conf to /fonts.conf so firefox wouldn't look at it and lo and behold fonats are back to normal!

*after relog openbox and conky fonts look wrong! hahahah linux is a pain in the arse sometimes.

Gonna try different things and report back if I find an overall solution.

Last edited by Andy Mack (2009-07-04 19:40:24)

Offline

#8 2009-07-04 19:44:07

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

I'm still trying to find a working solution for me, but for reference here's the difference:

http://cinderwick.ca/tmp/firefox-3.0-rendering.png
http://cinderwick.ca/tmp/firefox-3.5-rendering.png

It's definitely a hinting issue...

Last edited by thayer (2009-07-04 19:45:22)


thayer williams ~ cinderwick.ca

Offline

#9 2009-07-04 19:47:17

Andy Mack
Member
Registered: 2008-06-16
Posts: 133

Re: [Solved]Firefox 3.5 Fonts gone wrong

Ok, make a backup of ~/fonts.conf and in the original remove

</match>
<match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintfull</const>
  </edit>

In doing so openbox and conky are back to normal and I'm pretty sure firefox looks like it used to.
Could someone test this too.

Offline

#10 2009-07-04 19:54:54

Andru
Member
From: Zhitomir(Ukraine)
Registered: 2008-09-07
Posts: 23
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

thayer
seems that in /etc/fonts/conf.d no 10-hinting-full.conf, or there are any other hinting-conf files.

Offline

#11 2009-07-04 20:12:24

catweazle
Member
From: Germany
Registered: 2006-12-14
Posts: 24

Re: [Solved]Firefox 3.5 Fonts gone wrong

I tried Andru's suggestion and, lo and behold, I got crisp fonts in firefox 3.5. However, in my KDE applications (KDE 3.5) fonts came out a little too skinny for my taste. I tried to change that in the KDE control center by changing the font configuration from "System Settings" to explicitly using "medium" for hintstyle. After that (logout and restart X) KDE fonts looked ok again, but firefox fonts were back to being not so crisp again sad .  The funny thing now is, whatever I do I cannot get the crisp fonts in firefox back. I'll try Andy Mack's suggestion and report back.

Offline

#12 2009-07-04 20:19:20

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

Andru wrote:

thayer
seems that in /etc/fonts/conf.d no 10-hinting-full.conf, or there are any other hinting-conf files.

That's true, I don't want hinting period, nor antialiasing.  I tried dropping 10-unhinting.conf into conf.d but that didn't work either.  Then I tried creating my own rule in conf.d containing the following (it also failed to make a difference):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!--  Disable hinting --> 
  <match target="font">
    <edit name="hinting" mode="assign"><bool>false</bool></edit>
    <edit name="autohint" mode="assign"><bool>false</bool></edit>
    <edit name="antialias" mode="assign"><bool>false</bool></edit>
  </match>
</fontconfig>

Removing ~/.fonts.conf does make the fonts legible, albeit with antialiasing and hinting enabled (which I do not want). It looks like Firefox is forcing hinting regardless of how Fontconfig is configured.  As you can see from my screenshot above, bold fonts appear normal.  That's because I specifically antialias and hint bold fonts and fonts exceeding a certain size via ~/.fonts.conf .  All other fonts should appear aliased and unhinted.

Last edited by thayer (2009-07-04 20:23:58)


thayer williams ~ cinderwick.ca

Offline

#13 2009-07-04 21:28:37

catweazle
Member
From: Germany
Registered: 2006-12-14
Posts: 24

Re: [Solved]Firefox 3.5 Fonts gone wrong

I found that I need to set "hinting" to "hintfull" and "autohint" to "true"  in order to get crisp fonts in firefox 3.5. I have all my settings in /etc/fonts/local.conf and I don't have a ~/.fonts.conf. What's confusing is that sometimes when I log in, a .fonts.conf gets created (by KDE 3.5?) which overrides the settings I have made in /etc/fonts/local/conf. In the KDE control center font antialiasing is set to "system settings" which would lead me to believe that KDE would not try to alter any settings. Oh well...

Offline

#14 2009-07-05 20:10:55

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong


thayer williams ~ cinderwick.ca

Offline

#15 2009-07-08 17:31:09

Spider
Member
Registered: 2009-05-13
Posts: 4

Re: [Solved]Firefox 3.5 Fonts gone wrong

Is there any solution yet?

Offline

#16 2009-07-08 18:02:55

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

No and we seem to be an extreme minority if the Google search results mean anything.  Most users are content by forcing their preferred hint style (slight, medium, or full) in /etc/fonts/conf.d.  For those of us that don't use/like antialiased fonts, we're up a creek because there's no way to completely turn off hinting.

In the meantime I'm back with FF 3.0.

Last edited by thayer (2009-07-08 18:04:21)


thayer williams ~ cinderwick.ca

Offline

#17 2009-07-08 18:13:21

brebs
Member
Registered: 2007-04-03
Posts: 3,636

Re: [Solved]Firefox 3.5 Fonts gone wrong

I can't reproduce your problem. ~/.fonts.conf works correctly for me (with all the flexibility it allows), in firefox 3, 3.5 and other apps.

There's some firefox-specific options for you to play with:
gfx.use_text_smoothing_setting
browser.display.auto_quality_min_font_size

Offline

#18 2009-07-08 19:07:42

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

I can't reproduce your problem. ~/.fonts.conf works correctly for me (with all the flexibility it allows), in firefox 3, 3.5 and other apps.

Yeah that's frustrating for sure.  For peace of mind (so that I know it's at least possible), can you post a screenshot of your own FF 3.5 displaying aliased/non-hinted fonts.  It should appear very near to what I have posted above in my FF 3.0 example (ala classic Windows 98 font appearance).

There's some firefox-specific options for you to play with:
gfx.use_text_smoothing_setting
browser.display.auto_quality_min_font_size

gfx.use_text_smoothing_setting: false
browser.display.auto_quality_min_font_size: 20

Both were the same as they were in FF 3.0.  Toggling the former made no difference and neither did increasing the min_font_size to 40.

Last edited by thayer (2009-07-08 19:41:43)


thayer williams ~ cinderwick.ca

Offline

#19 2009-07-08 19:30:38

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

Here's another example.  I have completely stripped ~/.fonts.conf to contain only the basic settings (no exceptions, conditions, etc.):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
        <edit name="hinting" mode="assign"><bool>false</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintnone</const></edit>
        <edit name="rgba" mode="assign"><const>none</const></edit>
    </match>
 </fontconfig>

And here's the result:
firefox-3.5-nohinting-noautohint-noantialias-th.png

Note that hinting is still being applied to the fonts even though it has been disabled in fontconfig.

Applying the above rules to the system-wide /etc/fonts/conf.d location produces the exact same result.  Here's what is linked there now (and I've moved everything out of here too and it made no difference):

$ ls -l /etc/fonts/conf.d/

total 4
lrwxrwxrwx 1 root root  39 2009-06-13 11:08 20-fix-globaladvance.conf -> ../conf.avail/20-fix-globaladvance.conf
lrwxrwxrwx 1 root root  39 2009-06-13 11:08 20-unhint-small-vera.conf -> ../conf.avail/20-unhint-small-vera.conf
lrwxrwxrwx 1 root root  42 2009-06-13 11:08 29-replace-bitmap-fonts.conf -> ../conf.avail/29-replace-bitmap-fonts.conf
lrwxrwxrwx 1 root root  36 2009-06-13 11:08 30-metric-aliases.conf -> ../conf.avail/30-metric-aliases.conf
lrwxrwxrwx 1 root root  33 2009-06-13 11:08 30-urw-aliases.conf -> ../conf.avail/30-urw-aliases.conf
lrwxrwxrwx 1 root root  30 2009-06-13 11:08 40-nonlatin.conf -> ../conf.avail/40-nonlatin.conf
lrwxrwxrwx 1 root root  27 2009-06-13 11:08 45-latin.conf -> ../conf.avail/45-latin.conf
lrwxrwxrwx 1 root root  31 2009-06-13 11:08 49-sansserif.conf -> ../conf.avail/49-sansserif.conf
lrwxrwxrwx 1 root root  26 2009-06-13 11:08 50-user.conf -> ../conf.avail/50-user.conf
lrwxrwxrwx 1 root root  27 2009-06-13 11:08 51-local.conf -> ../conf.avail/51-local.conf
lrwxrwxrwx 1 root root  27 2009-06-13 11:08 60-latin.conf -> ../conf.avail/60-latin.conf
lrwxrwxrwx 1 root root  35 2009-06-13 11:08 65-fonts-persian.conf -> ../conf.avail/65-fonts-persian.conf
lrwxrwxrwx 1 root root  30 2009-06-13 11:08 65-nonlatin.conf -> ../conf.avail/65-nonlatin.conf
lrwxrwxrwx 1 root root  29 2009-06-13 11:08 69-unifont.conf -> ../conf.avail/69-unifont.conf
lrwxrwxrwx 1 root root  31 2009-06-13 11:08 80-delicious.conf -> ../conf.avail/80-delicious.conf
lrwxrwxrwx 1 root root  31 2009-06-13 11:08 90-synthetic.conf -> ../conf.avail/90-synthetic.conf
-rw-r--r-- 1 root root 959 2008-07-06 15:08 README

I run a minimal X desktop (dwm). No gnome-settings-daemon.  No font settings declared in .Xdefaults either.  I manage everything via ~/.fonts.conf and every other application looks great.

Last edited by thayer (2009-07-08 19:37:29)


thayer williams ~ cinderwick.ca

Offline

#20 2009-07-09 10:23:22

Spider
Member
Registered: 2009-05-13
Posts: 4

Re: [Solved]Firefox 3.5 Fonts gone wrong

I managed to restore my old display (monochrome with full hinting) with .fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
        <edit name="hinting" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
    </match>
 </fontconfig>

Offline

#21 2009-07-11 21:51:52

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

...but doesn't anyone else within the Arch community run a desktop without hinting or antialiasing?  I can't believe I'm the only one!


thayer williams ~ cinderwick.ca

Offline

#22 2009-07-15 01:31:19

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

OK I was able to resolve the issues I was having, but I'm not still not quite sure why.  What I mean is that the method I have used for years no longer works, and the method that previously gave undesired results is now the only way to achieve the desired results.

Traditionally, disabling hinting, autohinting and antialiasing resulted in Windows 98/XP-style font rendering as long as the BCI was enabled in Freetype2.  This continues to work for GTK applications, but fails in QT apps, Firefox 3.5 and Opera.  The latter applications display horrible font hinting (broken letters, etc.) when these settings are in place.

To generate the Windows 98/XP font rendering now, I have to enable hinting, set the hintstyle to hintfull, and then disable autohinting and antialiasing. With these settings all applications appear to render properly.  Previously this resulted in poorly hinted characters, even when the Bytecode Interpreter was compiled into Freetype2.

So...I don't what has changed, but I'm just glad it's working.

Last edited by thayer (2009-07-15 15:02:18)


thayer williams ~ cinderwick.ca

Offline

#23 2009-07-15 15:04:49

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: [Solved]Firefox 3.5 Fonts gone wrong

Andy, if you're happy with your revised settings go ahead and mark this as resolved.


thayer williams ~ cinderwick.ca

Offline

#24 2009-07-16 22:05:38

uastasi
Member
From: Salento - Italy
Registered: 2007-11-27
Posts: 247

Re: [Solved]Firefox 3.5 Fonts gone wrong

thayer wrote:

OK I was able to resolve the issues I was having, but I'm not still not quite sure why.  What I mean is that the method I have used for years no longer works, and the method that previously gave undesired results is now the only way to achieve the desired results.

Traditionally, disabling hinting, autohinting and antialiasing resulted in Windows 98/XP-style font rendering as long as the BCI was enabled in Freetype2.  This continues to work for GTK applications, but fails in QT apps, Firefox 3.5 and Opera.  The latter applications display horrible font hinting (broken letters, etc.) when these settings are in place.

To generate the Windows 98/XP font rendering now, I have to enable hinting, set the hintstyle to hintfull, and then disable autohinting and antialiasing. With these settings all applications appear to render properly.  Previously this resulted in poorly hinted characters, even when the Bytecode Interpreter was compiled into Freetype2.

So...I don't what has changed, but I'm just glad it's working.

Could you please post your .fonts.conf ? I have this issue yet, and it is very unpleaseful.
Thanks


Till the last battle, till the last bottle.
aur - twitter

Offline

Board footer

Powered by FluxBB