You are not logged in.

#1 2009-07-06 14:28:23

ntowakbh
Member
Registered: 2009-06-04
Posts: 29

[SOLVED] System Beep Just Won't Die!

My laptop's system beep is incredibly loud and shrill.  I have searched the forums, the wiki and a few other places, with no luck.  My laptop is a Dell Studio 15.

List of tried things:
Adding !pcspkr and !snd-pcsp to the MODDULES array in /etc/rc.conf. -- Did absolutely nothing.
Disabling it in X by adding xset -b to ~/.xinitrc -- Works for X as it is supposed to, though I would like to not have to run this at each start up of X.
Adding setterm -b length 0 to .bashrc -- This works in X, if I am on a Virtual Console, I have to manually enter it.
Adding set bell-style none to ~/.inputrc -- Did absolutely nothing.
Muting/Setting at 0% PC Beep in Alsamixer.  -- This works...sorta...  At first it will work, but once I reboot, it's back again.

Please assist, it's driving me nuts!

Thanks for any help in advance!

EDIT: Thanks to arkhan.  The problem was that alsa was not in the daemons array of /etc/rc.conf.

Last edited by ntowakbh (2009-07-06 14:59:24)


Many nights, I lay awake in bed,
Looking up at the stars.
Thinking of life, it's complexity,
And where in the world my ceiling could have gone this time.

Offline

#2 2009-07-06 14:31:43

phisphere
Member
From: Tallinn, Estonia
Registered: 2007-03-05
Posts: 136
Website

Re: [SOLVED] System Beep Just Won't Die!

i found the following solution: adding !snd_pcsp and !pcspkr in the following order to rc.conf modules list did the trick for me.

MODULES=(!snd_pcsp !pcspkr)

Last edited by phisphere (2009-07-06 14:31:54)

Offline

#3 2009-07-06 14:43:16

ntowakbh
Member
Registered: 2009-06-04
Posts: 29

Re: [SOLVED] System Beep Just Won't Die!

phisphere wrote:

i found the following solution: adding !snd_pcsp and !pcspkr in the following order to rc.conf modules list did the trick for me.

MODULES=(!snd_pcsp !pcspkr)

As I said, I already tried that.  Though to double check I put them in the order that is on your's, just to be safe.  Still nothing.


Many nights, I lay awake in bed,
Looking up at the stars.
Thinking of life, it's complexity,
And where in the world my ceiling could have gone this time.

Offline

#4 2009-07-06 14:53:18

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: [SOLVED] System Beep Just Won't Die!

Did you add alsa to your daemons in /etc/rc.conf ?
Try doing that, muting the pc beep in alsamixer and running 'alsactl store' as root.


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#5 2009-07-06 14:58:09

ntowakbh
Member
Registered: 2009-06-04
Posts: 29

Re: [SOLVED] System Beep Just Won't Die!

arkham wrote:

Did you add alsa to your daemons in /etc/rc.conf ?
Try doing that, muting the pc beep in alsamixer and running 'alsactl store' as root.

Thanks a ton! No more of that shrill noise!

The problem wasn't my alsamixer settings, and I did run alsactl store as root.  The problem was that alsa wasn't in my startup daemons. Thank you!


Many nights, I lay awake in bed,
Looking up at the stars.
Thinking of life, it's complexity,
And where in the world my ceiling could have gone this time.

Offline

#6 2009-07-06 15:06:47

moljac024
Member
From: Serbia
Registered: 2008-01-29
Posts: 2,676

Re: [SOLVED] System Beep Just Won't Die!

Scratch that, good you solved it...

Last edited by moljac024 (2009-07-06 15:07:34)


The day Microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
--------------------------------------------------------------------------------------------------------------
But if they tell you that I've lost my mind, maybe it's not gone just a little hard to find...

Offline

#7 2009-07-07 13:42:40

rine
Member
From: Germany
Registered: 2008-03-04
Posts: 217

Re: [SOLVED] System Beep Just Won't Die!

This is solved, but just to be sure: You typed snd-pcsp in your first post and not snd_pcsp.

Offline

#8 2009-07-17 19:27:13

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: [SOLVED] System Beep Just Won't Die!

sorry

but when snd_pcsp is not in new kernel..

I cant hear system beep


what module replace snd_pcsp ?

Last edited by sacarde (2009-07-17 19:28:00)

Offline

#9 2009-07-22 23:19:17

szabo
Member
Registered: 2009-05-06
Posts: 8

Re: [SOLVED] System Beep Just Won't Die!

arkham wrote:

Did you add alsa to your daemons in /etc/rc.conf ?
Try doing that, muting the pc beep in alsamixer and running 'alsactl store' as root.

Thanks! That damn beep came back from the dead and was driving me crazy!
I couldn't find the beep in gnome-volume-control and (dumbly) assumed I
wouldn't find it in good Ol' alsamixer.

Last edited by szabo (2009-07-22 23:20:45)

Offline

#10 2009-07-23 06:45:07

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: [SOLVED] System Beep Just Won't Die!

I solve installing snd-pcsp from aur

Offline

#11 2009-08-14 20:55:54

sol0
Member
Registered: 2008-07-02
Posts: 4

Re: [SOLVED] System Beep Just Won't Die!

Sidenote: I blacklisted pcspkr in rc.conf and finally got rid of it!


find /etc |grep \\.d$

Offline

#12 2009-09-15 02:19:27

cit30
Member
Registered: 2009-08-19
Posts: 24

Re: [SOLVED] System Beep Just Won't Die!

phisphere wrote:

i found the following solution: adding !snd_pcsp and !pcspkr in the following order to rc.conf modules list did the trick for me.

MODULES=(!snd_pcsp !pcspkr)

This worked for me too. Big thanks!

Offline

Board footer

Powered by FluxBB