You are not logged in.

#1 2009-07-13 18:05:11

gizme
Member
Registered: 2007-02-17
Posts: 11

[Solved] Aufs2

Was wondering if Aufs/2 has been dropped or currently unavailible, iam using kernel 2.6.30-1.
There might be another solution than aufs that iam unaware of roll
Currently using it to span similar folders on different drives.

Last edited by gizme (2009-07-20 22:20:10)

Offline

#2 2009-07-13 22:32:07

Allan
is always right
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,463
Website

Re: [Solved] Aufs2

I have no issues with aufs2 support.  Can you describe the problems you are having?

Offline

#3 2009-07-14 10:31:09

gizme
Member
Registered: 2007-02-17
Posts: 11

Re: [Solved] Aufs2

When trying to use aufs with two folders i.e:

mount -t aufs -o br:/mnt/disk1/dir1:/mnt/disk2/dir1 none /mnt/fakedir

i get:

mount: wrong fs type, bad option, bad superblock on br:/mnt/disk1/dir1:/mnt/disk2/dir1,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Output of dmesg | tail is:

aufs 2-standalone.tree-20090601
aufs au_xino_create:662:mount[2811]: xino doesn't support /tmp/.aufs.xino(xfs)
aufs au_xino_create:662:mount[2850]: xino doesn't support /tmp/.aufs.xino(xfs)
aufs aufs_fill_super:767:mount[2855]: no arg

Same if you invoke with aufs.mount and if you use aufs.mount without any parameters you get:
mount.aufs:mount.aufs.c:156: : Invalid argument

Offline

#4 2009-07-14 10:33:55

gizme
Member
Registered: 2007-02-17
Posts: 11

Re: [Solved] Aufs2

Forgot to mention that it is XFS file systems on the drives if that is of any importance.

Offline

#5 2009-07-15 15:54:45

gradgrind
Member
From: Germany
Registered: 2005-10-06
Posts: 921

Re: [Solved] Aufs2

Seems to be some problem with the /tmp folder - maybe it does have something to do with xfs. You could try putting the xino stuff somewhere else (e.g. on a tmpfs), there is an option for this (see the manual), otherwise ask the developer, he's quick and friendly.

Offline

#6 2009-07-17 23:06:28

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: [Solved] Aufs2

Any updates on this? I have the same issue, also on XFS.


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#7 2009-07-18 21:28:13

gizme
Member
Registered: 2007-02-17
Posts: 11

Re: [Solved] Aufs2

Don't really understand howto put the xino stuff on a tmpfs.
But i belive you pointed me in the right direction.

If you invoke: mount -t aufs -o noxino br:/mnt/disk1/dir1:/mnt/disk2/dir1 none /mnt/fakedir it works, but is there a downside of doing this said in the manual that some stuff does not work like intended but do not know what they mean wink

Offline

#8 2009-07-19 16:23:20

gizme
Member
Registered: 2007-02-17
Posts: 11

Re: [Solved] Aufs2

If you try to put the xino stuff in the tmp folder or any other folders for that matter it does not mount but if you put it in /dev/shm there is no problem using aufs.

Doesnt this stuff usually go in the tmp folder?

Last edited by gizme (2009-07-19 16:26:34)

Offline

#9 2009-07-20 22:16:26

gizme
Member
Registered: 2007-02-17
Posts: 11

Re: [Solved] Aufs2

I will declare this solved as it works with some adjustments wink

Put this into your fstab if you want it auto mounted:
none /path/combinedir aufs dirs=/path/dir1:/path/dir2,xino=/dev/shm/aufs.xino

Offline

#10 2009-09-23 21:38:01

gn2
Member
Registered: 2009-09-23
Posts: 1

Re: [Solved] Aufs2

I can confirm this works but I use br= instead of dirs=

I mount readonly so this is my line:
none /path/combinedir aufs br=/path/dir1=ro:/path/dir2=ro,xino=/dev/shm/aufs.xino

Offline

Board footer

Powered by FluxBB