You are not logged in.

#26 2009-08-23 16:39:51

Ranguvar
Member
Registered: 2008-08-12
Posts: 2,540

Re: kde-snapshot repo

Thanks! Awesome work you're doing wink

Offline

#27 2009-08-23 16:47:24

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kde-snapshot repo

ProgDan wrote:

Hi,
I uploaded 4.3.65. Sorry for missing 4.3.64 :-) This snapshot is really cool, because everything has built. Except of kdebindings (as usual), so expect them later.

That's awesome smile

Last edited by flamelab (2009-08-23 16:47:34)

Offline

#28 2009-08-24 09:47:20

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Thanks guys! :-)

Does any of you use Kmail? I'm somehow unable to send email :-(

Offline

#29 2009-08-24 18:45:56

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: kde-snapshot repo

ProgDan wrote:

Does any of you use Kmail? I'm somehow unable to send email :-(

works fine here (imap/smtp)

Offline

#30 2009-08-24 23:02:23

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

pressh wrote:
ProgDan wrote:

Does any of you use Kmail? I'm somehow unable to send email :-(

works fine here (imap/smtp)

Hmm...what the hell it could be...

I've uploaded !!NEW!! version of networkmanager-plasmoid-svn.

Last edited by ProgDan (2009-08-24 23:07:29)

Offline

#31 2009-08-24 23:17:23

venky80
Member
Registered: 2007-05-13
Posts: 1,002

Re: kde-snapshot repo

are you also splitting packages?


Acer Aspire V5-573P Antergos KDE

Offline

#32 2009-08-25 10:14:18

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Yes I do :-)

Offline

#33 2009-08-25 11:21:59

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kde-snapshot repo

Can I ask you where we can find the PKGBUILDs ? smile

Offline

#34 2009-08-25 12:35:00

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

In official SVN repositories (http://repos.archlinux.org/viewvc.cgi/). The PKGBUILDs I use are almost same as the stable, just little changes to fit the snapshots (however I often have to build some packages manually). The best way to get the PKGBUILDs is to use Pierre's awesome buildscripts (http://git.archlinux.de/build-scripts/).

Offline

#35 2009-09-03 19:06:36

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Hi guys,
We have 4.3.66 out there waiting for you in my repo. Update, use and develop (or just report bugs...). The sources are not (at least at the time of writing this post they were not) available on the KDE FTP, they can be only retrieved as a revision 1016707 from KDESVN.

Hallowed are the Ories

Offline

#36 2009-09-18 02:24:29

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

Hi, the repo was not updated since version 1016707 sad

The kopete cannot be used after I upgrade libldap, I don't have kde svn account, so please help me to build the package

Thanks in advance

Offline

#37 2009-09-18 06:00:30

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

I'm already building 4.2.68 (I don't remember the commit). I failed to build 4.2.67 so I decided to skip it. I have already built x86_64, however building kdelibs on i686 fails. I'll update the repo ASAP.

Offline

#38 2009-09-18 22:28:43

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Btw, the libldap is in in [testing] and I don't build against [testing]. I'll rebuilt kdepim against libldap when it hits [core]. If I did it now, other users who don't use [testing] would have their system broken as you do now. Please downgrade the libldap or wait :-) It won't take much time until libldap arrives to [core].

Last edited by ProgDan (2009-09-18 22:29:20)

Offline

#39 2009-09-19 09:40:00

Mazur
Member
Registered: 2009-06-10
Posts: 103
Website

Re: kde-snapshot repo

How can I install it? pacman -S kde is installing kde from [extra].

Edit: Nevermind. I just done pacman -S kdebase-workspace kdebase-plasma etc.

Last edited by Mazur (2009-09-19 10:03:25)

Offline

#40 2009-09-19 13:04:39

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Mazur wrote:

How can I install it? pacman -S kde is installing kde from [extra].

Edit: Nevermind. I just done pacman -S kdebase-workspace kdebase-plasma etc.

You have to place [kde-4.4-unstable] BEFORE [extra] in your pacman.conf or you can try pacman -Sy kde-4.4-unstable/kde

Offline

#41 2009-09-20 01:02:28

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Hi there,
the repo was updated to 4.3.68 (svn 1024319). As usually update, test and report :-)

Offline

#42 2009-09-21 15:52:40

nuovodna
Member
Registered: 2007-12-15
Posts: 17

Re: kde-snapshot repo

first of all thanks for your hard compiling work!!

Do you compile the snapshots with qt 4.6 or qt 4.5.x ?? If you use qt 4.6, can you upload the package on server??

Thanks, you rock!

Offline

#43 2009-09-21 16:03:27

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

nuovodna wrote:

first of all thanks for your hard compiling work!!

Thanks! :-)

nuovodna wrote:

Do you compile the snapshots with qt 4.6 or qt 4.5.x ?? If you use qt 4.6, can you upload the package on server??

I use Qt 4.5.x now. I'll try next snapshot aginst Qt 4.6.

nuovodna wrote:

Thanks, you rock!

Thank you again! :-)

Offline

#44 2009-09-21 16:54:24

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kde-snapshot repo

Ι think it is unsafe to build kde with bare Qt wink KDE should be compiled with Qt build with kde patches (from qt-copy). The [extra] one has qt-copy patches (from the one from gitorious).

Offline

#45 2009-09-21 19:43:25

nuovodna
Member
Registered: 2007-12-15
Posts: 17

Re: kde-snapshot repo

with qt 4.6 the kde performance will rock...the painting ll be very very fast and all the DE ll be faster (i read it on KDE Planet some days ago...)

Offline

#46 2009-09-21 19:56:44

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

KDE already rocks, but if it will be really faster then now, I'll do my best to build it on Qt 4.6 ;-) Man, I love Qt&KDE...

Offline

#47 2009-09-21 20:19:02

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kde-snapshot repo

Trust me. Wait until qt-copy repo passes to 4.6 wink

Offline

#48 2009-09-21 21:36:37

syms
Member
Registered: 2008-12-25
Posts: 296

Re: kde-snapshot repo

ProgDan wrote:

KDE already rocks, but if it will be really faster then now, I'll do my best to build it on Qt 4.6 ;-) Man, I love Qt&KDE...

Qt 4.6 has improved mostly QGraphicsview performance,  and Qgraphicsview can be found on almost all kde areas. Though i dont believe that there will be speed miracle, you should see performance improvement. Aaron Seigo said that kde with qt 4.6 runs good on 800 mhz computer.

Offline

#49 2009-09-22 08:19:23

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

ProgDan wrote:

Hi there,
the repo was updated to 4.3.68 (svn 1024319). As usually update, test and report :-)

error occured when upgrading:

error: failed to commit transaction (conflicting files)
kdelibs: /usr/share/dbus-1/interfaces/org.kde.NotificationItem.xml exists in filesystem
kdelibs: /usr/share/dbus-1/interfaces/org.kde.NotificationItemWatcher.xml exists in filesystem

After I moved these two files away, I could upgrade, thanks wink

Offline

#50 2009-09-22 11:13:40

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

ffjia wrote:
ProgDan wrote:

Hi there,
the repo was updated to 4.3.68 (svn 1024319). As usually update, test and report :-)

error occured when upgrading:

error: failed to commit transaction (conflicting files)
kdelibs: /usr/share/dbus-1/interfaces/org.kde.NotificationItem.xml exists in filesystem
kdelibs: /usr/share/dbus-1/interfaces/org.kde.NotificationItemWatcher.xml exists in filesystem

After I moved these two files away, I could upgrade, thanks wink

You should not delete files in your filesystem...

First pacman has the ability to watch recursively to which package a file belongs.... I think something like pacman -Qo pathtofile...

After that you could consider if this will make some ugly to your system. And at last, don't delete, just take pacman - xx "f" option, it will force pacman to silently override these files!

Offline

Board footer

Powered by FluxBB