You are not logged in.

#51 2009-09-23 08:41:59

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

Thanks Solid1986Snake, hehe

I didn't delete the two files, I just moved the to my $HOME/

Yeah, I should run pacman -Qo pathtofile, first, thank you

Offline

#52 2009-09-23 10:00:07

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Well there is always a problem with libraries/scripts moving between various packages/folders. It is a devel version and you must count on it.
Using pacman -Sf in is in case of kde-4.4-unstable safe (mostly).

Offline

#53 2009-09-23 17:05:54

linopolus
Member
From: /home/linopolus
Registered: 2009-01-08
Posts: 32

Re: kde-snapshot repo

Nice work, but i have a error on starting kontact and the parts of them:

% kontact
kontact: error while loading shared libraries: libakonadi-contact.so.4: cannot open shared object file: No such file or directory
(127)linopolus in ~% kmail
kmail: error while loading shared libraries: libmessagelist.so.4: cannot open shared object file: No such file or directory
(127)linopolus in ~%

I don't know the commands of the other parts but i suggest they also have errors. Looks like a package mistake for me. Any idea?


Thanks for reading, linopolus

Offline

#54 2009-09-23 17:20:28

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Yeah, I missed some libraries in the package. The update will come soon, but I have a problems with my 32bit chroot at the moment and I'm unable to build anything there.
Please be patient. Thank you

Offline

#55 2009-09-24 00:10:17

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Hi guys,
snapshot of 4.3.69 was released. There is already stable qt-kde patched sources for Qt 4.6, so I'll try to make build it on Qt 4.6. However it requires for example openssl 1.0.0 (currently beta, stable expected soon), so I have to prepare much more packages then usually and it will take me some time.
I don't have much free disk space and therefor I'm unable to keep older packages on my disk, so I'm sorry I won't rebuilt the current kdepimlibs to provide the correct libs in 4.3.68.

Offline

#56 2009-09-24 02:47:58

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

ProgDan wrote:

Hi guys,
snapshot of 4.3.69 was released. There is already stable qt-kde patched sources for Qt 4.6, so I'll try to make build it on Qt 4.6. However it requires for example openssl 1.0.0 (currently beta, stable expected soon), so I have to prepare much more packages then usually and it will take me some time.
I don't have much free disk space and therefor I'm unable to keep older packages on my disk, so I'm sorry I won't rebuilt the current kdepimlibs to provide the correct libs in 4.3.68.

That means I have to upgrade qt and openssl to run 4.3.69?

Offline

#57 2009-09-24 05:20:37

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Well - not after all :-) I spent a LOT of time by trying to build Qt 4.6 and I'm still missing something. So I'll build it as usually against our stable Qt 4.5 and maybe later make a rebuilt on Qt 4.6.
Ad the updating: I have prepared both packages (openssl and Qt) to be stored in /opt and not to conflict with the official stable packages.

Offline

#58 2009-09-25 09:23:34

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

So, other apps depend on qt 4.5 will still work?

Offline

#59 2009-09-25 09:43:07

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kde-snapshot repo

No, they 'll need to be rebuilt. Only those built upon 4.6 will work.

Offline

#60 2009-09-25 12:38:43

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

The upcomming update will still be on Qt 4.5, so no worry about it. If I some day manage to compile Qt 4.6, I'll make it as a separate package and put it to /opt so it will not conflict with Qt 4.5 and I'll build KDE against it. Then KDE will use Qt 4.6 and other application will use Qt 4.5.
This will satisfy both - those who want Qt 4.6 and those who don't want to rebuild all their beloved apps :-)

Offline

#61 2009-09-27 17:38:37

linopolus
Member
From: /home/linopolus
Registered: 2009-01-08
Posts: 32

Re: kde-snapshot repo

ProgDan wrote:

Yeah, I missed some libraries in the package. The update will come soon, but I have a problems with my 32bit chroot at the moment and I'm unable to build anything there.
Please be patient. Thank you

Where is the PKGBUILD for kdelibs so I can build it self?
WHAT have i to build?

P.S.: my english... sad


Thanks for reading, linopolus

Offline

#62 2009-09-27 19:18:14

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Updated to 4.3.69. I hope it will all work :-)

linopolus: I'll try to pack the PKGBUILDs and upload them. I'll post a link here later.

Offline

#63 2009-09-28 14:15:37

nuovodna
Member
Registered: 2007-12-15
Posts: 17

Re: kde-snapshot repo

hi ProgDan. The last packages uploaded on i686 are compiled with qt 4.5.x or with qt 4.6??
Thanks

i m excited for qt 4.6: everyone in every web corner says that it rocks!!!

Offline

#64 2009-09-28 14:21:58

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Hi,
it's compiled with Qt 4.5.2 (both archs).
Don't worry guys, I'll write it with huge bold letters when I'll upload KDE with Qt 4.6 :-)

Offline

#65 2009-09-29 05:39:13

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: kde-snapshot repo

upgrade to 4.3.69, x86_64, thanks

Finally, I can use kopete now, though kopete icon of system tray become a question mark...

Offline

#66 2009-09-29 09:14:19

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

ffjia wrote:

...though kopete icon of system tray become a question mark...

Huh, I'll try to find it  :-)

Offline

#67 2009-10-03 19:25:50

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

Hi,

I get a 404 error on all kdepim stuff... seems to be something wrong in the repo atm

Offline

#68 2009-10-03 19:45:35

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Yeah, there is definitely something missing in x86_64 repo. Unfortunately I don't have enough disk space to store the packages locally and therefor I would have to rebuild them now. But there is a better option: wait until I build 4.3.70 :-) The compilation of x86_64 is already running and I'll update it ASAP (eg. I'll not wait for i686 to update both at the same time).
Sorry for that inconvenience.

Offline

#69 2009-10-04 18:25:32

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

Thanks for the 70 packages big_smile Trunk seems to be in a very stable state at the moment....

next version will will have more failures with qt 4.6...

Offline

#70 2009-10-04 19:25:41

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

I've updated x86_64 repo to 4.3.70, i686 will follow later tonight. Built against Qt 4.5.

Offline

#71 2009-10-04 19:54:14

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

Would you mind to share your PKGBUILD s on git? Collaborative work is always good wink

Just two problems this time... your kdepim meta package is broken.... kdepim-kontactinterfaces is missing....
And two little conflicts with kdelibs and kdelibs-experimental, but no problem so far....

Againt which java did you compile strigi? openjdk or sunjre? Just to install the right package...

Offline

#72 2009-10-04 21:05:31

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Solid1986Snake wrote:

Would you mind to share your PKGBUILD s on git? Collaborative work is always good wink

Well, that should not be a problem at all. I'll do it tomorrow or so.

Solid1986Snake wrote:

Just two problems this time... your kdepim meta package is broken.... kdepim-kontactinterfaces is missing....

Yeah, it was moved to kdelibs, I just forgot to update meta packages. Fixed & uploaded

Solid1986Snake wrote:

And two little conflicts with kdelibs and kdelibs-experimental, but no problem so far....

kdelibs-experimental was merged to kdelibs so it's no longer necessary. I think I put it into conflicts=() and provides=() in kdelibs....

Solid1986Snake wrote:

Againt which java did you compile strigi? openjdk or sunjre? Just to install the right package...

I use strigi from [extra] and it does not even requires Java...

Thank you very much for all your remarks!

Offline

#73 2009-10-04 21:33:43

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

Well you need java for the nepomuk/strigi/sesame2 backend.

I think you should compile against openjdk6 and it will be included.

At last, i can't get amarok to work at the moment, seems to be a fault in kdelis and qtscriptgenerator, anyone else with the same problems?

But very clean packages you copmiled here.... impressive for such a huge project in development (and naturally for your work)

Offline

#74 2009-10-04 21:44:05

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: kde-snapshot repo

Solid1986Snake wrote:

Well you need java for the nepomuk/strigi/sesame2 backend.
I think you should compile against openjdk6 and it will be included.

Oh, I see - so Strigi is build against openjdk6 1.6.1.

Solid1986Snake wrote:

At last, i can't get amarok to work at the moment, seems to be a fault in kdelis and qtscriptgenerator, anyone else with the same problems?

Maybe it will be necessary to rebuilt Amarok against new kdelibs...?

Solid1986Snake wrote:

But very clean packages you copmiled here.... impressive for such a huge project in development (and naturally for your work)

Well, I must say that this time the compilation was absolutely smooth, all packages compiled without any problem, which does not happen very often :-)

Offline

#75 2009-10-04 22:17:36

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: kde-snapshot repo

I am still working on the amarok issue.... i got it compiled now, but it segfaults on scanning many items of my collection...

Maybe you can try it out own your own?

Offline

Board footer

Powered by FluxBB