You are not logged in.

#1 2009-07-23 01:35:24

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Conky doesn't work well under LXDE

I'm using LXDE and PCManFM is managing my desktop. when I run Conky the icons on desktop are unclickable:(. I don't know how to make PCManFM and Conky work together. Anyone has any ideas?

Offline

#2 2009-07-23 01:48:23

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,050
Website

Re: Conky doesn't work well under LXDE

Can you post the top half (before TEXT) of your .conkyrc?

Last edited by jasonwryan (2009-07-23 01:48:42)


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2009-07-23 02:20:38

firecat53
Member
From: Sammamish, Wa
Registered: 2007-05-14
Posts: 1,447
Website

Re: Conky doesn't work well under LXDE

Interesting .... just noticed something similar. I can click the icons, but when I do, conky disappears and has to be killed and restarted to be visible again.

background yes
out_to_console no
use_xft yes
xftfont dejavusans:size=18
xftalpha 1.0
update_interval 2
own_window yes
own_window_type desktop
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager 
double_buffer yes
minimum_size 800
stippled_borders 0
default_outline_color white
alignment bottom_left
TEXT
${if_match "$mpd_status" == "Playing"}${goto 50}${font URW Bookman L:Italic:size=26}${color light gray}${mpd_artist}
${goto 100}${voffset -20}${font URW Bookman L:Italic:size=16}${color slate gray}${mpd_title}${endif}
${if_match "$mpd_status" != "Playing"}${voffset -40}${goto 50}${font URW Bookman L:Italic:size=26}${color light gray}Music Paused${endif}

Scott

Offline

#4 2009-07-23 02:24:20

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,050
Website

Re: Conky doesn't work well under LXDE

Try adding own_window_type override - that might help...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2009-07-23 04:16:05

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Re: Conky doesn't work well under LXDE

Thanks for you help. This is my conkyrc.

use_xft        yes
xftfont        WenQuanYi Bitmap Song: size=8 :bold

update_inteval    3

background    no
double_buffer    yes

TEXT
${exec echo "Hello Conky!"}

I tried the following code

own_window yes
own_window_type override

but it won't help.

Offline

#6 2009-07-23 04:18:31

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Re: Conky doesn't work well under LXDE

And if I kill pcmanfm conky will work perfectly.

Offline

#7 2009-07-23 04:24:57

droog
Member
Registered: 2004-11-18
Posts: 877

Re: Conky doesn't work well under LXDE

RichSelian wrote:

And if I kill pcmanfm conky will work perfectly.

lxde, conky and pcmanfm, I think if found your problem!

Offline

#8 2009-07-23 06:58:05

mandog
Member
From: Peru
Registered: 2008-09-17
Posts: 204

Re: Conky doesn't work well under LXDE

I'm using LXDE set up as per the Wiki I've just installed conky using my configered  conkyrc file that I use on all distros guess what it works perfect with Pcman/openbox,
I suggest you go to the Arch Wiki, desktop envirements LXDE, and check you have installed all the required components on the list I installed LXDE, 3 weeks ago following the Wiki and all works flawlessly for me.
This is my conkyrc, it lives in the home directory this may help you may need to edit a few lines like Arch instead of Parsix



# Parsix-CONKY
#
## A comprehensive conky script, configured for use on
# Ubuntu / Debian Gnome, without the need for any external scripts.
#
# Based on conky-jc and the default .conkyrc.
# INCLUDES:
# - tail of /var/log/messages
# - netstat connections to your computer
#
# -- Pengo (conky@pengo.us)
#

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# fiddle with window
use_spacer yes
use_xft no

# Update interval in seconds
update_interval 2.0

# Minimum size of text area
# minimum_size 250 5

# Draw shades?
draw_shades no

# Text stuff
draw_outline yes # amplifies text if yes
draw_borders no
font arial


uppercase no # set to yes if you want all text to be in uppercase

# Stippled borders?
stippled_borders 3

# border margins
border_margin 9

# border width
border_width 10

# Default colors and also border colors, grey90 == #e5e5e5
default_color grey

own_window_colour brown
own_window_transparent yes

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
gap_x 30
gap_y 40

# stuff after 'TEXT' will be formatted on screen

TEXT
$color
${color #88ECE0}SYSTEM ${hr 2}$color
$nodename $sysname $kernel on $machine
${color #88ECE0}CPU ${hr 2}$color
${freq}MHz   Load: ${loadavg}   Uptime: ${uptime}
${color}Core 1 Usage:$color ${alignc} ${cpu cpu1}% ${color}${cpubar cpu1}
${color}Core 2 Usage:$color ${alignc} ${cpu cpu2}% ${color}${cpubar cpu2}
${cpugraph 000000 DFEC88}
NAME             PID       CPU%      MEM%
${top name 1} ${top pid 1}   ${top cpu 1}    ${top mem 1}
${top name 2} ${top pid 2}   ${top cpu 2}    ${top mem 2}
${top name 3} ${top pid 3}   ${top cpu 3}    ${top mem 3}
${top name 4} ${top pid 4}   ${top cpu 4}    ${top mem 4}

${color #88ECE0}MEMORY / DISK ${hr 2}$color
RAM:   $memperc%   ${membar 6}$color
Swap:  $swapperc%   ${swapbar 6}$color

Root:  ${fs_free_perc /}%   ${fs_bar 6 /}$color
Home:  ${fs_free_perc /home}%   ${fs_bar 6 /home}$color

${color}DiskI/O:${color}${diskio}
${diskiograph 000000 88D5EC}

${color #88ECE0}NETWORK (${addr eth0}) ${hr 2}$color
Down: $color${downspeed eth0} k/s ${alignr}Up: ${upspeed eth0} k/s
${downspeedgraph eth0 25,140 000000 ff0000} ${alignr}${upspeedgraph eth0
25,140 000000 00ff00}$color
Total: ${totaldown eth0} ${alignr}Total: ${totalup eth0}
Inbound: ${tcp_portmon 1 32767 count} Outbound: ${tcp_portmon 32768
61000 count}${alignr}Total: ${tcp_portmon 1 65535 count}

Last edited by mandog (2009-07-23 07:07:50)


I'm dyslexic Please do not complain about puntuation or spelling and remember most dyslexic people have above average iq.

Offline

#9 2009-07-23 07:33:04

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Re: Conky doesn't work well under LXDE

mandog wrote:

I'm using LXDE set up as per the Wiki I've just installed conky using my configered  conkyrc file that I use on all distros guess what it works perfect with Pcman/openbox,
I suggest you go to the Arch Wiki, desktop envirements LXDE, and check you have installed all the required components on the list I installed LXDE, 3 weeks ago following the Wiki and all works flawlessly for me.
This is my conkyrc, it lives in the home directory this may help you may need to edit a few lines like Arch instead of Parsix



# Parsix-CONKY
#
## A comprehensive conky script, configured for use on
# Ubuntu / Debian Gnome, without the need for any external scripts.
#
# Based on conky-jc and the default .conkyrc.
# INCLUDES:
# - tail of /var/log/messages
# - netstat connections to your computer
#
# -- Pengo (conky@pengo.us)
#

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# fiddle with window
use_spacer yes
use_xft no

# Update interval in seconds
update_interval 2.0

# Minimum size of text area
# minimum_size 250 5

# Draw shades?
draw_shades no

# Text stuff
draw_outline yes # amplifies text if yes
draw_borders no
font arial


uppercase no # set to yes if you want all text to be in uppercase

# Stippled borders?
stippled_borders 3

# border margins
border_margin 9

# border width
border_width 10

# Default colors and also border colors, grey90 == #e5e5e5
default_color grey

own_window_colour brown
own_window_transparent yes

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
gap_x 30
gap_y 40

# stuff after 'TEXT' will be formatted on screen

TEXT
$color
${color #88ECE0}SYSTEM ${hr 2}$color
$nodename $sysname $kernel on $machine
${color #88ECE0}CPU ${hr 2}$color
${freq}MHz   Load: ${loadavg}   Uptime: ${uptime}
${color}Core 1 Usage:$color ${alignc} ${cpu cpu1}% ${color}${cpubar cpu1}
${color}Core 2 Usage:$color ${alignc} ${cpu cpu2}% ${color}${cpubar cpu2}
${cpugraph 000000 DFEC88}
NAME             PID       CPU%      MEM%
${top name 1} ${top pid 1}   ${top cpu 1}    ${top mem 1}
${top name 2} ${top pid 2}   ${top cpu 2}    ${top mem 2}
${top name 3} ${top pid 3}   ${top cpu 3}    ${top mem 3}
${top name 4} ${top pid 4}   ${top cpu 4}    ${top mem 4}

${color #88ECE0}MEMORY / DISK ${hr 2}$color
RAM:   $memperc%   ${membar 6}$color
Swap:  $swapperc%   ${swapbar 6}$color

Root:  ${fs_free_perc /}%   ${fs_bar 6 /}$color
Home:  ${fs_free_perc /home}%   ${fs_bar 6 /home}$color

${color}DiskI/O:${color}${diskio}
${diskiograph 000000 88D5EC}

${color #88ECE0}NETWORK (${addr eth0}) ${hr 2}$color
Down: $color${downspeed eth0} k/s ${alignr}Up: ${upspeed eth0} k/s
${downspeedgraph eth0 25,140 000000 ff0000} ${alignr}${upspeedgraph eth0
25,140 000000 00ff00}$color
Total: ${totaldown eth0} ${alignr}Total: ${totalup eth0}
Inbound: ${tcp_portmon 1 32767 count} Outbound: ${tcp_portmon 32768
61000 count}${alignr}Total: ${tcp_portmon 1 65535 count}

Thanks. I have tried your configuration file. But conky will not appear until I kill pcmanfm.

Offline

#10 2009-07-23 07:42:01

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Re: Conky doesn't work well under LXDE

I also tried

own_window_type normal

It can make conky work with pcmanfm. But once I press Super+D to minimize all windows, conky is also minimized and I can't read conky information.

Offline

#11 2009-07-23 09:25:45

mandog
Member
From: Peru
Registered: 2008-09-17
Posts: 204

Re: Conky doesn't work well under LXDE

You really need the check your setuup is correct as I'm using a vanilla setup as per the Arch Wiki on 2 desktops and a laptop with absolutly no problems all I do is follow the Wiki and use GDM, not slim, make sure fam is not installed and Gamin is thats it, Gdm needs to be in the RC config daemons file and it all works. I have never had to install Openbox as its installed as a dependency to LXDE this is 1 of my rc. conf file entries (syslog-ng @network dbus hal wicd rpcbind alsa gdm) this  my entry in home .xinitrc file,
setxkbmap gb
exec ck-launch-session startlxde
I hope this helps
Or you could do in the terminal # pacman -Sy lxde gamin, that will reinstall LXDE as per my setup this is what it installs

    *  PCManFM: File manager, provides desktop icon and wallpaper.
    * LXPanel: Feature-rich desktop panel (if you have problems with this version, use lxpanel-svn from aur)
    * LXSession: Standard-compliant X11 session manager with shutdown/reboot/suspend supports via HAL and gdm

    (There are some bugs in lxsession related to session management. lxsession-lite is a version of lxsession which does not have the session management capability. The stability of lxsession-lite is better than lxsession, however it can not save and restore sessions. Thus it is recommended to use lxsession-lite till the problems in lxsession are fixed.)

    * LXAppearance: LXAppearance is a new feature-rich GTK+ theme switcher able to change GTK+ themes, icon themes, and fonts used by applications
    * Openbox: Lightweight, standard-compliant, and highly-configurable window manager (This is not developed by LXDE Project, but it's used as default window manager). This can be replaced by any other window manager like icewm, fluxbox, metacity, ...etc.
    * GPicView: A very simple, fast, and lightweight image viewer featuring immediate startup.
    * Leafpad: Lightweight and simple text editor(This is not developed by LXDE Project, but it's suggested as the default text editor).
    * XArchiver: Lightweight, fast, and desktop-independent gtk+-based file archiver (This is not developed by LXDE Project, but you are suggested to use this as default archiver).
    * LXNM (Still under development. Available through AUR): Lightweight network manager for LXDE supporting wireless connections (Linux-only)

Last edited by mandog (2009-07-23 09:36:14)


I'm dyslexic Please do not complain about puntuation or spelling and remember most dyslexic people have above average iq.

Offline

#12 2009-07-23 16:07:57

firecat53
Member
From: Sammamish, Wa
Registered: 2007-05-14
Posts: 1,447
Website

Re: Conky doesn't work well under LXDE

Mandog: Just so we're clear -- you can click on the 'My Documents' icon and right click on the desktop and your conky stays visible? I tried the own_window override setting and it didn't seem to work. Hmmm, well if it works for you I'll go back and try again.

Scott

Offline

#13 2009-07-24 07:23:19

mandog
Member
From: Peru
Registered: 2008-09-17
Posts: 204

Re: Conky doesn't work well under LXDE

Yes as I said before when I click on my documents conky does NOT disapear nor when I right click on desktop, or with compiz, Its strange to me that people are having problems.

Last edited by mandog (2009-07-24 07:25:16)


I'm dyslexic Please do not complain about puntuation or spelling and remember most dyslexic people have above average iq.

Offline

#14 2009-07-24 08:44:43

RichSelian
Member
From: China
Registered: 2009-03-14
Posts: 43

Re: Conky doesn't work well under LXDE

I have searched the problem on Google. Maybe it is just a bug. Anyway, I have decided not to use PCManFM to manage my desktop any more.

Last edited by RichSelian (2009-07-24 11:32:39)

Offline

Board footer

Powered by FluxBB