You are not logged in.

#1 2009-08-02 03:42:52

gamgam
Member
Registered: 2009-06-06
Posts: 15

FreeNX authentication [SOLVED]

Hey guys,

I've been trying to set up Freenx on my archlinux computer to control it using a winxp comp (using no machine)
ive been following the arch wiki (http://wiki.archlinux.org/index.php/FreeNX)
except i run into an issue, im not able to find the public keys in /opt/NX/home/nx/.ssh/client.id_dsa.key. The .ssh directory does not even exist

I am assuming that because i have not copied the key to my windows computer, i am getting the following authentication error
NX> 203 NXSSH running with pid: 708
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.0.8 on port: 9000
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Does anyone know how to solve this?

Thanks in advance

Last edited by gamgam (2009-08-06 14:10:01)

Offline

#2 2009-08-02 09:52:46

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

Never tried it myself, but the wiki (http://wiki.archlinux.org/index.php/FreeNX) does tell you how to generate a set of random keys. Perhaps you should try that. Personally I just use the default NoMachine key (again how to is in the wiki).

Offline

#3 2009-08-02 10:45:57

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

Hey, yeah ive been trying to get that working too
i ran:
/opt/NX/bin/nxsetup --install --setup-nomachine-key --clean --purge

as per the wiki

but when trying to connect im still getting this error
...
RSA key fingerprint is 30:e2:e8:df:b8:c0:76:39:9e:d4:32:c0:9a:b7:30:1e.
Are you sure you want to continue connecting (yes/no)?
Warning: Permanently added '[supers.homeunix.com]:9000,[203.171.76.131]:9000' (RSA) to the list of known hosts.
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Any ideas?

Offline

#4 2009-08-02 10:53:27

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: FreeNX authentication [SOLVED]

Have you added the configuration in /etc/hosts.allow?

Read http://wiki.archlinux.org/index.php/SSH … _others_in

Last edited by arkham (2009-08-02 10:54:03)


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#5 2009-08-02 11:15:01

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

Well, keep in mind arkham's reminder - point is, you must be able to ssh to your server.

If your nomachine-key is installed, you should have /opt/NX/home/nx/.ssh/client.id_dsa.key now. When you run your nxclient, under "configure" you should see in the server section a button that says "key". That key should be the same as your /opt/NX/home/nx/.ssh/client.id_dsa.key. If not, click default (I think that gives you the default nomachine key) or somehow copy it over from your server. Basically they should match.

Offline

#6 2009-08-02 11:41:03

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

Hey guys,
at the moment i am able to SSH into my computer
I have checked that the nomachine client is also using the default key. I am not able to check whether the key on the client is the same as on the server though, i am still not able to locate client.id_dsa.key
the furthest i can go /opt/NX/home/

Offline

#7 2009-08-02 12:35:30

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

Something seems wrong then. Perhaps a re-install is in order? Or, better, uninstall, delete /opt/NX and then pacman -Sy freenx.

Offline

#8 2009-08-02 14:26:41

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

hey,

yeah i gave that a go, but nothing changed =[

Offline

#9 2009-08-03 05:09:32

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

Well, it is weird that you don't have /opt/NX/home/nx because it probably means that the setup failed and there seems to be no reason why nxsetup should fail to setup your nx properly. Perhaps you should try "/opt/NX/bin/nxsetup --install --clean --purge " and see if there are any error messages.

Basically a user "nx" is created, and a group "nx" also. You can check /etc/group, /etc/passwd to see if it is done. Then the nx home is created in /opt/NX/home and in it client.id_dsa.key is created in .ssh. I suppose you can manually do all these. The contents of client.id_dsa.key should be the same as the dsa key in the nxclient that I spoke about earlier. Beyond this I cannot help you - in my experience the setup is pretty straightforward and my only issue is the publickey which I solved by using the nomachine key. Hope this helps.

Offline

#10 2009-08-03 06:17:04

Wittfella
Member
From: Australia
Registered: 2008-05-27
Posts: 462

Re: FreeNX authentication [SOLVED]

Are you sure you installed 'freenx', not just 'nxserver'?

Last edited by Wittfella (2009-08-03 06:17:18)

Offline

#11 2009-08-03 07:22:21

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

Hey guys,
when i do /opt/NX/bin/nxsetup --install --clean --purge, i get the following output:

Removing special user "nx" ...done
Removing session database ...done
Removing logfile ...done
Removing configuration files ...done
Setting up /opt/NX/etc ...done
Generating public/private dsa key pair.
Your identification has been saved in /opt/NX/etc/users.id_dsa.
Your public key has been saved in /opt/NX/etc/users.id_dsa.pub.
The key fingerprint is:
89:73:3d:3b:38:c5:c4:a4:69:6a:0d:13:21:b3:e2:6d root@arch
The key's randomart image is:
+--[ DSA 1024]----+
|    o o.  .      |
|     + . =       |
|  . . o + o      |
| . o   B =       |
|  . E = S =      |
|   . . o o o     |
|        o o      |
|         . .     |
|                 |
+-----------------+
Setting up /opt/NX/var/db ...done
Setting up /var/log/nxserver.log ...done
Setting up special user "nx" ...passwd: unlocking the password would result in a passwordless account.
You should set a password with usermod -p to unlock the password of this account.

I examined /etc/passwd and /etc/group. I was able to find NX in the files.


Do you guys see any problem thus far?

Last edited by gamgam (2009-08-03 07:25:47)

Offline

#12 2009-08-03 13:10:52

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

Seems OK. Point is, do you now have the /opt/NX/home/nx folder? If not, the only way it seems is to create the folder yourself then. Then add the .ssh folder inside. Then the key inside .ssh. Look up my previous post. You can find the permissions for the folders/files in the freenx wiki. Good luck.

Offline

#13 2009-08-03 23:35:31

Teshadael
Member
Registered: 2008-04-06
Posts: 29

Re: FreeNX authentication [SOLVED]

I'm also having a hard time getting freenx to work.
After installing, I have the /otp/NX/home/nx directory, but no .ssh/
I tried generating new keys as well as the public one, but noticed after running nxsetup, it doesn't seem to recreate the /opt/NX/home/nx directory.
I tried creating the .ssh folder manually and the client.id_dsa.key file by copying the key from the client's info, but still missing the other two files that are suppose to be there.
I set the permissions as stated in the wiki, but still get authentication error.
If I take the /opt/NX/etc/users.id_dsa* keys and try to put them in nx/.ssh/client.id_dsa.key and copy them to the client, then I try to connect and get a message saying "DSA key is corrupted or has been protected with a passphrase".
Not sure what to try next.

Offline

#14 2009-08-04 07:04:45

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

Hey stryder,

Thanks for the help so far

Before i try your suggestion i was wondering if you may know if my issue is related my sshd_config file.
i scanned through the file again and noticed
#PublickeyAuthentication yes
#authorizekeyfile .ssh/authorized_keys

are these meant to be enabled?

Offline

#15 2009-08-04 10:01:13

stryder
Member
Registered: 2009-02-28
Posts: 498

Re: FreeNX authentication [SOLVED]

OK, you're in luck because for some reason my arch server failed and I had to reinstall, and I had to reinstall freenx.

1. If you just installed freenx, /opt/NX/home/nx/.ssh/clientwhatever exists. The setup is OK.
2. If you follow the wiki's instructions to install the nomachine key, the nx folder gets deleted.
3. What you need to do is to run /opt/NX/bin/nxsetup --install --setup-nomachine-key
4. Or, if you only want everything setup (but using unique key) then run --install only.

Check your hosts.deny/hosts.allow to ensure that ssh is allowed. My hosts.deny is empty.
Read http://bbs.archlinux.org/viewtopic.php?id=71302 for setting the sshd_config listen address.

As for your question on sshd_config,

my "PubkeyAuthentication yes" is uncommented.
and I also have "UsePAM yes" uncommented.

Don't forget to restart /etc/rc.d/sshd. My nxserver is up and running. Hope yours will be too. smile

Offline

#16 2009-08-05 08:33:18

serrghi
Member
From: Bergen, NO
Registered: 2008-02-12
Posts: 100
Website

Re: FreeNX authentication [SOLVED]

Ive written a small post about the subject on my blog if anyones interessted.. http://www.unyttig.info/2009/08/05/tuto … eenx-wave/


Unyttig.INFO - Your source to not so useless information
My github - Various configs, dotfiles and nifty scripts

Offline

#17 2009-08-06 13:53:02

gamgam
Member
Registered: 2009-06-06
Posts: 15

Re: FreeNX authentication [SOLVED]

Hey guys,
thanks so far i've been able to get that damn /.ssh folder
im still working on it now, thanks for all the help so far

ps. serrighi your tutorial is very indeph, ill be sure to give it a look before i continue smile

Solved smile, thanks guys
running /opt/NX/bin/nxsetup --install --setup-nomachine-key, and then copying the key files across the client worked like a charm

freenx feels faster and more responsive to vnc at the moment, ill have to keep playing with it smile
thanks guys

Last edited by gamgam (2009-08-06 14:09:48)

Offline

#18 2010-03-21 05:18:42

smartboyathome
Member
From: $HOME
Registered: 2007-12-23
Posts: 334
Website

Re: FreeNX authentication [SOLVED]

Well, I am trying to set up FreeNX on my Arch Linux box to go to my new netbook, but no matter what I do it seems that FreeNX absolutely will not connect. Whenever I run the client on my Windows machine, I get "authentification failed", even though I know my password is correct and that I can ssh just fine into it using Putty. I can't find anything useful in the log file on my Windows machine, but I will post it anyway, and there doesn't seem to be any log files on the Arch Linux box itself.

Log file:

nxwinOpenLogFile: Redirected the standard error to the log file.
nxwinOpenLogFile: NX_TEMP is set to [C:\Users\Alex\NXC495~1/D-Alex-PC-8503A9EAFF381C962F9570B664C8042C].
nxwinOpenLogFile: Using log file [C:\Users\Alex\NXC495~1/D-Alex-PC-8503A9EAFF381C962F9570B664C8042C/winlog].
ddxProcessArgument - Initializing default screens
winInitializeDefaultScreens - w 1024 h 600
winInitializeDefaultScreens - Returning
OsVendorInit - Creating bogus screen 0
_XSERVTransmkdir: Owner of C:\Users\Alex\NXC495~1/D-Alex-PC-8503A9EAFF381C962F9570B664C8042C/.X11-unix should be set to root
(EE) Unable to locate/open config file
InitOutput - Error reading config file
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - Allowing PrimaryDD
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 0000001f
InitOutput - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
winSetEngine - Using Shadow DirectDraw NonLocking
winAdjustVideoModeShadowDDNL - Using Windows display depth of 32 bits per pixel
winCreateBoundingWindowFullscreen - User w: 1024 h: 600
winCreateBoundingWindowFullscreen - Current w: 1024 h: 600
Info: Display running with pid '1192' and handler '0x40500'.
winFinishScreenInitFB - Device blending capability [0].
winCreatePrimarySurfaceShadowDDNL - Creating primary surface
winCreatePrimarySurfaceShadowDDNL - Created primary surface
winCreatePrimarySurfaceShadowDDNL - Attached clipper to primary surface
winAllocateFBShadowDDNL - lPitch: 4096
winAllocateFBShadowDDNL - Created shadow pitch: 4096
winAllocateFBShadowDDNL - Created shadow stride: 1024
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowDDNL - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
winCreateDefColormap - Deferring to fbCreateDefColormap ()
winFinishScreenInitFB starting winInitWM
winFinishScreenInitFB After winInitWM
color offset: 10 8 0
winFinishScreenInitFB - returning
winScreenInit - returning
InitOutput - Returning.
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
(EE) No primary keyboard configured
(==) Using compiletime defaults for keyboard
names.keymap=(null)Rules = "xfree86" Model = "pc101" Layout = "us" Variant = "(null)" Options = "(null)"
Couldn't load XKB keymap, falling back to pre-XKB keymap
winBlockHandler - Releasing pmServerStarted
winBlockHandler - pthread_mutex_unlock () returned
Dispatch: Exiting from the dispatcher with exception [2].

Anyone got any ideas?

Offline

Board footer

Powered by FluxBB