You are not logged in.

#1 2009-08-04 10:00:33

K0tuk
Member
Registered: 2009-04-06
Posts: 125

xcompmgr glitches

Hi!

I`m using Openbox as a standalone DE, with xcompmgr and conky. No KDE apps (i know they don`t like xcompmgr and vice-versa). The problem is that after some time (2-3 hours) xcompmgr starts glitching. Windows overlay, some become transparent etc. If is simply kill it in task-manager and restart again, it works normally for 2-3 hours, and then it starts all over again.  I start xcompmgr with xcompmgr -cCfF -t-5 -l-5 -r4.2 -o.55 -D3.

This is how it looks like:
http://img179.imageshack.us/img179/7590 … 0x1200.png

Last edited by K0tuk (2009-08-04 10:01:13)

Offline

#2 2009-08-04 14:08:37

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,273

Re: xcompmgr glitches

xcompmgr is by no means perfect. I have written a small script to restart xcompmgr and bound it to a suitable key. Thus, as soon as there are any misfunctions (usually windows build up becomes slow and ruggy) I simply press that key and everything runs smoothly again for some time.


To know or not to know ...
... the questions remain forever.

Offline

#3 2009-11-01 11:33:35

Wikimig
Developer
From: France
Registered: 2004-12-10
Posts: 77
Website

Re: xcompmgr glitches

K0tuk wrote:

Hi!

I`m using Openbox as a standalone DE, with xcompmgr and conky. No KDE apps (i know they don`t like xcompmgr and vice-versa). The problem is that after some time (2-3 hours) xcompmgr starts glitching. Windows overlay, some become transparent etc. If is simply kill it in task-manager and restart again, it works normally for 2-3 hours, and then it starts all over again.  I start xcompmgr with xcompmgr -cCfF -t-5 -l-5 -r4.2 -o.55 -D3.

This is how it looks like:
http://img179.imageshack.us/img179/7590 … 0x1200.png

+1 here

It used to work but doesn't any more. And I can't find any log or output!

Offline

#4 2009-11-01 20:26:41

Raffles10
Member
From: London, UK
Registered: 2009-05-09
Posts: 115

Re: xcompmgr glitches

I've had similar experiences with xcompmgr, running up the cpu after 3 - 4 hrs and slowing everything down. I'm now using xcompmgr-dana (in AUR) and have had no problems, works smoothly. big_smile

Offline

#5 2009-12-10 16:33:30

freely
Member
Registered: 2009-08-17
Posts: 7

Re: xcompmgr glitches

xcompmgr-dana   +1  wink

Shadows conky issue, fixed for me with:

bakground yes
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Last edited by freely (2009-12-10 17:14:26)

Offline

Board footer

Powered by FluxBB