You are not logged in.

#1 2004-10-30 05:57:59

dk
Member
Registered: 2004-04-20
Posts: 106

kernel 2.6.9 & nvidia 1-6111-3

Should you run into any problems after -Syu'ing to kernel 2.6.9 and the new nividia 1-6111-3 you might want to have a look here:

http://ngc891.blogdns.net/index.php?200 … ia-drivers

Offline

#2 2004-10-30 08:22:58

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: kernel 2.6.9 & nvidia 1-6111-3

nvidia-3 contains all patches for 2.6.9
you shouldn't have to worry about that

Offline

#3 2004-10-30 11:47:21

skeeterbug
Member
From: Oklahoma, USA
Registered: 2004-10-24
Posts: 92
Website

Re: kernel 2.6.9 & nvidia 1-6111-3

I can verify that nvidia-3 works great.  I upgraded my kernel first, then nvidia and all went smoothly.  Great job by Tobias.

Offline

#4 2004-10-30 18:05:35

dk
Member
Registered: 2004-04-20
Posts: 106

Re: kernel 2.6.9 & nvidia 1-6111-3

I installed the kernel first and then 6111-3 All went well untill
I tried to startx. Then no nvidia splah and just a black screen. I
checked /var/log/Xorg and /nvidia-install but could't find any errors.

I then tried to rollback to 2.6.8 and 6111-2 but the nvidia module wouldn't load :?

The patched nvidia-installer from the link above got things to work.
The installer did hang with /usr/lib/libGL.so.1.0.6111 and the like
so I removed them and the installer worked - for what it's worth.


Thanks always tpowa for the packages big_smile

Offline

#5 2004-10-30 23:22:53

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: kernel 2.6.9 & nvidia 1-6111-3

you tried running pacman -S nvidia in console mode (no X running) ?
else it will not work correctly

Offline

#6 2004-10-31 04:32:09

dk
Member
Registered: 2004-04-20
Posts: 106

Re: kernel 2.6.9 & nvidia 1-6111-3

I was in console. I know, I couldn't figure it out... those nvidia
pkg's have always worked flawless.

I even tried to rollback to -6111-2 w/ 2.6.8  but got:

FATAL: Module nvidia not found 

Offline

#7 2004-10-31 06:49:53

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: kernel 2.6.9 & nvidia 1-6111-3

strange
you have installed new kernel and done a reboot
and then installed nvidia with pacman -S nvidia?
else it cannot work because the kernel
needs to be booted and then building the new module
also you can try pacman -R nvidia
and then reinstall with pacman -S nvidia

the package is defacto the nvidia installer
so i don't know why it doesn't work for you

Offline

#8 2004-11-01 04:37:45

dk
Member
Registered: 2004-04-20
Posts: 106

Re: kernel 2.6.9 & nvidia 1-6111-3

After the kernel update I rebooted even did a 'uname -a" to check
and then ran the pacman -S nvidia.

Like I said they've always worked great.

Seems like kernel 2.6.9 messed-up a few things on my system.
I'm back at 2.6.8 and all is working

Offline

#9 2004-11-01 09:02:36

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: kernel 2.6.9 & nvidia 1-6111-3

i had some people yesterday on irc chat
that haven't nvidia-3 package in pacman cache
perhaps you are also affected by that
and pacman installs always -2 package on your system
try to install -3 package by hand using pacman -U nvida-xxx-3.pkg.tar.gz
and look if it works

Offline

#10 2004-11-02 03:31:24

dk
Member
Registered: 2004-04-20
Posts: 106

Re: kernel 2.6.9 & nvidia 1-6111-3

Thanks again tpowa for the suggestions/help. I did find 6111-3
in /var/cache/pacman/pkg.

I think I'm gonna wait for another pkgbuild on 2.9.6 before I
upgrade my kernel. Maybe even wait for nvidia to correct the driver for 2.6.9

Offline

Board footer

Powered by FluxBB