You are not logged in.

#1 2009-08-07 15:41:03

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 380

[SOLVED] knotify4 is using 7% of the cycles

Hi,

I don't know if this is an issue with KDE4.3 in general, or whether this issue came up because I have removed some of the packages due to the recent package splitup.
When I start KDE, I see the CPU being used abnormally high by knotify4. I am not sure what the service does, nor why it takes up so many CPU cycles.
Seems to me that should not be like that, but I would be grateful for some input.

Regards,
Blind

Last edited by Blind (2009-08-07 21:11:14)

Offline

#2 2009-08-07 16:32:54

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,084

Re: [SOLVED] knotify4 is using 7% of the cycles

I had encountered the same issue and after some research I finally got rid of these 6-9% continual cpu usage by knotify4.
The process is used to notify sounds when events occur in KDE running applications.

As I don't need this function, I went in System Settings/Notifications/System Notifications and the Player Settings tab, and I chose "No audio output" there.
It seems necessary to do a logout/login for it to take effect.

I had also installed the gstreamer0.10-good-plugins and dependencies, because I got a error in .xsession-error log file about that missing plugin.
I don't know if that was linked with the knotify4 cpu usage, but as I proceeded to make the two changes together, and after that the knotify4 process stopped to annoy me, I mention that also here.

There may exist other ways to cope with that issue, but I share what has worked for me and what I now use.

Greetings.

Online

#3 2009-08-07 19:32:36

Blind
Member
From: Desert mountain
Registered: 2005-02-06
Posts: 380

Re: [SOLVED] knotify4 is using 7% of the cycles

berbae,
thanks a lot for your input. I will try right now. gstreamer was already installed here, so probably your "No audio output" solution did the trick...
Kind regards

Update: The Option"No audio output" solves the issue. I am not sure whether that is appropriate for everyone, but I am happy without 'plings' and 'plongs'.

Last edited by Blind (2009-08-07 21:23:25)

Offline

#4 2010-06-17 12:32:42

bilboa
Member
Registered: 2010-06-17
Posts: 3

Re: [SOLVED] knotify4 is using 7% of the cycles

A bit late but thanks for this. I had the same issue with a freshly installed kde4.
Disabling sound output for notification worked around the issue. They def. should fix this.

I gain a whooping 1H of battery life on the laptop and lose 7 degres inside the laptop case according to sensors after I did this. That's huge!!

It somehow wakes up the disk 50 times per seconds according to powertop when the sound is enabled for notifications.
Something is totaly wrong with it !

Offline

Board footer

Powered by FluxBB