You are not logged in.

#1 2009-08-19 14:06:49

vpoinot
Member
Registered: 2009-04-09
Posts: 19

Akonadi: MySQL errors

I recently installed KDE 4.3 (not KDE mod), and noticed several issues when starting up Akonadi:

- the log file (generated from System settings/Akonadi), contains the following errors:

Test 4:  ERROR
--------

MySQL server log contains errors.
Details: The MySQL server error log file /home/vincent/.local/share/akonadi/db_data/mysql.err contains errors.

File content of '/home/vincent/.local/share/akonadi/db_data/mysql.err':
090817 20:18:16 [Note] Plugin 'FEDERATED' is disabled.
090817 20:18:16 [Note] Plugin 'ndbcluster' is disabled.
090817 20:18:17  InnoDB: Started; log sequence number 0 250385
090817 20:18:17 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
090817 20:18:17 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
090817 20:18:17 [ERROR] Cannot open mysql.db
090817 20:18:17 [ERROR] Cannot open mysql.user
090817 20:18:17 [ERROR] Cannot open mysql.event
090817 20:18:17 [ERROR] Event Scheduler: An error occurred when initializing system tables.
090817 20:18:17 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.37-log'  socket: '/home/vincent/.local/share/akonadi/db_misc/mysql.socket'  port: 0  Source distribution
090817 20:25:37 [Warning] Aborted connection 8 to db: 'akonadi' user: 'vincent' host: '' (Got an error reading communication packets)
090817 21:55:52 [Note] /usr/sbin/mysqld: Normal shutdown

090817 21:55:54  InnoDB: Starting shutdown...
090817 21:55:55  InnoDB: Shutdown completed; log sequence number 0 354162
090817 21:55:55 [Warning] Forcing shutdown of 2 plugins
090817 21:55:55 [Note] /usr/sbin/mysqld: Shutdown complete

Besides the warning, the errors seem more critical: a table does not exist. Is it a configuration issue, something pacman did not do upon Akonadi installation ?

- I also have:

Test 9:  ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

I assume this is a consequence of the first error, so this does not worry me much,

- however, I also have the following:

Test 12:  ERROR
--------

No resource agents found.
Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/local/share', make sure this includes all paths where Akonadi agents are installed to.

Directory listing of '/usr/share/akonadi/agents':
birthdaysresource.desktop
distlistresource.desktop
icalresource.desktop
imapresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
kolabproxyresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
microblog.desktop
nepomukcontactfeeder.desktop
nepomukemailfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
notesresource.desktop
strigifeeder.desktop
vcarddirresource.desktop
vcardresource.desktop

Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/local/share'

From what I understand, the XDG_DATA_DIRS variable does not list the directory /usr/share/akonadi/agents, which does contains the Akonadi agents. I would assume this an installation issue ? Or do I have to do something manually after installation (did not see anything like that in pacman.log).

Offline

#2 2009-08-19 20:05:09

Spy
Member
Registered: 2009-02-26
Posts: 78

Re: Akonadi: MySQL errors

Are you using root account ?

Offline

#3 2009-08-20 06:55:20

vpoinot
Member
Registered: 2009-04-09
Posts: 19

Re: Akonadi: MySQL errors

No, I am using my own user account.

Offline

#4 2009-08-21 17:10:57

Spy
Member
Registered: 2009-02-26
Posts: 78

Re: Akonadi: MySQL errors

put here of your .local/share/akonadi/mysql.conf   It should be the same like .config/akonadi/mysql-local.conf   !!!!

also put your /.config/akonadi/akonadiserverrc

Offline

#5 2009-08-25 12:33:54

vpoinot
Member
Registered: 2009-04-09
Posts: 19

Re: Akonadi: MySQL errors

Here is my .config/akonadi/akonadiserverrc:

[%General]
Driver=QMYSQL
SizeThreshold=4096
ExternalPayload=false

[QMYSQL]
Name=akonadi
User=
Password=
Options="UNIX_SOCKET=/home/vincent/.local/share/akonadi/db_misc/mysql.socket"
ServerPath=/usr/sbin/mysqld
StartServer=true

[Debug]
Tracer=null

Note that the pair user/password is empty. Don't know if this is expected, though.
Then my .config/akonadi/akonadiserverrc:

[Data]
Method=UnixPath
UnixPath=/home/vincent/.local/share/akonadi/akonadiserver.socket

[DBUS]
Address="unix:abstract=/tmp/dbus-G3xsYyhLGA,guid=38051aec7aa8ff8a2b20eed04a899ecc"

And finally, my .local/share/akonadi/mysql.conf :

#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2

Can you spot anything unusual ?
Thanks in advance.

Offline

#6 2009-08-27 01:44:09

stingray
Member
From: Lima, Peru SA
Registered: 2006-03-24
Posts: 188

Re: Akonadi: MySQL errors

Commenting out "default_storage_engine=innodb" in ".local/share/akonadi/mysql.conf" fixed some issues I was having with Akonadi.  But they were different issues than you are having...

Offline

#7 2009-08-29 08:45:02

vpoinot
Member
Registered: 2009-04-09
Posts: 19

Re: Akonadi: MySQL errors

Tried that, but did not change anything...

Just out of curiosity, do you all have Akonadi starting up alright ? If so, did you do anything special that I may have missed after installing KDE/Akonadi ?
I don't know MySQL, but I assume there is a way to manually connect to the database and check the schema ? How can I do that and check if the missing table is really missing, or if Akonadi cannot access it for some reason, etc. ? Is there some sqlplus-like tool ?

Offline

#8 2009-09-03 18:44:29

Wauzenplauz
Member
From: Starnberg, BY, Germany
Registered: 2006-10-11
Posts: 21
Website

Re: Akonadi: MySQL errors

vpoinot, your error message looks like the one I found on my system.

Maybe you should give this a try: Just copy the main config file from

/usr/share/config/akonadi/mysql-global.conf

to the appropriate directory of your user

$HOME/.config/akonadi/mysql-local.conf

and uncomment the line which reads

sql_mode=strict_trans_tables

.

Further help can be found at
http://userbase.kde.org/Akonadi.

Offline

#9 2009-10-29 11:50:47

BlueSkyNis
Member
From: Serbia, Niš
Registered: 2009-10-08
Posts: 16

Re: Akonadi: MySQL errors

Wauzenplauz wrote:

vpoinot, your error message looks like the one I found on my system.

....

Further help can be found at
http://userbase.kde.org/Akonadi.

I did the steps mentioned in url, but I still get this

091029 12:23:04 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
091029 12:23:04 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

in mysql.err file.

Last edited by BlueSkyNis (2009-10-29 11:51:15)

Offline

#10 2010-01-17 11:40:56

giucam
Member
Registered: 2009-02-01
Posts: 12

Re: Akonadi: MySQL errors

did you manage to fix this? i get the same error.

Offline

#11 2010-01-17 13:58:43

Mad Fish
Member
Registered: 2009-09-22
Posts: 295

Re: Akonadi: MySQL errors

I've also had the same error, with absolutely clean KDE installation on clean Arch installation. Something is definitely broken.

Offline

#12 2010-01-25 15:54:50

jonasp
Member
Registered: 2010-01-25
Posts: 1

Re: Akonadi: MySQL errors

hey could you try the following:

stop akonadi

akonadictl stop

remove the db_data dir:

rm  -r ~/.local/share/akonadi/db_data

recreate mysqldb with

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

restart akonadi

akonadictl start

worked for me.

I found the solution here: http://forum.kde.org/viewtopic.php?f=20 … 8&start=10

Offline

#13 2010-02-01 20:21:22

giucam
Member
Registered: 2009-02-01
Posts: 12

Re: Akonadi: MySQL errors

it worked! thanks!!
that error is gone, now there are still others but i'm now nearer to the goal smile

Offline

#14 2010-05-11 16:41:20

cies
Member
From: rotterdam
Registered: 2010-05-11
Posts: 1
Website

Re: Akonadi: MySQL errors

i had similar akonadi problems on kdemod 4.4.3. fixed it with help of jonasp and Wauzenplauz. THANKS!

and my first post on the arch forums, just installed an already loving it...

Offline

#15 2010-05-17 11:32:32

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: Akonadi: MySQL errors

All of a sudden akonadi stared failing again.

I tried jonasp proposed solution and now i have the exact problem:

When i open Kontact i get the error of "no resource agents found".

http://pastebin.com/d1f2AVFp

If i try to start akonadi via terminal with :

akonadictl start

there is no problem at all,and akonadi starts normaly.

any suggestion?


Mikes on AUR

Offline

#16 2010-05-17 23:24:43

tony5429
Member
Registered: 2006-03-28
Posts: 961
Website

Re: Akonadi: MySQL errors

I can second mechmg93. I just installed a fresh new Arch32/KDE4.4.3 system. Every time it starts up I get this in the Akonadi Server Self-test output: "MySQL server log contains errors."


Krondi: the free and ad-free music-streaming app.

Offline

#17 2010-05-18 11:45:51

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: Akonadi: MySQL errors

I finally managed to make akonadi functional, by deleting all the old resources(traditional calendar and tranditional kaddressbook) and creating new ones(icalendar calendar and personal contacts kaddressbook).

Now everything seems fine, but i believe that akonadi is by far the most problematic software of kde 4.


Mikes on AUR

Offline

#18 2011-03-15 13:52:13

mikesol
Member
From: Toulouse, France
Registered: 2011-02-01
Posts: 14

Re: Akonadi: MySQL errors

jonasp wrote:

hey could you try the following:

stop akonadi

akonadictl stop

remove the db_data dir:

rm  -r ~/.local/share/akonadi/db_data

recreate mysqldb with

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

restart akonadi

akonadictl start

worked for me.

I found the solution here: http://forum.kde.org/viewtopic.php?f=20 … 8&start=10


It works for me but first you must go to /usr directory

cd /usr 

if not it will appears a message like that

 $mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

FATAL ERROR: Could not find ./bin/my_print_defaults

If you compiled from source, you need to run 'make install' to
copy the software into the correct location ready for operation.

If you are using a binary release, you must either be at the top
level of the extracted archive, or pass the --basedir option
pointing to that location.
 

--
Sorry for my English.

Offline

#19 2012-05-25 15:15:15

isaque
Member
Registered: 2012-05-25
Posts: 1

Re: Akonadi: MySQL errors

mikesol wrote:

...
It works for me but first you must go to /usr directory

cd /usr 

if not it will appears a message like that

 $mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

FATAL ERROR: Could not find ./bin/my_print_defaults
...

Just for documetation purpose, the correct command line should be:

 $mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/ --basedir=/usr 

Thanks.

Offline

Board footer

Powered by FluxBB