You are not logged in.

#1 2004-11-14 04:44:42

Registered: 2004-07-06
Posts: 67

nitro3 kernel and menuconfig and ctrl+alt+fX problem

Hi, im having the stranges occurrences.
I tried 2 use this PKGBUILD of nitro in here … ight=nitro, but changed the nitrover = 3.

it downloaded fine, and it goes to the choice menu :
==> How do you want to configure the kernel:
==> ----------------------------------------
==> (for ArchLinux defaults, use 'not_at_all (1)')
1) not_at_all
2) menuconfig
3) xconfig
4) oldconfig
5) config

when i choose '2', it goes into menuconfig ok, but once i get there, the only keys i can use is enter and esc. when i press the arrow keys to try to move, it already ask you if you want to save the config. I find this very strange since I compiled nitro2 thru menuconfig the last time and it operated normally.

Since menuconfig is out of wack, i tried xconfig, and it operated normally. But strange thing is that after it starts compiling, in the middle of the compliation, i get this error :

if [ -r ]; then /sbin/depmod -ae -F -b /var/abs/local/kernel26/pkg -r 2.6.9-nitro3-ARCH; fi
WARNING: /var/abs/local/kernel26/pkg/lib/modules/2.6.9-nitro3-ARCH/kernel/drivers/video/vesafb-tng.ko needs unknown symbol vesafb_setup
./PKGBUILD: line 133: cd: /var/abs/local/kernel26/pkg/lib/modules/2.6.9-nitro3: No such file or directory
==> ERROR: Build Failed. Aborting...

which I am stoked as what it means.

I am also having problem with switching to console mode after I have started X, like startx or startxfce4.  It seems that after it's started I can't switch back to console thru ctrl+alt+f3.


Board footer

Powered by FluxBB