You are not logged in.

#1 2009-10-01 08:42:43

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

How do I specify multiple fans in /etc/fancontrol ?

I've been running through the fan control guide in the wiki, and reading most every post here on fan control without finding any solutions to this problem... Here are my notes on my setup from pwmconfig and sensors output:

fan1: CPU
fan2: Chassis
fan3: Power

hwmon0 is atk0110
hwmon1/device is it8712

PWM controls:
hwmon1/device/pwm1
hwmon1/device/pwm2
hwmon1/device/pwm3

controlled by hwmon1/device/pwm1
hwmon0/fan1_input YES (CPU fan)
hwmon0/fan2_input no corr
hwmon0/fan3_input no corr

controlled by hwmon1/device/pwm1
hwmon1/device/fan1_input YES (CPU fan)
hwmon1/device/fan2_input no corr
hwmon1/device/fan3_input no corr

controlled by hwmon1/device/pwm2
hwmon0/fan1_input no corr
hwmon0/fan2_input YES
hwmon0/fan3_input no corr
hwmon1/device/fan1_input no corr
hwmon1/device/fan2_input YES
hwmon1/device/fan3_input no corr

controlled by hwmon1/device/pwm3
hwmon0/fan1_input no corr
hwmon0/fan2_input no corr
hwmon0/fan3_input no corr
hwmon1/device/fan1_input no corr
hwmon1/device/fan2_input no corr
hwmon1/device/fan3_input no corr

temp1: 28 C, CPU (high = 60 C, crit = 95 C)
temp2: 33 C, MB  (high = 45 C, crit = 75 C)

temp1 should control hwmon1/device/pwm1 which controls the CPU fan
temp2 should control hwmon1/device/pwm2 which controls the MB fans

So lm-sensors seems to work, and pwmconfig seems to spin down the right fans.  Now, after pwmconfig has run through the tests, I say that pwm1 should be controlled by temp1, while pwm2 should be controlled by temp2, set interval, save and quit. Then I try starting fancontrol, it reads everything up until FCTEMPS, where I get an error. The FCTEMPS line has a + between the two fans controlled by pwm2, could this be the problem? Does anyone have a similar setup (two fans controlled by one pwm2 and one temp2, and a third fan controlled by pwm1 and temp1) and an /etc/fancontrol which displays this setup? Basically it seems to me pwmconfig is not writing the right /etc/fancontrol syntax for two fans on one pwm.

(Googling for this just gave me "here's a patch to make lotsa fans work with lotsa temps" and similar stuff which seemed way more complex than what I want.)

Offline

#2 2009-10-01 12:43:31

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

Re: How do I specify multiple fans in /etc/fancontrol ?

wops, forgot to include my /etc/fancontrol:

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=5
FCTEMPS=hwmon1/device/pwm2=hwmon0/temp2_input hwmon1/device/pwm1=hwmon0/temp1_input
FCFANS=hwmon1/device/pwm2=hwmon1/device/fan2_input+hwmon0/fan2_input hwmon1/device/pwm1=hwmon1/device/fan1_input+hwmon0/fan1_input
MINTEMP=hwmon1/device/pwm2=20 hwmon1/device/pwm1=20
MAXTEMP=hwmon1/device/pwm2=60 hwmon1/device/pwm1=75
MINSTART=hwmon1/device/pwm2=150 hwmon1/device/pwm1=150
MINSTOP=hwmon1/device/pwm2=0 hwmon1/device/pwm1=0

and the error output:

Loading configuration from /etc/fancontrol ...

Common settings:
  INTERVAL=5

Settings for hwmon1/device/pwm2:
  Depends on hwmon0/temp2_input
  Controls hwmon1/device/fan2_input+hwmon0/fan2_input
  MINTEMP=20
  MAXTEMP=60
  MINSTART=150
  MINSTOP=0
  MINPWM=0
  MAXPWM=255

Settings for hwmon1/device/pwm1:
  Depends on hwmon0/temp1_input
  Controls hwmon1/device/fan1_input+hwmon0/fan1_input
  MINTEMP=20
  MAXTEMP=75
  MINSTART=150
  MINSTOP=0
  MINPWM=0
  MAXPWM=255

Enabling PWM on fans...
Starting automatic fan control...
/usr/sbin/fancontrol: line 287: hwmon1/device/fan2_input+hwmon0/fan2_input: No such file or directory
Error reading Fan value from /sys/class/hwmon/hwmon1/device/fan2_input+hwmon0/fan2_input
Aborting, restoring fans...
Verify fans have returned to full speed

Last edited by unhammer (2009-10-01 17:27:55)

Offline

#3 2009-10-01 17:51:28

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

Re: How do I specify multiple fans in /etc/fancontrol ?

OK, after some messing about, it seems the solution is simply to delete the part after the plus, I now have

FCFANS=hwmon1/device/pwm2=hwmon1/device/fan2_input hwmon1/device/pwm1=hwmon1/device/fan1_input

in /etc/fancontrol

(from what I remember from the sensor detection script, one of my drivers was "to-be-written", which I'm assuming is the reason that I can't control fan3 yet :-/)

If anyone's interested, this is my hardware:
AMD Phenom II X3 720 Black Edition Triple Core, 2,8Ghz, AM3, 95W, Boxed
ASUS M4A785TD-M, Socket-AM3 AMD 785G+SB710, DDR3, Firewire, GbLAN, m-ATX, HDMI
Silver Power SP-400P2C 400W Super Low Noise, 2x PCIe, 12cm Fan

So I guess pwmcontrol shouldn't add those +'es there? or the fancontrol script should be able to read/ignore them?

Offline

#4 2009-10-09 20:59:32

Piiotr
Member
Registered: 2009-10-09
Posts: 1

Re: How do I specify multiple fans in /etc/fancontrol ?

Thanks,

it worked for me too smile

Offline

#5 2009-10-22 12:11:35

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

Re: How do I specify multiple fans in /etc/fancontrol ?

OK after the last kernel upgrade I had to put this in my /boot/grub/menu.lst, at the end of the line starting with "kernel" for the kernel I'm using:

acpi_enforce_resources=lax

According to http://hansdegoede.livejournal.com/7932.html it's dangerous and shouldn't be done, but I haven't seen problems so far...

Also, http://aur.archlinux.org/packages.php?ID=28734 (k10temp-module) gave me the rest of my temperatures for my ASUS M4A785TD-M.

There's still one fan that isn't controlled (the one plugged into the very corner of the MB by the RAM, named POWER by /usr/bin/sensors), but 2 out of 3 helps..

Last edited by unhammer (2009-10-22 12:33:01)

Offline

Board footer

Powered by FluxBB