You are not logged in.

#1 2009-10-02 20:27:25

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,108
Website

MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

I just put tightvnc on my box which runs gnome.  When I connected to the vncserver, the keyboard map is all messed up.  What I mean is that when I type (in a shell, in a webbrowser, open office, it doesn't matter), the characters that I'm typing do not get displayed.  It's as if the keys aren't mapped properly.

For example, I type "asdf" but it gets printed in the shell as "abfh"  Similarly, "qwert" becomes "c.gvn"

This is a problem unique to Gnome because if I start an xfce4 session, the keymap is fine.  I'd like to use gnome with tightvnc though.  Thoughts/suggestions are welcomed!

Last edited by graysky (2009-10-04 11:48:03)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2009-10-03 11:01:18

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,108
Website

Re: MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

Turns out that this is a Gnome-thing.  See the following thread where an ugly hack is proposed: http://ubuntuforums.org/showthread.php?t=420179

Can anyone in here with more knowledge of Gnome suggest something prettier smile

Last edited by graysky (2009-10-03 11:01:45)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2009-10-03 12:43:47

max.bra
Member
From: Bologna - Italy
Registered: 2008-06-02
Posts: 86

Re: MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

it's a know problem of gnome-settings-daemon under a vnc session.

out of gnome environement of corse, login on remote pc as vnc session user and execute:

gconftool-2 --set /desktop/gnome/peripherals/keyboard/kbd/layouts --type List --list-type String [aa]
gconftool-2 --set /apps/gnome_settings_daemon/plugins/keyboard/active --type boolean false

Offline

#4 2009-10-04 10:27:36

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,108
Website

Re: MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

This worked great.  Thank you very much!  I updated the tightvnc wiki article with your fix.

...how did you come up with this?

Last edited by graysky (2009-10-04 11:53:51)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2009-10-04 20:39:18

max.bra
Member
From: Bologna - Italy
Registered: 2008-06-02
Posts: 86

Re: MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

smile glad to be of help.

Nothing special. I've seen this behavior a couple of month ago.
Not only keyboard was completely unmapped but, after theming my session with a more compact one, i saw that my choosen theme were continuously set and unset jumping from it and the default one.

Mmm... this is gnome setting deamon that loop restart, I said. Confirming that with a bit of googling, i blamed the management of the keyboard in vnc session.

completely disabling keyboard management of gnome setting daemon solved the problem.


Happy VNCing.

Last edited by max.bra (2009-10-04 20:42:49)

Offline

#6 2009-10-04 21:18:38

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,108
Website

Re: MAJOR keyboard mapping problem with Gnome and tightvnc [SOLVED]

I also added the fix I found googling after trying your fix to the wiki article.  Basically, add the following to the ~/.vnc/xstart before the exec gnome line: export XKL_XMODMAP_DISABLE=1


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB