You are not logged in.

#1 2004-11-23 15:51:38

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

gimp 2.2

this is NOT a request for a PKGBUILD ... only discussion ...

it seems that gimp 2.2 will be out later this month

http://developer.gimp.org/screenshots.html :

gimp-preview-rotate.png

finally, we have free rotate of layers in gimp!  8) (looking forward for much better panorama editing now!)


The impossible missions are the only ones which succeed.

Offline

#2 2004-11-25 13:56:55

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gimp 2.2

when should we expect it?
nice rotation coz it always was confusing the other (without preview)

I hear the selection everywhere also got better (it does lighten the one you select, and it shadows the unselected)

I was a Photoshop user. I tried (a bit hard) to use Gimp, learn the shortcut keys and so on, and have the tips always on, and I 'm happy. Yesterday I found out that Gimp also have auto levels like Photoshop does. nice

Offline

#3 2004-12-03 16:13:51

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gimp 2.2

dp wrote:

this is NOT a request for a PKGBUILD ... only discussion ...

it seems that gimp 2.2 will be out later this month

finally, we have free rotate of layers in gimp!  8) (looking forward for much better panorama editing now!)

yea, I know for now it looks fine to me, the only drawback is that the refocus
plugin won't work on it. It prolly needs a complete GUI cleanup/rewrite cuz it
just clash with the new Plugin_preview architecture. Don't get me wrong, this
architecture is awesome, cuz you get some nice helpful previews for most of
the plugins now. Also the layer masks got thome upgrade and the handling
become better in general. Not more photoshop like, just better than it was
b4.
One of the most awesome things is that there is a gimp-console binary now,
which allows x-less editing if you need some special gimp functions on a web
server.

-neri

oh, it's a bit tweaked, since it uses some dependencies form "extra", and
most of you additionally installed plugins won't work. Also, it might conflict
with the gimp from current.

pkgname=gimp-unstable
pkgver=2.2
_pkgver=pre2
pkgrel=1
pkgdesc="GNU Image Manipulation Program"
depends=('gtk2' 'librsvg' 'pygtk' 'gimp-print' 'libmng' 'libexif' 'libgtkhtml' 'lcms')
makedepends=('gimp-print')
conflicts=('')
source=(ftp://ftp.gimp.org/pub/gimp/v2.2/testing/gimp-$pkgver-$_pkgver.tar.bz2)
url="http://www.gimp.org/"
md5sums=('ebf7e6ecfd8140933ba8def721df49cd')

build() {
  cd $startdir/src/gimp-$pkgver-$_pkgver
  ./configure --prefix=/usr --enable-mp --enable-python --disable-devel-docs 
  --enable-gimp-console --with-gif-compression=lzw --without-aa
  make || return 1
  make DESTDIR=$startdir/pkg install-strip
  cd $startdir/pkg
    
 ################################################################
 # neri's tweaks
  install -Dm644 $startdir/src/gimp-$pkgver-$_pkgver/docs/Wilber.svg 
    $startdir/pkg/usr/share/pixmaps/wilber-devel.svg
  ln -s /usr/share/gimp/2.2/images/wilber-devel-icon.png 
    $startdir/pkg/usr/share/pixmaps/wilber-devel-icon.png
  install -Dm644 $startdir/src/gimp-$pkgver-$_pkgver/data/misc/gimp.desktop 
    $startdir/pkg/usr/share/applications/gimp.desktop
  cd $startdir/pkg/usr/bin
  ln -s gimptool-2.0 gimptool
}

Offline

#4 2004-12-19 20:41:17

ylikone
Member
From: Southern Ontario
Registered: 2004-12-17
Posts: 45
Website

Re: gimp 2.2

So, as Gimp 2.2 was officially released as stable today, when can we expect it in "current"?  Just asking... I'm new to arch and am not familiar with the speed of new software being added.

Offline

#5 2004-12-19 22:05:20

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: gimp 2.2

ylikone wrote:

So, as Gimp 2.2 was officially released as stable today, when can we expect it in "current"?  Just asking... I'm new to arch and am not familiar with the speed of new software being added.

sometimes it takes a a few days, sometimes weeks and sometimes it is in arch' repos before it is officially released,
there is no general rule for it, as soon as possible i guess,

sometimes new packages go to testing repo first before it goes to current,


arch + gentoo + initng + python = enlisy

Offline

#6 2004-12-20 08:30:13

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gimp 2.2

Gimp 2.2 requires GTK 2.6.0, which will go into testing in a few days (maybe today). Dorphell doesn't have time until after tomorrow. After tomorrow he will start with his large todo list, and I am sure that gtk2 is not on top of it...

Please give us some days.

Offline

#7 2004-12-20 14:27:33

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: gimp 2.2

This PKGBUILDs worked for me:

glib2-2.6.0:

# $Id: PKGBUILD,v 1.14 2004/10/16 04:36:48 dorphell Exp $
# Maintainer: dorphell <dorphell@archlinux.org>
pkgname=glib2
pkgver=2.6.0
pkgrel=1
pkgdesc="Common C routines used by GTK+ 2.6 and other libs"
depends=('glibc' 'pkgconfig')
source=(ftp://ftp.gtk.org/pub/gtk/v2.6/glib-$pkgver.tar.bz2)
url="http://www.gtk.org/"
md5sums=('649b89c8bfd152feea6db6f68b7cd54e')

build() {
  cd $startdir/src/glib-$pkgver
  ./configure --prefix=/usr
  make || return 1
  make DESTDIR=$startdir/pkg install
}

pango-1.8.0:

# $Id: PKGBUILD,v 1.23 2004/10/04 17:07:47 judd Exp $
# Maintainer: dorphell <dorphell@archlinux.org>
pkgname=pango
pkgver=1.8.0
pkgrel=1
pkgdesc="A library for layout and rendering of text"
depends=('glib2>=2.6.0' 'x-server')
install=pango.install
source=(ftp://ftp.gtk.org/pub/gtk/v2.6/$pkgname-$pkgver.tar.bz2)
url="http://www.gtk.org/"
md5sums=('d11f9857df7216321163e14d66d0cab8')

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  make || return 1
  make DESTDIR=$startdir/pkg install
}

gtk2-2.6.0:

# $Id: PKGBUILD,v 1.35 2004/10/16 02:47:16 dorphell Exp $
# Maintainer: dorphell <dorphell@archlinux.org>
pkgname=gtk2
pkgver=2.6.0
pkgrel=1
pkgdesc="The GTK+ Toolkit (v2)"
install=gtk2.install
depends=('atk' 'glib2>=2.6.0' 'pango>=1.8.0' 'libpng' 'libtiff' 'libjpeg')
source=(ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-$pkgver.tar.bz2)
url="http://www.gtk.org/"
md5sums=('ca717c728264fa0b3302ca00da2bcfe4')
    
build() {
  cd $startdir/src/gtk+-$pkgver
  sed -i 's|g_build_filename (GTK_DATADIR, "icons", NULL)|g_strdup ("/opt/gnome/share/icons")|' gtk/gtkicontheme.c
  sed -i 's|g_build_filename (GTK_DATADIR, "pixmaps", NULL)|g_strdup ("/opt/gnome/share/pixmaps")|' gtk/gtkicontheme.c
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-xinput=yes
  make || return 1
  make DESTDIR=$startdir/pkg install
}


They're just modifications of older versions of the official PKGBUILDs.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#8 2004-12-20 14:30:06

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: gimp 2.2

m... gtk2 is installed in /usr/lib/gtk2/2.4.0, and not 2.6.0. Anyway, it works.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#9 2004-12-20 14:30:29

ylikone
Member
From: Southern Ontario
Registered: 2004-12-17
Posts: 45
Website

Re: gimp 2.2

"Please give us some days."

Oh, don't get me wrong, I'm not complaining or anything.  Things seem to get updated fairly fast with Arch.

Offline

#10 2004-12-20 16:36:45

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gimp 2.2

Your GTK2 PKGBUILD will break gnome and it will have conflicts with gtk-engines wink

I will look at it tonight when I finish most of the python stuff. I have prerelease snapshots built for gnome 2.9, so I know what to do.

About gtk2 requirements: gimp 2.2 doesn't require it it seems, but would appreciate it if available wink

Offline

#11 2004-12-20 17:46:50

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: gimp 2.2

Gnome is working fine for me. Don't know about gtk-engines, but I had to force the upgrade, so maybe something is broken.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#12 2004-12-20 21:53:50

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gimp 2.2

Kill your gnome-panel and look how nice your icons disappear wink

Offline

#13 2004-12-20 22:28:23

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: gimp 2.2

m... there are only three icons missing, and I think those are missing from a long time (since gnome 2.8 ), but I'm not sure, cause I hadn't log into gnome since 2.8 came out.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#14 2004-12-24 11:46:38

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: gimp 2.2

http://www.gimp.org/release-notes/gimp-2.2.html
is official stable and out.

why al builts it with --without--aa ?

Offline

Board footer

Powered by FluxBB