You are not logged in.

#1 2009-10-22 08:57:32

becho4
Member
From: Galicia, Spain
Registered: 2004-12-09
Posts: 71

amarok error: "Cannot find demultiplexer plugin for MRL...

Since my last pacman -Syu today amarok doesn't play anything.

'amarok --debug' outputs the following error:

amarok: END__: void Context::Applet::setCollapseOff() - Took 0.00044s                                                                       
amarok: BEGIN: void CurrentTrack::dataUpdated(const QString&, const QHash<QString, QVariant>&)                                             
amarok: END__: void CurrentTrack::dataUpdated(const QString&, const QHash<QString, QVariant>&) - Took 0.04s                                 
amarok: BEGIN: void EngineController::slotStateChanged(Phonon::State, Phonon::State)                                                       
amarok:   [EngineController] [WARNING!] Phonon failed to play this URL. Error:  "Cannot find demultiplexer plugin for MRL [file:///home/alf/Musica/Virgin%20radio/Duffy%20-%20Rain%20On%20Your%20Parade.mp3]"                                                                           
amarok:   BEGIN: void Playlist::Actions::requestNextTrack()                                                                                 
amarok:     [Playlist::Actions] so far so good!                                                                                             
amarok:     [Playlist::Actions] nothing more to play...                                                                                     
amarok:   END__: void Playlist::Actions::requestNextTrack() - Took 0.0079s

Any ideas?
smile

Offline

#2 2009-10-30 13:08:53

YetAnotherUsername
Member
Registered: 2009-10-30
Posts: 3

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

Have the same here

Offline

#3 2009-10-30 15:09:13

YetAnotherUsername
Member
Registered: 2009-10-30
Posts: 3

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

hey, I got the first solution. It appears that phonon-xine 4.3.1-2 is broken or something like that (or is bad for Qt  4.5.3-3 ). Just go "System settings>Multimedia>Backend(Tab)"   and put gstreamer as preffered.
Now lets see what had happened with phonon-xine...

Offline

#4 2009-10-30 22:19:41

YetAnotherUsername
Member
Registered: 2009-10-30
Posts: 3

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

gstreamer is bad, I found the way to fix xine(already known on Arch forum):
rm ~/.xine/catalog.cache

Offline

#5 2009-11-01 12:33:10

becho4
Member
From: Galicia, Spain
Registered: 2004-12-09
Posts: 71

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

It worked here
Thank you very much YetAnotherUsername!!!
smile

Offline

#6 2009-11-10 17:22:15

Steve`
Member
From: Buchholz / Germany
Registered: 2005-04-16
Posts: 15
Website

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

Yeah, works here also - many thanks for this ...

Offline

#7 2010-01-31 09:59:23

Phlogiston
Member
Registered: 2009-02-14
Posts: 39

Re: amarok error: "Cannot find demultiplexer plugin for MRL...

Hi guys, I'm having the same issue, but can't find that file in .xine...

any ideas?

/edit: Playing around in systemsettings, got the file, deleted it -> fixed

Last edited by Phlogiston (2010-01-31 10:05:04)

Offline

Board footer

Powered by FluxBB