You are not logged in.

#1 2004-11-29 10:26:04

Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

lspci does not recognise my 11g card

I've started a new Arch install on my laptop, in a separate partition form the existing Debian and Windoze. I'm using arch-0.7-beta2-base. The base install is complete, and I have network access via a PC Card wired NIC. However, I generally use this laptop wirelessly - no problem with either Debian or Windoze - but when I run lspci under Arch, I get the following:

02:00.0 Network controller: 3Com Corporation: Unknown device 6001 (rev 01)

I've had a look at /usr/share/hwdata/pcitable, and it contains the following correct information:

0x10b7  0x6001  "prism54"       "3Com Corp.|3cRWE154G72 Wireless LAN adapter"

If the card worked, this wouldn't really matter, but when I modprobe the required prism54 driver, kernel.log shows the following:

Nov 29 02:10:02 myhost Loaded prism54 driver, version 1.2
Nov 29 02:10:02 myhost ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 11 (level, low) -> IRQ 11
Nov 29 02:10:02 myhost eth0: islpci_open()
Nov 29 02:10:02 myhost eth0: resetting device...
Nov 29 02:10:02 myhost eth0: uploading firmware...
Nov 29 02:10:02 myhost prism54: request_firmware() failed for 'isl3890'
Nov 29 02:10:02 myhost eth0: could not upload firmware ('isl3890')

The firware file isl3890 is in the right location - /usr/lib/hotplug/firmware - and is the same as the file used under Debian, where it uploads with no problem.

Now I had Arch 0.6 on here briefly before, and the card worked fine, so is this an 0.7 beta bug? Is there anything I can do to fix it, or should I blow the partition and go back to 0.6?


Board footer

Powered by FluxBB