You are not logged in.

#1 2003-07-23 20:45:30

From: Hamburg/Germany
Registered: 2003-07-23
Posts: 62

too stupid to setup gnome etc.


my english is not that good, so if anybody speak german here feel free to answer in german..

I´m not new to linux. I use Debian since 3 years and gentoo sind 1 year.

i just setup arch 0.4 - ok
update to 0.5 -ok

i installed all gnome packets in the 0.4 installation and i installed xfree and gdm.

i configured xfree and it works but i cant start gnome or something else. what have i to do run gnome?

thank you for helping me


#2 2003-07-23 23:09:58

From: Germany
Registered: 2002-09-03
Posts: 166

Re: too stupid to setup gnome etc.

You should have a look in the home directory of the user wanting to use Gnome, and look for a file called ".xinitrc" (note the dot). In here, pretty much at the end, you will find a line like "exec xfwm". This starts your window manager. Comment out this exec line, and replace it with "exec gnome-session", that should do the trick. For system-wide config, or if that file doesnt exist, see /etc/X11/xinit/xinitrc. Remove anything at the end (twm and xterm stuff) and add the "exec gnome-session" there. I'm not 100% positive on the name, but that's the executable I remember "bootstrapping" Gnome.

--- German

Du solltest mal einen Blick in das Homeverzeichnis des Benutzers werfen, der Gnome starten will, und nach einer Datei mit dem Namen ".xinitrc" (Der Punkt ist wichtig) Ausschau halten. Hier drin findest du dann ziemlich am Ende eine Zeile die sowas aehnliches wie "exec xfwm" enthaelt. Das startet deinen window manager. Kommentiere diese Zeile aus, und ersetze sie durch "exec gnome-session", das sollte tun. Fuer eine systemweite Konfiguration, oder falls diese Datei nicht existiert, schau in die /etc/X11/xinit/xinitrc. Entferne alles am Ende (twm und xterm Krempel) und fuege hier das "exec gnome-session" ein. Ich bin mir nicht 100%ig sicher mit dem Namen, aber das ist meines Wissens die executable die Gnome "aus dem Dreck zieht".


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert


#3 2003-08-27 15:38:02

Andrius Kokianciks
From: Lithuania
Registered: 2003-05-30
Posts: 10

Re: too stupid to setup gnome etc.

"x:5:respawn:/usr/X11R6/bin/xdm -nodaemon"

autostarts Gnome well at bootup.


#4 2003-08-27 15:52:11

Registered: 2002-12-04
Posts: 82

Re: too stupid to setup gnome etc.

Note that if you make that change in inittab you should also pass the -nodaemon option to GDM. If you don't, things like gdmflexiserver (particularly the Xnest version) will not work because they will claim that GDM is not running.


#5 2003-08-27 17:01:50

From: Lockport, IL
Registered: 2003-08-06
Posts: 104

Re: too stupid to setup gnome etc.

you can also edit /etc/rc.conf and add gdm to DAEMONS

DAEMONS=( gdm )

That is if you want gdm to be your login manager.


Board footer

Powered by FluxBB