You are not logged in.

#1 2004-12-07 16:51:31

PunkRawkSucks
Member
From: Kingston, Ontario, Canada
Registered: 2004-11-06
Posts: 47
Website

Openoffice stopped working after pacman -Syu

I ran an update this morning, and now my Openoffice won't run. The update included:

[12/07/04 10:08] upgraded glibc (2.3.3-2 -> 2.3.4-1)
[12/07/04 10:08] upgraded wput (0.4-1 -> 0.5-1)

So I am guessing that the new glibc is the cause.

Trying to run OOO from the K menu or from within Konquerer does nothing. Trying to run /opt/openoffice/programs/soffice directly segfaults.

Any thoughts?

Mark

Offline

#2 2004-12-08 12:20:09

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Openoffice stopped working after pacman -Syu

hi
i had someone with the same problem
try setting your DRI permissions right that should solve everything
here is what i got from him:

OK - false alarm.  This is not an OO problem.  (Although perhaps you can help
me with what the problem is.)

I've run into this before.  Apparently on my machine, /dev/dri (and
/dev/dri/card0) are always owned by root.root.  This, however, prevents
regular users from accessing that device.  And, apparently, Open Office tries
to access that device, fails, and then crashes.

I was able to solve this problem for my current session by setting ownership
to root.users.  However, this isn't a long term solution obviously.  And
although Judd previously tried to help me with this by providing me with what
looked like a workable long term solution (add the line "REGISTER dri/.*
PERMISSIONS root.users 660" to /etc/devfsd.conf) this does not seem to take
effect for some reason when I reboot.

Anyway, bottom line:  OO not broken, but if you've got any suggestions as to
why I'm having this problem or how to work around it, I'd appreciate it.

Thanks and sorry for the false alarm

Offline

#3 2004-12-08 14:59:31

darose
Member
Registered: 2004-04-13
Posts: 118

Re: Openoffice stopped working after pacman -Syu

Hi.  I'm the guy Tobias is referring to.

And FYI - I finally found the appropriate correct solution that will fix the permissioning issue on the dri device.

Add this into your X config (e.g., xorg.conf or XF86Config(-4)):

Section "DRI"
        Group "users"
        Mode 0660
EndSection

You'll need to shut down and restart X for this to take effect.

HTH,

DR

Offline

#4 2004-12-15 19:00:59

PunkRawkSucks
Member
From: Kingston, Ontario, Canada
Registered: 2004-11-06
Posts: 47
Website

Re: Openoffice stopped working after pacman -Syu

I don't have a /dev/dri.

[root@yen etc]# ls -l /dev/dri*
ls: /dev/dri*: No such file or directory
[root@yen etc]#

Mark

Offline

#5 2004-12-16 01:52:50

darose
Member
Registered: 2004-04-13
Posts: 118

Re: Openoffice stopped working after pacman -Syu

Hard to say what it could be without seeing output.  From a console, type "strace `which soffice`", and post the results up here.

Offline

#6 2004-12-16 16:37:14

PunkRawkSucks
Member
From: Kingston, Ontario, Canada
Registered: 2004-11-06
Posts: 47
Website

Re: Openoffice stopped working after pacman -Syu

Too late! I reinstalled Arch and now ooo is working fine.

Mark

Offline

Board footer

Powered by FluxBB