You are not logged in.

#1 2009-11-30 21:24:07

markp1989
Member
Registered: 2008-10-05
Posts: 431

yaourt wont build any packages..../configure: /bin/sh: bad interpreter

im tying to build a package with yaourt and it isnt working.

[mark@markspc ~]$ yaourt -S indicator-applet 
==> Resuming previous build

==> Downloading indicator-applet PKGBUILD from AUR...
==> Last 5 comments ordered by date (asc):

Comment by: lumpy211 on Fri, 13 Nov 2009 19:51:52 +0000
Phrodo,
It doesn't work for me either, it just crashes even with libindicator.

Comment by: max.bra on Sun, 15 Nov 2009 10:48:19 +0000
don't use now (0.2.0-1)
it doesn't work and install file directly onto the system overwriting a gdm package file (no real package creation and no real remove/clean)
trying to do better. hold on.

Comment by: max.bra on Mon, 16 Nov 2009 21:08:35 +0000
The situation is slightly better.
now indicator-applet-session work as expected. tested with empathy and pidgin.
indicator-applet (the icon with the letter envelope) even that seems to work (tested with /usr/libexec/im-client) but nothing on arch trigger compatible events. as usual applications are patched upstream. standard compiling of available sources, also lacks of initial menu applet found in Ubuntu to launch applications.
no localization at the moment, only English.
I added a dbus rule which may represent a security lack. I ask those who have more knowledge of dbus to give advice on.
suggestions are appreciated

Comment by: max.bra on Mon, 16 Nov 2009 21:43:13 +0000
However I do not think it's worth to be used on arch.
Dropping

Comment by: piezoelectric on Tue, 17 Nov 2009 01:52:06 +0000
It's a nice utility for multi-user environments. Especially those with inexperienced users.

    
      First Submitted: Tue, 20 Oct 2009 20:30:35 +0000    
indicator-applet 0.2.0-2 : A small applet to display information from various applications consistently in the panel. (Canonical Ayatana Project)
( Unsupported package: Potentally dangerous ! )
==>  Edit the PKGBUILD (highly recommended for security reasons) ? [Y/n]("A" to abort)
==>   ----------------------------------------------
==>n


==> indicator-applet dependencies:
 - gconf (already installed)
 - gnome-panel (already installed)
 - indicator-messages (building from AUR)
 - indicator-session (building from AUR)

==> WARNING: This PKGBUILD contains install file that can be dangerous.
indicator-applet.install
==>  Edit indicator-applet.install (highly recommended for security reasons) ? [Y/n] ("A" to abort)
==>   ----------------------------------------------
==>n

==>  Continue the building of indicator-applet ? [Y/n]
==>   ----------------------------------------------
==>y

==> Building missing dependencies from AUR:
==> Resuming previous build

==> Downloading indicator-messages PKGBUILD from AUR...
tar: Record size = 15 blocks

    
      First Submitted: Mon, 16 Nov 2009 20:51:33 +0000    
indicator-messages 0.2.6-1 : A place on the user's desktop that collects messages that need a response. (Canonical Ayatana Project)
( Unsupported package: Potentally dangerous ! )
==>  Edit the PKGBUILD (highly recommended for security reasons) ? [Y/n]("A" to abort)
==>   ----------------------------------------------
==>n


==> indicator-messages dependencies:
 - libindicate (building from AUR)
 - libdbusmenu (building from AUR)
 - libindicator (building from AUR)

==> WARNING: This PKGBUILD contains install file that can be dangerous.
indicator-messages.install
==>  Edit indicator-messages.install (highly recommended for security reasons) ? [Y/n] ("A" to abort)
==>   ----------------------------------------------
==>n

==>  Continue the building of indicator-messages ? [Y/n]
==>   ----------------------------------------------
==>y

==> Building missing dependencies from AUR:
==> Resuming previous build

==> Downloading libindicate PKGBUILD from AUR...
tar: Record size = 6 blocks

    
      First Submitted: Mon, 16 Nov 2009 20:50:29 +0000    
libindicate 0.2.3-1 : A small library for applications to raise \"flags\" on DBus for other components of the desktop to pick up and visualize. (Canonical Ayatana Project)
( Unsupported package: Potentally dangerous ! )
==>  Edit the PKGBUILD (highly recommended for security reasons) ? [Y/n]("A" to abort)
==>   ----------------------------------------------
==>n


==> libindicate dependencies:
 - glib2 (already installed)
 - gtk2 (already installed)
 - dbus-glib (already installed)
 - libxml2 (already installed)
==>  Continue the building of libindicate ? [Y/n]
==>   ----------------------------------------------
==>y


==> Install or build missing dependencies for libindicate:
==> Building and installing package

==> libindicate dependencies:
 - glib2 (already installed)
 - gtk2 (already installed)
 - dbus-glib (already installed)
 - libxml2 (already installed)
==> Making package: libindicate 0.2.3-1 x86_64 (Mon Nov 30 21:22:18 GMT 2009)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
  -> Found libindicate-0.2.3.tar.gz in build dir
==> Validating source files with md5sums...
    libindicate-0.2.3.tar.gz ... Passed
==> Extracting Sources...
  -> Extracting libindicate-0.2.3.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
/tmp/yaourt-tmp-mark/aur-libindicate/libindicate/./PKGBUILD: ./configure: /bin/sh: bad interpreter: Permission denied
==> ERROR: Build Failed.
    Aborting...
Error: Makepkg was unable to build libindicate package.


==> Install or build missing dependencies for indicator-messages:

==> Install or build missing dependencies for indicator-applet:
[mark@markspc ~]$

this is the most important bit

==> Starting build()...
/tmp/yaourt-tmp-mark/aur-libindicate/libindicate/./PKGBUILD: ./configure: /bin/sh: bad interpreter: Permission denied

any reason why this is happening?

thanks markp1989


Desktop: E8400@4ghz - DFI Lanparty JR P45-T2RS - 4gb ddr2 800 - 30gb OCZ Vertex - Geforce 8800 GTS - 2*19" LCD
Server/Media Zotac GeForce 9300-ITX I-E - E5200 - 4gb Ram - 2* ecogreen F2 1.5tb - 1* wd green 500gb - PicoPSU 150xt - rtorrent - xbmc - ipazzport remote - 42" LCD

Offline

#2 2009-11-30 21:27:22

JuseBox
Member
Registered: 2009-11-27
Posts: 260

Re: yaourt wont build any packages..../configure: /bin/sh: bad interpreter

Hello,
I saw the error:

Error: Makepkg was unable to build libindicate package.

make sure the makepkg package is updated.


Linux ArchLinux 3.2.8-1-ARCH
#1 SMP PREEMPT Mon Feb 27 21:51:46 CET 2012 x86_64 AMD FX(tm)-8120 Eight-Core Processor AuthenticAMD GNU/Linux
8192MB DDR3 1300MHz | Asus m5a97 | GeForce GTX 550 Ti | 120 GB SSD

Offline

#3 2009-11-30 22:46:02

tdy
Member
From: Sacremende
Registered: 2008-12-14
Posts: 438

Re: yaourt wont build any packages..../configure: /bin/sh: bad interpreter

markp1989 wrote:
==> Starting build()...
/tmp/yaourt-tmp-mark/aur-libindicate/libindicate/./PKGBUILD: ./configure: /bin/sh: bad interpreter: Permission denied

What are your /tmp permissions?

Also, is your /tmp on a separate partition?  If so, what is the fstab entry for it?

Last edited by tdy (2009-11-30 22:47:23)


dots (or just the awesomewm config)

$ whatis this?
this?: nothing appropriate.

Offline

Board footer

Powered by FluxBB