You are not logged in.

#1 2009-12-08 03:45:10

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

2.6.32 GTK Applications Slow Scrolling

Hi there,

I have updated my kernel to 2.6.32 yesterday (NO ati driver update).

After the update the scrolling in GTK applications like Firefox and Pidgin was slow as hell (X had >90% CPU load)

So I decided to downgrade to 2.6.31 again which worked like a charm.


The last update updated the -ati driver; But I am using the -radeonhd one.

"Internal Frames" like iframes as well as ALL KDE apps work well.


Xorg:

[kai@bierchen itsicherheitseminar]$ cat /etc/X11/xorg.conf                                         

# Auto-generated by Archie mkxcfg
# Auto-generated by Archie mkxcfg

Section "ServerLayout"

# PS/2 Mouse not detected
# Serial Mouse not detected
        Identifier     "Xorg Configured"
        Screen      0  "Screen0" 0 0   
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "USB Mouse" "CorePointer"
EndSection                                       

Section "Files"

# Additional fonts: Locale, Gimp, TTF...
#       FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
#       FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
        ModulePath   "/usr/lib/xorg/modules"                                   
        FontPath     "/usr/share/fonts/misc:unscaled"                           
        FontPath     "/usr/share/fonts/misc"                                   
        FontPath     "/usr/share/fonts/75dpi:unscaled"                         
        FontPath     "/usr/share/fonts/75dpi"                                   
        FontPath     "/usr/share/fonts/100dpi:unscaled"                         
        FontPath     "/usr/share/fonts/100dpi"                                 
        FontPath     "/usr/share/fonts/PEX"                                     
        FontPath     "/usr/share/fonts/cyrillic"                               
        FontPath     "/usr/share/fonts/Type1"                                   
        FontPath     "/usr/share/fonts/ttf/western"                             
        FontPath     "/usr/share/fonts/ttf/decoratives"                         
        FontPath     "/usr/share/fonts/truetype"                               
        FontPath     "/usr/share/fonts/truetype/openoffice"                     
        FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"             
        FontPath     "/usr/share/fonts/latex-ttf-fonts"                         
        FontPath     "/usr/share/fonts/defoma/CID"                             
        FontPath     "/usr/share/fonts/defoma/TrueType"                         
EndSection                                                                     

Section "Module"
        Load  "ddc"  # ddc probing of monitor
        Load  "dbe"                         
        Load  "dri"                         
        Load  "extmod"                       
        Load  "glx"                         
        Load  "bitmap" # bitmap-fonts       
        Load  "type1"                       
        Load  "freetype"                     
        Load  "record"                       
        #   Load  "synaptics"               
EndSection                                   

Section "ServerFlags"
        Option      "AllowMouseOpenFail" "true"
        Option      "AutoAddDevices" "False"   
EndSection                                     

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "CoreKeyboard"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de-latin1-nodeadkeys"
        Option      "XkbVariant" ""                   
EndSection                                           

Section "InputDevice"
        Identifier  "Serial Mouse"
        Driver      "mouse"       
        Option      "Protocol" "Microsoft"
        Option      "Device" "/dev/ttyS0"
        Option      "Emulate3Buttons" "true"
        Option      "Emulate3Timeout" "70" 
        Option      "SendCoreEvents" "true"
EndSection                                 

Section "InputDevice"
        Identifier  "PS/2 Mouse"
        Driver      "mouse"     
        Option      "Protocol" "auto"
        Option      "ZAxisMapping" "4 5"
        Option      "Device" "/dev/psaux"
        Option      "Emulate3Buttons" "true"
        Option      "Emulate3Timeout" "70" 
        Option      "SendCoreEvents" "true"
EndSection                                 

Section "InputDevice"
        Identifier  "USB Mouse"
        Driver      "mouse"   
        Option      "Device" "/dev/input/mice"
        Option      "SendCoreEvents" "true"   
        Option      "Protocol" "IMPS/2"       
        Option      "ZAxisMapping" "4 5"     
        Option      "Buttons" "5"             
EndSection                                   

Section "Monitor"
        Identifier   "Monitor0"
        Option      "DPMS" "true"
EndSection                       

Section "Device"
        Identifier  "Card0"
        Driver      "radeonhd"
        VendorName  "All"     
        BoardName   "All"     
EndSection                   


Section "Screen"
        Identifier "Screen0"
        Device     "Card0" 
        Monitor    "Monitor0"
        DefaultDepth     24 
        SubSection "Display"
                Depth     1 
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection                                                         
        SubSection "Display"                                                   
                Depth     4                                                   
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     8
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     15
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Virtual   3840 3840
                Depth     24
                Modes    "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Virtual   3840 3840
                Depth     32
                Modes    "1280x1024" "1024x768" "800x600" "640x480" "1920x1080" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

#Section "Screen"
#       Identifier "aticonfig-Screen[0]-0"
#       Device     "aticonfig-Device[0]-0"
#       Monitor    "aticonfig-Monitor[0]-0"
#       DefaultDepth     24
#       SubSection "Display"
#               Viewport   0 0
#               Depth     24
#       EndSubSection
#EndSection

Section "DRI"
        Mode         0666
EndSection

The screens are placed with xrandr.


lspci:

[kai@bierchen itsicherheitseminar]$ lspci
00:00.0 Host bridge: nVidia Corporation nForce2 IGP2 (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 06)
01:07.1 Input device controller: Creative Labs SB Live! Game Port (rev 06)
01:0a.0 Network controller: AVM GmbH A1 ISDN [Fritz] (rev 02)
01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:0c.0 RAID bus controller: Silicon Image, Inc. SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02)
01:0d.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 61)
02:00.0 VGA compatible controller: ATI Technologies Inc RV670 AGP [Radeon HD 3850]

Any ideas?

Last edited by Kai (2009-12-08 04:03:10)

Offline

#2 2009-12-08 12:04:50

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,625

Re: 2.6.32 GTK Applications Slow Scrolling

What does xdriinfo say?
Maybe its something related with KMS.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Online

#3 2009-12-08 12:21:33

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

[kai@bierchen itsicherheitseminar]$ xdriinfo
Screen 0: not direct rendering capable.

Offline

#4 2009-12-08 18:54:46

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,625

Re: 2.6.32 GTK Applications Slow Scrolling

Kai wrote:

[kai@bierchen itsicherheitseminar]$ xdriinfo
Screen 0: not direct rendering capable.

There you go, that's your problem, try to disable kms. Try adding nomodeset or radeon.modeset=0 to your kernel line and see if either entry helps.
http://wiki.archlinux.org/index.php/ATI#Disable_KMS


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Online

#5 2009-12-08 18:59:27

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: 2.6.32 GTK Applications Slow Scrolling

You should switch back to the ati driver and see if that improves things. Apparently radeonhd is on its way out, and the the ati driver should have KMS support with 2.6.32 (and it seems better 3D support too).


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#6 2009-12-08 19:11:42

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

@R00KIE

I tried that; if I disable KMS X crashed for whatever reason; the logs dont say anything

@B I tried the -ati one; it fixes the problem but dual view does not work which I need.

I'll fall back to .31 in the meantime.

Thanks!

Last edited by Kai (2009-12-08 19:12:48)

Offline

#7 2009-12-08 19:12:08

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: 2.6.32 GTK Applications Slow Scrolling

Do what B says. Move from radeonhd to radeon.

Offline

#8 2009-12-08 19:13:15

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

@flamelab see my last post...

Offline

#9 2009-12-08 19:26:37

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: 2.6.32 GTK Applications Slow Scrolling

@Kai: Read the ATi wiki page carefully smile

Offline

#10 2009-12-08 19:40:48

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

I did that and it dual view does not work; I'll wait for an updated -radeonhd.

Thanks anyway! :-)

Offline

#11 2009-12-08 19:41:04

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,625

Re: 2.6.32 GTK Applications Slow Scrolling

Did you try with the -ati from testing? I have the .32 kernel with the -ati driver form testing (and respective dependencies ... libdrm and maybe something else) and it works here.

I had to upgrade all that here before I could get things to work properly. You can also try without any xorg.conf (although I didn't touch that and things still work), anyway each case is different.

You can also try to add the DRI section in your xorg.conf, I don't have it and things work fine but who knows, trying isn't going to make things worse.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Online

#12 2009-12-08 19:45:15

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

I tried it with the DRI section and even with the GIT versions of the packets.

I have to admit that I have a 3850AGP which is known to cause some problems; I just thought somebody else has those problems as well.

Maybe when .32 is moved to [core].

Anyway; I'll do some additional testing tomorrow; if I dont find a solution I'll fill in a bug report :-)


Kai

Offline

#13 2009-12-08 19:55:46

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: 2.6.32 GTK Applications Slow Scrolling

I can confirm with my binary NVIDIA driver...
I didn't think it could be the kernel, but I don't have much else to blame right now, and this makes me think more that it was the kernel upgrade...

The problem is mostly in Firefox with long (yes, fully loaded) documents (example), I haven't really noticed it in anything else.  Turning off smooth scrolling helps.

Offline

#14 2009-12-08 22:10:35

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,625

Re: 2.6.32 GTK Applications Slow Scrolling

Ranguvar wrote:

I can confirm with my binary NVIDIA driver...
I didn't think it could be the kernel, but I don't have much else to blame right now, and this makes me think more that it was the kernel upgrade...

The problem is mostly in Firefox with long (yes, fully loaded) documents (example), I haven't really noticed it in anything else.  Turning off smooth scrolling helps.

Interesting read that one tongue

But here does work fine, however xdriinfo spits this out:

$ xdriinfo 
Screen 0: r600

I'm using kernel26 2.6.32-1 kernel26-firmware 2.6.32-1 kernel26-headers 2.6.32-1 libdrm 2.4.16-1 and xf86-video-ati 6.12.99.git20091207-1.

I have no other packages from testing and my system is up-to-date, now I can have it working properly either with or without kms. I guess these latest changes can be a big headache for us that use the latest and greatest ... ish versions of the software.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Online

#15 2009-12-15 16:41:44

Kai
Member
From: Germany
Registered: 2006-12-11
Posts: 27

Re: 2.6.32 GTK Applications Slow Scrolling

HI there,

sorry for the delay but I had to do something else.

The newest problem:

If I delete/rename the xorg.conf everything but dual view works fine.

KDE says:

http://img267.imageshack.us/img267/8719/37292075.png

and

http://img209.imageshack.us/img209/1464/33431960.png

[kai@bierchen ~]$ !xra
xrandr --output DVI-I_1/digital --right-of DVI-I_2/digital
warning: output DVI-I_1/digital not found; ignoring

If I disable(!) KMS and start X with my xorg.conf dualview works fine;

[kai@bierchen itsicherheitseminar]$ xdriinfo
Screen 0: r600

but the following appears in dmesg:

Pid: 0, comm: swapper Not tainted 2.6.32-ARCH #1
Call Trace:
 [<c1088554>] ? __report_bad_irq+0x24/0x90
 [<c10871c5>] ? handle_IRQ_event+0x45/0x190
 [<c1088710>] ? note_interrupt+0x150/0x190
 [<c1088e6b>] ? handle_fasteoi_irq+0xab/0xd0
 [<c1006405>] ? handle_irq+0x15/0x30
 [<c1005977>] ? do_IRQ+0x47/0xc0
 [<c1005980>] ? do_IRQ+0x50/0xc0
 [<c1003ff0>] ? common_interrupt+0x30/0x38
 [<c12b3fb6>] ? _spin_unlock_irqrestore+0x6/0x30
 [<f8da4571>] ? sbliveintr+0x281/0x730 [oss_sblive]
 [<c1006405>] ? handle_irq+0x15/0x30
 [<c1045471>] ? irq_exit+0x31/0x70
 [<c1005980>] ? do_IRQ+0x50/0xc0
 [<c10663cc>] ? clockevents_program_event+0x8c/0x130
 [<c1003ff0>] ? common_interrupt+0x30/0x38
 [<f8cd6b0c>] ? osscore_intr+0x1c/0x60 [osscore]
 [<c10871c5>] ? handle_IRQ_event+0x45/0x190
 [<c1088e25>] ? handle_fasteoi_irq+0x65/0xd0
 [<c1006405>] ? handle_irq+0x15/0x30
 [<c1005977>] ? do_IRQ+0x47/0xc0
 [<c105d560>] ? hrtimer_start+0x20/0x30
 [<c1003ff0>] ? common_interrupt+0x30/0x38
 [<c1023dd2>] ? native_safe_halt+0x2/0x10
 [<c100b19f>] ? default_idle+0x3f/0xb0
 [<c1002904>] ? cpu_idle+0x94/0xe0
 [<c13dc85d>] ? start_kernel+0x335/0x33a
 [<c13dc366>] ? unknown_bootoption+0x0/0x190
handlers:
[<f82c2e70>] (irq_handler+0x0/0x4e0 [firewire_ohci])
Disabling IRQ #17

edit:

With the new kernel Xorg sometimes consumes over 80% of the CPU, esp. when flash is running...

Last edited by Kai (2009-12-15 17:31:15)

Offline

#16 2009-12-20 03:34:47

broch
Banned
From: L.A. California
Registered: 2006-11-13
Posts: 975

Re: 2.6.32 GTK Applications Slow Scrolling

Ranguvar wrote:

I can confirm with my binary NVIDIA driver...
I didn't think it could be the kernel, but I don't have much else to blame right now, and this makes me think more that it was the kernel upgrade...

The problem is mostly in Firefox with long (yes, fully loaded) documents (example), I haven't really noticed it in anything else.  Turning off smooth scrolling helps.

Well,
it does not happen in my case:
nvidia 7400 Go
nvidia driver 195.22 or 190.53 (lower number but newer than 195.22)
custom kernel 2.6.32-zen2 (git, I don't use PKGBUILDS for kernels)
xor-server 1.6.3-4
system up to date with exception of xorg-server, as the latest 1.7 is really slow

smooth scrolling enabled and after FBSD handbook is loaded, I can scroll as fast as possible. CPU goes up to 35% but with second scrolling stays at 8.7%

I don't know about ATI (although without direct rendering enabled - not so surprising), but whatever scrolling problems in GTK apps with NVIDIA seem not to be related to kernel.

Last edited by broch (2009-12-20 03:37:04)

Offline

Board footer

Powered by FluxBB