You are not logged in.

#1 2003-07-30 21:35:33

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 361
Website

Crummy looking fonts in KDE

I'm new to Arch and finally got XFree up and running. However, the fonts on KDE look terrible and out of proportion. Tried changing all my fonts in the configuration menus to Times, which I know to be fairly clean in Windows but I still get funny looking fonts that strain my eyes. Any help for a newbie on where to go with this problem would be greatly appreciated, thanks. I also have a flat panel monitor.

JSkier


--
JSkier

Offline

#2 2003-07-30 21:37:20

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Crummy looking fonts in KDE

i don't know if this will help but as root type:

fc-cache -v

this may give you better looking fonts.


AKA uknowme

I am not your friend

Offline

#3 2003-07-30 21:55:34

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 361
Website

Re: Crummy looking fonts in KDE

That I did try, with no success. I also read over some documentation at XFree on fonts which only confused me.

Jskier


--
JSkier

Offline

#4 2003-07-30 22:58:28

Mt.Tam-Luxer
Member
From: San Rafael, CA, U.S.A.
Registered: 2003-07-24
Posts: 32

Re: Crummy looking fonts in KDE

OK .. as you would see from my other posts, fonts in Linux are tricky.  Arch gives you the opportunity to learn from the ground up.  So, here's my advice:

1.  Consider using HWD from rasat(search the forum for this post).  Otherwise, make sure your XF86Config file is sane/appropriate.

2.  Make sure 'Load Freetype' is in the modules section !!!

3.  Put the correct value for your monitor in mm as the value of 'DisplaySize' under Section:  Monitor in your XF86Config.  See 'man XF86Config' for description of this item.  It makes a BIG difference for me on all type of monitors and I don't understand why it is not more commonly recommended(!?).

4.  Make sure you  are running your LCD at its' recommended and 'native' resolution.

5.  Consider using the Bitstream Vera Fonts from 'gnome.org/fonts'.  I think they beat the MS fonts anyday(IMHO).  Don't forget to run 'fc-cache' after installing.

6.  Make sure 'Anti-Alais' is 'ON' in KDE/Gnome and experiment with the sizes.

7.  Consider using the XFT build of Mozilla in 'incoming'.

8.  Know that I am still learning and others may wish to add/change my ideas.  I'm very interested in this 'Arch/Font' thing, too.

Cheers.

Offline

#5 2003-07-30 23:16:01

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: Crummy looking fonts in KDE

Yes, the default fonts (especially in the titlebar) look pretty chunky.  If you have a windows license, I'd recommend downloading the Microsoft fonts from  here: http://webperf.org/msfonts/msfonts-1.2.1.tar.gz

# tar zxvf msfonts-1.2.1.tar.gz
# cp -a msfonts-1.2.1/main /usr/X11R6/lib/X11/fonts/ms
# cd /usr/X11R6/lib/X11/fonts/ms
# ttmkfdir >fonts.scale
# mkfontdir
# fc-cache -v

I don't think the ttmkfdir/mkfontdir stuff is still needed, but it doesn't hurt.  Also check that you have the freetype and xtt modules loading in the Modules section of your XF86Config.

Pretty fonts.  smile

Offline

#6 2003-07-31 00:14:18

Mt.Tam-Luxer
Member
From: San Rafael, CA, U.S.A.
Registered: 2003-07-24
Posts: 32

Re: Crummy looking fonts in KDE

apeiro wrote:

I don't think the ttmkfdir/mkfontdir stuff is still needed, but it doesn't hurt.  Also check that you have the freetype and xtt modules loading in the Modules section of your XF86Config.


FYI:

"The bitmap, freetype, speedo, type1, and xtt modules are all font rasterizers.  The freetype and xtt modules should _not_ be enabled at the same time, as they are incompatible.  The freetype module should be used for Western languages and anti-aliased font support; the xtt module should be used for East Asian character set support (specifically, for CID-keyed fonts)."


~

Offline

#7 2003-07-31 00:23:52

Guest
Guest

Re: Crummy looking fonts in KDE

Thanks for the quick response times everyone. I was able to get the Windows fonts up and running, so most apps in KDE look awesome. I will try the Gnome fonts at a later time, I'm always looking for Windows alternatives  tongue

Thanks again,
JSkier

#8 2003-07-31 01:34:55

Mt.Tam-Luxer
Member
From: San Rafael, CA, U.S.A.
Registered: 2003-07-24
Posts: 32

Re: Crummy looking fonts in KDE

For those who want _even_more_info:


DESCRIPTION OF XF86CONFIG MODULES:


   The GLCore and glx modules enable software OpenGL rendering.  The
   dri module enables support in the X server for Direct Rendering
   Infrastructure (DRI).  Note that support for DRI must also exist
   in the kernel, the video card, and the installed version of the
   Mesa libraries for hardware-accelerated 3D operations using DRI
   to work.  Otherwise, the server falls back to software rendering.
    .
   The vbe and ddc modules enable support for VESA BIOS Extensions
   and Data Display Channel, respectively.  These modules are used
   to query monitor capabilties via the video card.  The int10
   module is a real-mode x86 emulator that is used to softboot
   secondary VGA cards.  Note that the vbe module depends on the
   int10 module, so if wish to enable vbe, enable int10 as well.
    .
   The dbe module enables the double-buffering extension in the
   server, and is useful for animation and video operations.
    .
   The extmod module enables many traditional and commonly used
   extensions, such as shaped windows, shared memory, video mode
   switching, DGA, and Xv.  The record module implements the RECORD
   extension, commonly used in server testing.
    .
   The bitmap, freetype, speedo, type1, and xtt modules are all
   font rasterizers.  The freetype and xtt modules should not
   be enabled at the same time, as they are incompatible.  The
   freetype module should be used for Western languages and
   anti-aliased font support; the xtt module should be used for
   East Asian character set support (specifically, for CID-keyed
   fonts).
   .
   For further information about these modules, please consult the
   XFree86 documentation.
    .
   If you unsure what to do, leave all of the modules enabled
   except xtt.  Advanced users may wish to disable all modules --
   in which case no Modules section will be written to the X server
   configuration file -- and add their own Modules section to the
   file manually.

Offline

#9 2004-06-12 07:24:03

monolin
Member
Registered: 2004-03-06
Posts: 31

Re: Crummy looking fonts in KDE

Add this fonts.conf file to your $HOME and rename it .fonts.conf and you will have sharper font display. This is especially useful when you want to get rid of anti-aliasing effects and use Asian language.
I don't know what generated, but it is effective to enhance Chinese display:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <test compare="more" name="size" qual="any" >
   <double>7</double>
  </test>
  <test compare="less" name="size" qual="any" >
   <double>16</double>
  </test>
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
 <match target="font" >
  <test compare="more" name="pixelsize" qual="any" >
   <double>9</double>
  </test>
  <test compare="less" name="pixelsize" qual="any" >
   <double>20</double>
  </test>
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>

When false is taken for true, true becomes false;
If non-being turns into being, being becomes non-being.

Pages full of fantastic talk
Penned with bitter tears;
All men call the author mad,
None his message hears.

Offline

#10 2004-08-01 08:31:19

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: Crummy looking fonts in KDE

It's also a good idea (if you want to go all the way) to enable the bytecode interpreter in libfreetype for better AA results. I don't know whether the arch package already does that--only been on Arch for two days, now--but usually, font display will gain lots from it.

A nice primer for font-deuglisation can be found here:

http://feenix.burgiss.net/ldp/fdu/index.html

It also contains the how-to for enabling truetype hinting / the bytecode interpreter.

93,
-Sascha.rb

P.S. Hi everybody. First posting here. smile -.rb

Offline

#11 2004-08-01 21:19:15

marin_linuxer
Member
From: San Rafael, CA U.S.A.
Registered: 2003-09-03
Posts: 111
Website

Re: Crummy looking fonts in KDE

I was once told, a while back, that the bytecode was enabled in Arch.  I suspect it still is.


-- Linux!  Isn't it time?

Offline

#12 2004-08-01 21:25:35

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: Crummy looking fonts in KDE

marin_linuxer wrote:

I was once told, a while back, that the bytecode was enabled in Arch.  I suspect it still is.

It certainly looks like it at first glance. But as I mostly use Bitstream Vera fonts only and they're excellent to begin with, I wasn't too sure.

What's crucial for proper font rendering, in any case, is exact dpi settings for your X-Server--especially on TFT displays. On my 20" TFT, even running 98dpi rather than 100dpi will make the fonts look crude and buggered.

93,
-Sascha.rb

Offline

#13 2004-08-02 00:02:55

marin_linuxer
Member
From: San Rafael, CA U.S.A.
Registered: 2003-09-03
Posts: 111
Website

Re: Crummy looking fonts in KDE

yeah, that's true.  I always set the 'DisplaySize' variable in the xorg.conf Monitor() in mm.  My 15" LCD turns out to be 85x85 dpi.  I'm still not clear how the Gnome Font system interacts with the X server DisplaySize variable(if at all).  It seems that GTK2 has it's own methods with Fontconfig separate from say the Toolbar bar in Mozilla(!?).


-- Linux!  Isn't it time?

Offline

#14 2004-09-10 21:42:33

Olli
Member
Registered: 2004-04-01
Posts: 57

Re: Crummy looking fonts in KDE

Mt.Tam-Luxer wrote:

.  Consider using the Bitstream Vera Fonts from 'gnome.org/fonts'.  I think they beat the MS fonts anyday(IMHO).

I just made this strange observation in relation to MS core fonts and OSS fonts and KDE. Nowadays I turn off the AA fonts because they are just too fuzzy looking. Now using a font like Bitstream Vera (Sans if possible) my KDE would look like this:

http://www.xs4all.nl/~olli/pics/nomsfonts.png

Though using any of the MS core fonts I get a nice and crisp look, like this:

http://www.xs4all.nl/~olli/pics/msfonts.png

This makes me wonder what the big difference is between the Bitstream Vera and the MS core fonts....


DIY: Doom-It-Yourself

Offline

#15 2004-09-13 17:02:14

marin_linuxer
Member
From: San Rafael, CA U.S.A.
Registered: 2003-09-03
Posts: 111
Website

Re: Crummy looking fonts in KDE

1.  Are you using a LCD or CRT?

2.  If LCD, are you using 'Best Shapes' or 'Sub-Pixel Rendering(RGB|BGR|GRB|etc)?

3.  If LCD, are you running your screen at 'Native' resolution?

4.  If CRT, try using a slightly larger Font Size ... anything below 8 or 10 pt size in AA is gonna look fuzzy.

5.  Vera wasn't really designed for non-AA if I understand the system architecture of TTF.

6.  M$ paid big-money for their fonts and somehow got a better end-product???

6.  You know all this and I'm spurting fizzy-pop foo(!?)


-- Linux!  Isn't it time?

Offline

#16 2004-12-08 08:27:01

Poprocks
Member
Registered: 2004-12-08
Posts: 26

Re: Crummy looking fonts in KDE

I've had my share of troubles with fonts, but after lots of hard work, I realized that there are ways to solve problems.  I'd like to say first off that I agree fully with the bytecode interpreter being enabled.  I also agree that the msttcorefonts should be installed, along with the bitstream vera fonts.

However, most people get discouraged, because the Bitstream Vera fonts look awesome antialiased, and the corefonts look awesome not antialiased.  But I have yet to see a GUI that lets you configure which font families are antialiased and which ones are not.  So I played with fonts.conf a bit, and to my delight, I came up with something that works for me and should work for most.

Put this in your ~/.fonts.conf :

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <dir>~/.fonts</dir>

<match target="font" >
 <edit mode="assign" name="antialias" >
  <bool>true</bool>
 </edit>
</match>


 <match target="font" >
  <test compare="eq" name="family" qual="any" >
   <string>Arial</string>
   <string>Arial Black</string>
   <string>Comic Sans MS</string>
   <string>Courier New</string>
   <string>Georgia</string>
   <string>Tahoma</string>
   <string>Times New Roman</string>
   <string>Trebuchet MS</string>
   <string>Verdana</string>
   <string>Webdings</string>
  </test>

  <test compare="less" name="size" qual="any" >
   <double>16</double>
  </test>

  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>

 <match target="font" >
  <test compare="eq" name="family" qual="any" >
   <string>Arial</string>
   <string>Arial Black</string>
   <string>Comic Sans MS</string>
   <string>Courier New</string>
   <string>Georgia</string>
   <string>Tahoma</string>
   <string>Times New Roman</string>
   <string>Trebuchet MS</string>
   <string>Verdana</string>
   <string>Webdings</string>
  </test>
                                                                                
  <test compare="less" name="pixelsize" qual="any" >
   <double>18</double>
  </test>
                                                                                
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>


</fontconfig>

Basically this sets all fonts antialiased, but excludes the Microsoft corefonts.  I have left Impact antialiased because I feel it looks better that way.  But that can be changed at your discretion.

I hope this helps someone!


I take my Poprocks with Diet Pepsi

Offline

#17 2004-12-08 15:35:34

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Crummy looking fonts in KDE

Interesting... personally I don't use the MS Core fonts as the Bitstream Vera fonts work wonderfully

Offline

Board footer

Powered by FluxBB