You are not logged in.

#1 2009-12-17 08:45:54

sacarde
Member
Registered: 2006-07-14
Posts: 380

usb automount problem

hi,
   I run kdemod3 on arch64: with: hal-0.5.13 and policykit-0.9
all works ok, until some days ago, I have this error:

Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=1000 pid=2537 comm="kded [kdeinit] --new-startup) interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=2219 comm="/usr/sbin/hald))

I try changing some PolicyKit.conf
but error is the same...

can you help me?



thankyou

Offline

#2 2009-12-17 09:02:50

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: usb automount problem

What file manager are you using? Generally automount is called on when you click on the USB in your file manager unless you have it setup to automount when the usb is plugged in? Hal detects it and then when you click it in file manager it talks with hal to mount it so it could be a number of issues all the way back to your fstab even.

Offline

#3 2009-12-17 09:23:36

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: usb automount problem

- I insert my usb pendrive
- system detect it
- kde ask me what to do
- konqueror try to mount and open it
- this error: http://sacarde.interfree.it/errore-hal-polkit.jpg

Offline

#4 2009-12-18 12:47:38

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: usb automount problem

from irc I have this workaround

- dont use kdm
- but I login as user
- and then run: startx   (with .xinitrc:  exec ck-launch-session startkde)

now automount is OK


p.s.
but I avent understand why

Offline

#5 2009-12-18 19:52:57

alex404
Member
Registered: 2009-12-03
Posts: 51

Re: usb automount problem

I'm getting the same problem with xfce (and I had it with enlightenment) so an answer to this would be super handy. I tried installing autofs as per the Arch wiki, but I get the same problem. Using slim as my login manager. This is the error I get:

Rejected send message, 1 matched rules; type="method_call", sender=":1.12" (uid=1000 pid=1519 comm="exo-mount) interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=1288 comm="/usr/sbin/hald))

Last edited by alex404 (2009-12-18 19:53:26)

Offline

#6 2009-12-24 17:15:04

k2000
Member
Registered: 2009-12-02
Posts: 33

Re: usb automount problem

Same problem here!
I use openbox with pcmanfm. When I click on my usb device in the file manager I got the error.
If I start pcmanfm as root, it works...
I've tried running thunar -d instead on pcmanfm, it tries to mount the device as soon as I insert it, but I still got the error.
I dont't use kdm or gdm, I login in console then startx.
Help would be welcomed!

Offline

#7 2009-12-24 17:39:15

jwbirdsong
Member
From: Western KS USA
Registered: 2006-11-25
Posts: 173

Re: usb automount problem

If you are having automount problems and get the error

IsCallerPrivileged failed

make SURE you are using exec ck-launch-session WM/DMSTART to launch instead of just exec. See HERE

Last edited by jwbirdsong (2009-12-24 17:45:52)


PLEASE read and try to FIX/FILE BUGS instead of assuming other have/will.

Offline

#8 2009-12-24 19:04:51

alex404
Member
Registered: 2009-12-03
Posts: 51

Re: usb automount problem

I was able to fix this by playing with HAL permissions as specified here:

http://wiki.archlinux.org/index.php/HAL

Offline

#9 2009-12-24 19:19:26

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: usb automount problem

the problem is that ...
if I run startx from user.... all is OK

if I run daemon /etc/rc.d/kdm3 ..... is not OK

p.s.
I try to modify:
/opt/kde/share/apps/kdm/sessions/kde.desktop
with
Exec=/usr/bin/ck-launch-session /opt/kde/bin/startkde

but same error

Last edited by sacarde (2009-12-25 07:55:35)

Offline

#10 2009-12-25 03:59:57

k2000
Member
Registered: 2009-12-02
Posts: 33

Re: usb automount problem

The error was not saying "IsCallerPrivileged failed", but ck-launch-session resloved the problem.
I was using "dbus-launch --exit-with-session openbox-session" like the wiki said to.
great thanks!

Offline

#11 2009-12-25 07:55:51

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: usb automount problem

you dont use kdm3 ?

Offline

#12 2009-12-25 13:36:01

k2000
Member
Registered: 2009-12-02
Posts: 33

Re: usb automount problem

No, I just login in the terminal, and then startx.
You probably have to find the configuration find for kdm3 and ajust the command line that start your wm... Is that what kde.desktop do?

Offline

#13 2009-12-26 16:35:26

sacarde
Member
Registered: 2006-07-14
Posts: 380

Re: usb automount problem

solved from kdm3 too

I change in: /etc/dbus-1/system.d/hal.conf

<!-- Only allow users at the local console to manipul...>
<policy at_console="false">

Offline

Board footer

Powered by FluxBB