You are not logged in.

#1 2009-12-20 19:55:29

sjakub
Member
From: Canada/Poland
Registered: 2008-06-16
Posts: 84

2.6.32 - Alsa problem

Hi.

I have installed 2.6.32 from testing, and my microphones (both internal and external) stopped working.
When I was using kernel 2.6.31, there were some more entries in alsamixer:
In 'Playback' section I am missing 'Line' 'CD', 'Mic' and 'Front Mic'.
In 'Capture' section I am missing entry for choosing 'Input source' (between mic, front mic, line and cd).
Now all those entries are gone. After downgrade to 2.6.31.6 they are all back.

I have also discovered, that sound quality (at least with skype) is horrible in 2.6.31 too - and it used to work fine...

What is the best place to submit some bugreports? Archlinux's bugtracker, alsa, or kernel itself?

Offline

#2 2010-01-02 00:22:08

Habmala
Member
From: Sweden
Registered: 2010-01-02
Posts: 21
Website

Re: 2.6.32 - Alsa problem

Hi
I'm having a similar error, after updating to 2.6.32 (from core) my microphone stoped working, but it was working fine in 2.6.31.

I have a bunch of problems whit the new kernel, but this is one of the tricky ones because I have no clue as to where to start. My alsamixer had very few options before the update, but seems to still have the same few options though. But the input settings don't seem to do anything, I've tryed different microphones and I know they are good, but the computer simply doesn't seem to recognice any activity. I haven't found any error messages, although I'm not sure where I would look for them in this case.

Any way, I don't get it. :/

Ps. I don't have an internal mic. so it's just fore external.

Offline

#3 2010-01-02 10:49:47

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,790

Re: 2.6.32 - Alsa problem

Sometimes after a kernel update I have to re-run alsa configuration to get things working properly, try following the alsa section of the wiki from scratch again.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#4 2010-01-02 19:23:36

Habmala
Member
From: Sweden
Registered: 2010-01-02
Posts: 21
Website

Re: 2.6.32 - Alsa problem

Yes I had some problems at bootup when alsa tried to restore my old volume levels, which were fixed by resetting alsa.
And after your tip I also tried a complete redo of the whole thing, but it doesn't seem to solve my problem. The mic. is still not responding. I've tried adding settings to modprobe.conf and I have set all the levels to maximum and tried different ways of recording. It doesn't help.

Thanks anyway,

Ps
I did find someone who seems to have had similar issues and managed to get by, didn't say how though. I'll try to get in contact whit them and se.
http://sidux.com/PNphpBB2-viewtopic-t-1 … vious.html
/Ds

EDIT: I sent a message to the author at that forum, just have to see if he can help. :)

Also I just realised that maybe this is starting to go OT as the headline says '[testing] Repo Forum » 2.6.32 - Alsa problem'? If so, sorry.

// Habmala

Last edited by Habmala (2010-01-02 19:42:44)

Offline

#5 2010-01-03 14:58:20

spookyln
Member
From: Czech Rep
Registered: 2009-02-10
Posts: 39

Re: 2.6.32 - Alsa problem

hi,
try set levels using alsamixer and store values "alsactl store"
after that write "alsactl restore" into rc.local

this working for me.

Offline

#6 2010-01-06 19:31:38

Habmala
Member
From: Sweden
Registered: 2010-01-02
Posts: 21
Website

Re: 2.6.32 - Alsa problem

Hello again.

I fixed it, silly me, I thougt I had tried a lot of different mode settings, but google finally gave me even more. So I had to switch to another one. I had auto before but lenova did the trick.

Thanks anyway ngoonee and spookyln.

Offline

Board footer

Powered by FluxBB