You are not logged in.

#1 2009-12-20 22:00:16

Fixnum
Member
Registered: 2009-12-02
Posts: 6

[SOLVED]New xf86-video-intel + 2.6.31.5 (Xen) kernel -> X won't start

I upgraded yesterday:

[2009-12-19 ...] upgraded gtksourceview2 (2.8.1-1 -> 2.8.2-1)
[2009-12-19 ...] upgraded gedit (2.28.2-1 -> 2.28.3-1)
[2009-12-19 ...] upgraded gtk-doc (1.11-2 -> 1.13-1)
[2009-12-19 ...] upgraded hal (0.5.13-3 -> 0.5.14-1)
[2009-12-19 ...] upgraded xcb-proto (1.5-1 -> 1.6-1)
[2009-12-19 ...] upgraded libxcb (1.4-1 -> 1.5-1)
[2009-12-19 ...] upgraded xf86-video-intel (2.9.1-1 -> 2.9.99.902-1)
[2009-12-19 ...] upgraded xorg-xkb-utils (7.5-1 -> 7.5-2)

After this, I can boot normally into the normal kernel2.6.32 configuration, but booting into Xen, which uses 2.6.31.9, fails to start X11 with the error:

INIT: Id "x" respawning too fast; disabled for 5 minutes

.

It turns out downgrading xf86-video-intel solves the problem.

I've posted the relevant Xorg.log.0 at http://pastebin.com/m5efab9b7.  It fails like this:

...
(II) LoadModule: "fbdev"
(WW) Warning, couldn't open module fbdev
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 00@00:02:0
(WW) Falling back to old probe method for vesa
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.
 
Fatal server error:
no screens found
...

Is this a bug, a module problem in Xen, or something that's going to affect everyone not running a 2.6.32 kernel? 

Thanks for your help!

Edit: the Xen kernel release was actually 2.6.31.5, not 2.6.31.9.

Last edited by Fixnum (2009-12-21 04:26:57)

Offline

#2 2009-12-20 22:09:54

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: [SOLVED]New xf86-video-intel + 2.6.31.5 (Xen) kernel -> X won't start

Straight from your own log:

(EE) intel(0): No kernel modesetting driver detected.

Are you using KMS?

Offline

#3 2009-12-21 00:19:31

Fixnum
Member
Registered: 2009-12-02
Posts: 6

Re: [SOLVED]New xf86-video-intel + 2.6.31.5 (Xen) kernel -> X won't start

OK, I added a KMS option to my /boot/grub/menu.lst:

module /vmlinuz26-xen-dom0 root=/dev/sda5 ro i915.modeset=1

It now works.  I guess the Xen kernel build didn't have KMS activated by default, unlike the vanilla kernel, and the video driver updates now require it.

Thanks for pointing me in the right direction.

Last edited by Fixnum (2009-12-21 04:29:05)

Offline

Board footer

Powered by FluxBB