You are not logged in.

#1 2009-12-27 08:03:49

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

[SOLVED] MythTV Live TV not starting

hey guys :>
mythtv seems to be up and running and everything is configured, though the live TV won't start when i push the "TV" button.
somehow there are any permission problems (says google) concerning the folder where mythtv puts its recordings in (but it won't work as root neither sad )

so i did: chown -R mythtv.mythtv /mnt/files/MythTV/
but it just says "invalid user"

this is the error I get when i try to start it

2009-12-27 09:01:52.404 TV: Attempting to change from None to Watching WatchingLiveTV
2009-12-27 09:01:52.407 MythContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2009-12-27 09:01:52.408 Using protocol version 50
2009-12-27 09:01:52.426 Spawning LiveTV Recorder -- begin
2009-12-27 09:01:52.526 Spawning LiveTV Recorder -- end
2009-12-27 09:01:52.527 GetEntryAt(-1) failed.
2009-12-27 09:01:52.528 EntryToProgram(0@Do. Jan 1 01:00:00 1970) failed to get pginfo
2009-12-27 09:01:52.528 TV Error: HandleStateChange(): LiveTV not successfully started
2009-12-27 09:01:52.528 We have a RingBuffer
2009-12-27 09:01:52.579 TV Error: LiveTV not successfully started
2009-12-27 09:01:52.601 ScreenSaverX11Private: DPMS Deactivated 1
2009-12-27 09:01:52.602 ScreenSaverX11Private: DPMS Reactivated 1

best regards cool

Last edited by arch0r (2009-12-28 14:56:38)

Offline

#2 2009-12-27 16:01:14

timm
Member
From: Wisconsin
Registered: 2004-02-25
Posts: 417

Re: [SOLVED] MythTV Live TV not starting

Did you create a user named mythtv and a group named mythtv?

Is the directory set up in mythtv-setup for recording the same one you're trying to use?

Please show the ls -al output for your recording directory.

Last edited by timm (2009-12-27 16:02:21)

Offline

#3 2009-12-27 16:38:40

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: [SOLVED] MythTV Live TV not starting

thx for your reply, ls -al says:

[gentox@valhalla files]$ ls -al
drwxrwxrwx   2 gentox users      4096 27. Dez 09:01 MythTV

i didn't create a mythtv user nor a mythtv group. just tried to start it with my normal user smile

Offline

#4 2009-12-28 02:08:00

timm
Member
From: Wisconsin
Registered: 2004-02-25
Posts: 417

Re: [SOLVED] MythTV Live TV not starting

You can't chown anything to a user and group unless you first create the user and group.  Check the wiki on how to do that.

You might want to find out who mythbackend runs as (ps aux |grep myth) and then chown the recording directory to that user and group.

Offline

#5 2009-12-28 10:05:22

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: [SOLVED] MythTV Live TV not starting

i know. i thought it would be created automatically.

ps aux | grep myth says:

root      4524  0.5  3.1 200384 28120 ?        Ssl  11:04   0:00 mythbackend --daemon --logfile /var/log/mythbackend.log --pidfile /var/run/mythbackend.pid

but as i said, it won't even run under root hmm


this is the output of mythfilldatabase

[root@valhalla gentox]# mythfilldatabase
2009-12-28 11:35:20.166 Using runtime prefix = /usr
2009-12-28 11:35:20.167 Using configuration directory = /root/.mythtv
2009-12-28 11:35:20.167 Unable to read configuration file mysql.txt  
2009-12-28 11:35:20.168 Empty LocalHostName.                         
2009-12-28 11:35:20.168 Using localhost value of valhalla            
2009-12-28 11:35:20.183 New DB connection, total: 1                  
2009-12-28 11:35:20.190 Connected to database 'mythconverg' at host: localhost
2009-12-28 11:35:20.190 Closing DB connection named 'DBManager0'              
2009-12-28 11:35:20.192 Connected to database 'mythconverg' at host: localhost
2009-12-28 11:35:20.197 Current MythTV Schema Version (DBSchemaVer): 1244     
2009-12-28 11:35:20.200 New DB connection, total: 2                           
2009-12-28 11:35:20.202 Connected to database 'mythconverg' at host: localhost
2009-12-28 11:35:20.203 Source 1 configured to use only the broadcasted guide data. Skipping.                                                                                         
2009-12-28 11:35:20.205 Data fetching complete.                                            
2009-12-28 11:35:20.205 Adjusting program database end times.                              
2009-12-28 11:35:20.206     0 replacements made                                            
2009-12-28 11:35:20.206 Marking generic episodes.                                          
2009-12-28 11:35:20.207     Found 0                                                        
2009-12-28 11:35:20.207 Fudging non-unique programids with multiple parts.                 
2009-12-28 11:35:20.208     Found -1                                                       
2009-12-28 11:35:20.208 Marking repeats.                                                   
2009-12-28 11:35:20.211     Found 0
2009-12-28 11:35:20.211 Unmarking new episode rebroadcast repeats.
2009-12-28 11:35:20.212     Found 0
2009-12-28 11:35:20.212 Marking episode first showings.
2009-12-28 11:35:20.213     Found 0
2009-12-28 11:35:20.213 Marking episode last showings.
2009-12-28 11:35:20.214     Found 0
2009-12-28 11:35:20.216
===============================================================
| Attempting to contact the master backend for rescheduling.  |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted.                            |
===============================================================
2009-12-28 11:35:20.224 MythContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2009-12-28 11:35:20.227 Using protocol version 50
2009-12-28 11:35:20.264 mythfilldatabase run complete.

Last edited by arch0r (2009-12-28 10:36:11)

Offline

#6 2009-12-28 13:57:45

ljshap
Member
From: Ossining, NY
Registered: 2008-01-23
Posts: 144

Re: [SOLVED] MythTV Live TV not starting

Do you get a good video from:

   cat /dev/video0 > video.mpg            #   As root.  video0 might be different.


Is the backend running when you do mythfilldatabase.  It didn't look like your guide was being updated.


I've had this problem in the past and in MY case it was never about permissions or groups.  I've had situtations where everything seemed to be working except it would just quit when I selected live-tv.  Going back and redoing mythtv-setup with the backend not running and possibly a reboot corrected the situtation.


Live Free or Die !

Offline

#7 2009-12-28 14:56:19

arch0r
Member
From: From the Chron-o-John
Registered: 2008-05-13
Posts: 597

Re: [SOLVED] MythTV Live TV not starting

thx for your reply. yes the cards working fine. I used to watch tv with kaffeine.

HAR! i found the error tongue
in mythtv-setup you have to put into a channel number for the first channel. this number was not assigned to a valid channel. tongue

Offline

Board footer

Powered by FluxBB