You are not logged in.

#1 2009-12-27 13:05:33

Paingiver
Member
Registered: 2008-03-01
Posts: 83

Superblock mount time is in the future(completely frustrating!)

I am dual booting Arch with Xp and somehow the time changed. So when i tried to boot ArchLinux it hangs at booting the filesystems and give this error:

Superblock mount time is in the future(/dev/sda2)(Last mount 20:35 25 DEC 2009, Current time 20:35 24 DEC 2009)

If change the time from bios to future. It boots and i can correct time within the archlinux with the help of date command. But if i restart it fails to boot again. And it becomes an endless circle(everytime i move more in the future time).

My partition table is as follows(on sda2 with LVM):

/var-reiserfs
/home-jfs
/-jfs

Is there a way to stop filesystems about last mount time?

Offline

#2 2009-12-27 13:33:57

SoleSoul
Member
From: Israel
Registered: 2009-06-29
Posts: 319

Re: Superblock mount time is in the future(completely frustrating!)

Two options:
1) Your arch clock is set to UTC instead of localtime in /etc/rc.conf
2) Set the hardware clock to the correct time and then delete the file /var/lib/hwclock/adjtime
This solution came up here on the forum a few times. I did it and it fixed my problem. Don't worry about the file, it will be recreated automatically.

Offline

#3 2009-12-27 14:01:54

Paingiver
Member
Registered: 2008-03-01
Posts: 83

Re: Superblock mount time is in the future(completely frustrating!)

Thanks for the answer but:

1-)My clock is set to localtime from the beginning
2-)I delete file but to no avail.

It is about the filesystem log. It saves the last mount time somewhere.(and you must make the hwclock future to mount the filesystem so mount time remains always in the future) And i could not find a way to remove it.

Some guys at debian forums found something like to be put in /etc/e2fsck.conf for ext filesystems. But i have reiser and jfs:

[problems]

# Superblock last mount time is in the future (PR_0_FUTURE_SB_LAST_MOUNT).
0x000031 = {
    preen_ok = true
    preen_nomessage = true
}

# Superblock last write time is in the future (PR_0_FUTURE_SB_LAST_WRITE).
0x000032 = {
    preen_ok = true
    preen_nomessage = true
}

The topic is here: http://forums.debian.net/viewtopic.php?f=10&t=45797

Last edited by Paingiver (2009-12-27 14:02:58)

Offline

#4 2009-12-27 14:57:33

SoleSoul
Member
From: Israel
Registered: 2009-06-29
Posts: 319

Re: Superblock mount time is in the future(completely frustrating!)

Try this:
Set the clock to the correct time.
Boot arch. When halted because of the error, type the root password in order to get a shell.
Use the appropriate tool to check all your filesystems. For ext it's e2fsck. I don't know the reiserfs equivalent.
This should fix the problem temporarily. Hopefully you will be able to reboot at least once successfully into arch.
Reboot. Make sure the time is right, delete the file adjtime and reboot again to see if the problem is gone.

I think it can work because now the fs's were really mounted in the present rather than in the future.

Tell me what happens.

edit: added something I forgot.

Last edited by SoleSoul (2009-12-27 15:01:35)

Offline

#5 2009-12-27 15:01:05

Cyrusm
Member
From: Bozeman, MT
Registered: 2007-11-15
Posts: 1,053

Re: Superblock mount time is in the future(completely frustrating!)

run fsck on your filesystems when you hit this error, it will fix you right up.


Hofstadter's Law:
           It always takes longer than you expect, even when you take into account Hofstadter's Law.

Offline

#6 2009-12-27 15:27:32

Paingiver
Member
Registered: 2008-03-01
Posts: 83

Re: Superblock mount time is in the future(completely frustrating!)

Oh i have already done fs checks on /var, /home and / But nothing has changed! But then i've remembered. I have a seperate /boot partition too which is ext2. The error message was about /dev/sda2. Silly me i thought the whole sda2 was lvm. I didnt even looked the size of partition.(i have forgotten fdisk doesnt show lvm part.) But it was just 100mb boot part. I scanned it with e2fsck then it worked!

Thank you guys and sorry for bothering you...

Last edited by Paingiver (2009-12-27 15:30:25)

Offline

#7 2010-02-23 07:40:03

unhammer
Member
Registered: 2009-10-01
Posts: 97
Website

Re: Superblock mount time is in the future(completely frustrating!)

Hey, did you ever try the trick from the debian forums? I'm considering doing something like that because 800GB disk checks are getting really annoying.

Also, does anyone know why e2fsck is so picky about future mount dates?

(Note: I have tried both localtime and UTC, and I have the correct time zone, but whenever openntpd doesn't get a chance to set my time correctly because of a bad net connection, and I forget to set it manually before shutdown, I get this future mount date problem. Very annoying since less advanced users are using the machine too.)

Offline

#8 2010-09-20 14:11:51

Alexbit
Member
From: Italy
Registered: 2010-06-02
Posts: 60

Re: Superblock mount time is in the future(completely frustrating!)

SoleSoul wrote:

Two options:
1) Your arch clock is set to UTC instead of localtime in /etc/rc.conf
2) Set the hardware clock to the correct time and then delete the file /var/lib/hwclock/adjtime
This solution came up here on the forum a few times. I did it and it fixed my problem. Don't worry about the file, it will be recreated automatically.

Confirm!

In my case:
1) clock in /etc/rc.conf was already on UTC
2) sudo hwclock --adjust
3) sudo rm /var/lib/hwclock/adjtime
4) reboot and...
5) Just Work!

;-)

Great!Thank you SoleSoul!
Ale

Last edited by Alexbit (2010-09-20 14:12:47)

Offline

#9 2010-09-20 14:17:15

hidefromkgb
Member
Registered: 2009-08-03
Posts: 146

Re: Superblock mount time is in the future(completely frustrating!)

I've also encountered the same issue a few times.

How to make the loader just ignore this "error"?

Offline

#10 2010-09-20 15:13:23

Alexbit
Member
From: Italy
Registered: 2010-06-02
Posts: 60

Re: Superblock mount time is in the future(completely frustrating!)

hidefromkgb wrote:

I've also encountered the same issue a few times.

How to make the loader just ignore this "error"?

Why "ignore" when you can solve?
Have you try the above solution?

Offline

#11 2010-09-20 17:28:37

hidefromkgb
Member
Registered: 2009-08-03
Posts: 146

Re: Superblock mount time is in the future(completely frustrating!)

Alexbit wrote:

Why "ignore" when you can solve?
Have you try the above solution?

Naturally smile
However, if such thing happens constantly, "solving" it begins to annoy...

Offline

#12 2010-09-20 18:45:59

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Superblock mount time is in the future(completely frustrating!)

If something like that happens constantly, that means something is wrong. You don't work around errors, unless there is no solution. For stuff like this, there are multiple solutions, and they're well documented.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

Board footer

Powered by FluxBB