You are not logged in.

#1 2010-01-10 19:19:50

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

[Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Ok I know this has been up like 500 times and its getting ridiculous but I can't seem to make mine work despite all the different things in all of the threads.  Here's my story:

I have cups 1.4.2-2 currently.  I had rolledback to 1.3.11-1 (with some effort I might add) and FINALLY got it to rollback and installed.  Origionally I had tried it before the Syu where gtk2 and things got updated that needed the new heimdel so I still had the old heimdal but of course the libhx error, anyways after a Syu new cups doesn't work (yes usblp is blacklisted) so I rolled back cups again and symlinked with the new heimdal and then when I try to restart cups I get

/usr/sbin/cupsd: /usr/lib/libkrb5.so.25: version `HEIMDAL_KRB5_1.0' not found (required by /usr/sbin/cupsd)

Which is a new one...

So now it at least is detecting the symlink.  I had a symlink up before but it still said it didn't exist (No I didn't spell it wrong I did it like 3 times it just didn't like it for some reason.) So I had rolled back heimdal even but then a bunch of things needed the newer version so I was like crap, but then when I was makepkg -s the 1.3.11-1 cups it said it wanted heimdal 1.3.1 so I was like oh ok then those things will work again, but then when I started cups then it didn't have the right libhx version which is where I symlinked again....but yea its a big mess and no matter what I try....No printer.

Bus 004 Device 002: ID 04e8:3409 Samsung Electronics Co., Ltd SCX-4216F Scanner
crw-rw-r-- 1 root lp 189, 385 Jan 10 10:48 /dev/bus/usb/004/002

Just for reference...

extra/cups 1.3.11-1
     The CUPS Printing System
extra/libcups 1.4.2-2
     The CUPS Printing System - client libraries and headers
core/heimdal 1.3.1-2
     Implementation of Kerberos V5 libraries

[siegemachine@localhost ~]$ lsmod | grep usblp
usblp                   9595  0

Basically how do I fix that heimdal error so that I can make cups 1.3.11-1 work?

Last edited by SiegeMachine (2010-01-11 07:02:07)

Offline

#2 2010-01-10 20:20:19

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

You should never syslink .so files! Anyways what you need to do is go back into svn grab the old cups pkg and recompile against the new version of hemidal. That is what I am doing right now. Cups 1.4.2 causes my printer to print out 50 pages of garbage after 2-3 good pages. I'm just not sure what I'll do when this solution stops working, maybe buy a print server from monoprice or something.

Last edited by pyther (2010-01-10 20:25:03)


Website - Blog - arch-home
Arch User since March 2005

Offline

#3 2010-01-11 05:18:38

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Well you have to symlink to get old cups version to work because you can't rollback heimdal because of gtk2 dependancy.  Secondly I have built it from 3 different packagebuilds and 2 of them don't even build. Currently I just use vbox to print, but its a bit of a pain.

Offline

#4 2010-01-11 05:21:53

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Ok so 1.3.11-1 using edited PKGBUILD from the abs tree gives me a libcups install-header error.  Building cups from the pkgbuild for 1.3.11-1 from the SVN gives me an error

==> ERROR: gnutls-pkgconfig.dpatch was not found in the build directory and is not a URL.

and then downloading the package via wget from http://www.schlunix.org/archlinux/extra/os/i686/ already built and just yaourt -U it installs but I get the above error with heimdal_KRB.  So how am I supposed to compile it?

P.S.

[siegemachine@localhost cups]$ yaourt -Qs gnutls
extra/gnutls 2.8.5-1
     A library which provides a secure layer over a reliable transport layer

before you ask tongue

Last edited by SiegeMachine (2010-01-11 05:23:05)

Offline

#5 2010-01-11 05:52:30

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

HOLY SHAZBOT For some retardedly miraculous reason it can suddenly detect my printer! And to think I actually TRIED Syu with current cups AND heimdal AND blacklisted usblp AND I rebooted AND I set my printer to group lp AND it didn't work before, yet some reason it does now... now I just have to make it stay lp group each time I reboot I guess.

Offline

#6 2010-01-11 06:05:57

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Ok so now I'm trying to set up a udev rule so that my printer stays as lp after reboot and I figured out something that might help others in the future....I've realized now that before when I tried after the Syu, usblp blacklisted, and with printer in lp group that CUPS still wouldn't detect it because of hal-cups-utils.  I'm not sure WHY that is however as I saw in another thread a minute ago when trying to set up the udev rule that they should just get that (which I had removed earlier today) So some reason that is making it not detect printers even when it SHOULD, so I'll remove that again and hopefully this all works

Scratch that....It seems that if I click the add printer button first and when cups prompts for root password THATS when the printer seems to be detected, trying that now WITH hal-cups-utils

Last edited by SiegeMachine (2010-01-11 06:09:57)

Offline

#7 2010-01-11 06:34:19

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

You need to rebuild the old cups package against the newer lib.
I'll link to you mine in a while download when you see my post.
Here's a package rebuilt by me two or three weeks ago, should work with current bleeding edge arch.

Last edited by Dheart (2010-01-11 06:41:15)


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#8 2010-01-11 06:47:25

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Read up a bit, building it against newer libs doesn't work.  hal-cups-utils seems to do nothing so I'm not gunna bother installing it.

Offline

#9 2010-01-11 07:00:18

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Ok so I see now that scanner/printers aren't set by the 1.4x cups udev rule so adding my own my printer now works without hal-cups-utils, heimdal is newest along with cups and after like 3 days of fighting and total bs and compiling it FINALLY fucking works...

Offline

#10 2010-01-11 18:50:28

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

You didn't edit the PKGBUILD properly that's why your build failed...


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#11 2010-01-11 19:14:48

catweazle
Member
From: Germany
Registered: 2006-12-14
Posts: 24

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Dheart,

thanks for providing a link to your recompiled cups package. Works nicely for me. That saved my day.

Offline

#12 2010-01-11 22:22:09

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Lol you need to read again, I compiled from the pkgbuild FROM the archlinux SVN, how could I edit that wrong?

Offline

#13 2010-01-12 07:34:03

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Because it has some patches for the newer versions which needed to be removed. If you wan the right PKGBUILD, download the 1.3.11 revisn. Click on document history and download the version you desire, then you'll have no problem compiling...
The fact that another user happily enjoys rebuilt cups 1.3.11 by me would mean that you're doing something wrong...

Last edited by Dheart (2010-01-12 07:36:36)


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#14 2010-01-13 00:50:11

SiegeMachine
Member
Registered: 2009-03-26
Posts: 157

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Thats exactly what I just said that I did.....I built from the pkgbuild from the svn, and it wasn't what I was doing that was wrong. If you want to keep flaming in a solved thread by all means but I'm not going to read anymore because you're getting boring repeating yourself.

Last edited by SiegeMachine (2010-01-13 00:50:36)

Offline

#15 2010-01-13 08:25:02

Dheart
Member
From: Sofia, Bulgaria
Registered: 2006-10-26
Posts: 951

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Fine, I'm wrong, you're right.
If anyone is interested here's a (miraculously) working PKGBUILD:

# $Id: PKGBUILD 44879 2009-07-04 19:14:42Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgname=cups
pkgver=1.3.11
pkgrel=1
pkgdesc="The CUPS Printing System"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.cups.org/"
depends=('acl' 'openslp' 'pam' "libcups>=${pkgver}" 'xdg-utils' 'avahi' 'heimdal>=1.2.1-5' 'gnutls>=2.8.1' 'poppler>=0.10.7-2')
makedepends=('xinetd' 'gzip' 'autoconf')
install=cups.install
backup=(etc/cups/cupsd.conf
        etc/cups/mime.convs
        etc/cups/mime.types
        etc/cups/snmp.conf
        etc/dbus-1/system.d/cups.conf
        etc/logrotate.d/cups
        etc/pam.d/cups
        etc/xinetd.d/cups-lpd)
source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
        cups cups.logrotate cups.pam)
options=('!emptydirs') #'!makeflags') seems smp safe now; find pkg/ | sort | wc -l gives 1815
md5sums=('23b334ac1a23ec16930e5cd6f0923bb2'
         '5c85b7d8d2ddd02c2c64955cebbf55ea'
         'f861b18f4446c43918c8643dcbbd7f6d'
         '96f82c38f3f540b53f3e5144900acf17')
build() {
  cd ${srcdir}/${pkgname}-${pkgver}
  # http://patch-tracking.debian.net/patch/series/view/cups/1.3.10-5/gnutls-pkgconfig.dpatch
#  patch -Np1 -i ${srcdir}/gnutls-pkgconfig.dpatch || return 1
  aclocal
  autoconf
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
     --with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
     --with-cups-user=daemon --with-cups-group=lp --without-php \
     --enable-pam=yes --disable-ldap --libdir=/usr/lib --enable-raw-printing \
     --enable-dbus --with-dbusdir=/etc/dbus-1 --enable-ssl=yes --enable-gnutls \
     --enable-pdftops --with-pdftops=pdftops --with-optim="$CFLAGS"
  make || return 1
  #Wreck out cups library installation
  sed -i -e 's/^DIRS\s=\scups/DIRS = /' Makefile
  make BUILDROOT=${pkgdir} install
  #Wreck out some stuff included in libcups
  
  if [ "$CARCH" = "x86_64" ]; then 
    if [ -f $pkgdir/usr/lib64 ]; then
         rm -rf ${pkgdir}/usr/lib64/
    fi
  fi
  rm -f ${startdir}/pkg/usr/lib/libcupsimage.so* 
  rm -f ${startdir}/pkg/usr/bin/cups-config
  rm -rf ${startdir}/pkg/usr/include
  # kill the sysv stuff
  rm -rf ${startdir}/pkg/etc/rc*.d
  rm -rf ${startdir}/pkg/etc/init.d
  install -D -m755 ../cups ${startdir}/pkg/etc/rc.d/cups
  install -D -m644 ../cups.logrotate ${startdir}/pkg/etc/logrotate.d/cups
  install -D -m644 ../cups.pam ${startdir}/pkg/etc/pam.d/cups
  
  # fix perms on /var/spool and /etc
  chmod 755 ${startdir}/pkg/var/spool
  chmod 755 ${startdir}/pkg/etc
  # fix .desktop file
  sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' $startdir/pkg/usr/share/applications/cups.desktop
  
  # compress some driver files, adopted from Fedora
  find ${pkgdir}/usr/share/cups/model -name "*.ppd" | xargs gzip -n9f
}

Just grab the rest of the files from the svn entries....


My victim you are meant to be
No, you cannot hide nor flee
You know what I'm looking for
Pleasure your torture, I will endure...

Offline

#16 2010-02-12 13:54:08

Rulatir
Banned
Registered: 2007-02-05
Posts: 94

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Dheart wrote:

You need to rebuild the old cups package against the newer lib.
I'll link to you mine in a while download when you see my post.
Here's a package rebuilt by me two or three weeks ago, should work with current bleeding edge arch.

The link doesn't work. Could you please upload it somewhere else?

Offline

#17 2010-02-12 13:58:29

Rulatir
Banned
Registered: 2007-02-05
Posts: 94

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Dheart wrote:

Just grab the rest of the files from the svn entries....

HOWWWWWWWWWWW???????

Please understand: I just need to have printing working. From the sentence above I cannot deduce what SVN server/branch/whatever contains "the" svn entries you have in mind. I would have to spend several days researching this before I could "just grab  the rest of the files from the svn entries".

Could you please provide the exact svn command lines? Благодаря!

Last edited by Rulatir (2010-02-12 14:00:51)

Offline

#18 2010-02-12 21:29:55

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Rulatir wrote:
Dheart wrote:

Just grab the rest of the files from the svn entries....

HOWWWWWWWWWWW???????

Please understand: I just need to have printing working. From the sentence above I cannot deduce what SVN server/branch/whatever contains "the" svn entries you have in mind. I would have to spend several days researching this before I could "just grab  the rest of the files from the svn entries".

Could you please provide the exact svn command lines? Благодаря!

http://repos.archlinux.org/wsvn/package … ?rev=44879

The Changes link will show you all the changes to that particular pkg.


Website - Blog - arch-home
Arch User since March 2005

Offline

#19 2010-02-25 19:06:40

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: [Solved] *sigh* CUPS 1.4.2 and usb printer....An incredible tale

Also, you can try my cups-usblp package. It uses cups 1.4, but disable the new libusb system and instead uses the usblp kernel module.
http://aur.archlinux.org/packages.php?ID=35029


Website - Blog - arch-home
Arch User since March 2005

Offline

Board footer

Powered by FluxBB