You are not logged in.

#1 2010-01-10 22:59:42

Registered: 2009-12-21
Posts: 8 disables mouse and keyboard [SOLVED]


This is my second major problem with the Arch testing repository, but it's not so easy to overcome as the first one that arose a few weeks ago was.
I am using xorg-server and the latest kernel26, and the latest radeon driver package, latest everything.
I have KMS enabled by late start, early start didn't work for me.

So, after my update, the next morning, I turned on my computer, and lo-and-behold, it would appear that my mouse and keyboard will not log me in to Enlightenment. This is very strange, as the last update I did, kernel26, did nothing strange after a reboot. I updated something else, between then and now, but I forgot what it was.

So, even with a freshly generated xorg.conf, my mouse and keyboard do not work. I decided to take a look at my xorg log. I found something interesting -- some lines marked with '(WW)' (uh-oh!) that said the following:

(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse; will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0

And that appears to be the problem. I tried loading evdev, to no avail.

So, I interpret this to mean that I need to find a way to turn AllowEmptyInput off, or turn off whatever's causing AllowEmptyInput to turn on.

How am I supposed to fix this? :S Am I just stupid, did I do something wrong, or is there something that I'm not aware of, or a combination of all 3...?

EDIT: The obvious addition of a "Option     "AllowEmptyInput"     "off" seemed to fix things here. But I'm still sad that they removed DRI2 from the kernel! There is, in fact, no KMS for me sad

Last edited by chickenlinux (2010-01-12 21:40:26)


Board footer

Powered by FluxBB