You are not logged in.

#1 2004-12-26 23:11:51

starthis
Member
Registered: 2004-12-25
Posts: 45

big desktop using gnome

I have successfully installed the ATI driver with big desktop configuration. (on xorg 6.7)
I'm using gnome as WM.

With my previous gfxcard using xinerama, if I maximized a window, it would maximize on the monitor it is on. The big desktop of ATI (which doesn't allow the xinerama option) streches the window over all monitors. (complete desktop) Same goes for the gnome panels that have the expand property. Also gdm shows the loginbox half on screen 1, half on second screen. Very handy  :?

Is there any way to alter this behaviour so that it acts like the xinerama mode?
I haven't found anything on the internet about this, besides this post with simular question, though it doesn't have a valid answer:

http://lunar-linux.org/pipermail/xfce4- … 12099.html

I'm using a pretty standard generated config, with

Option "MonitorLayout"              "AUTO, AUTO"

I can't seem to find out if xorg config or gnome config is responsible.
I'm sure the solution must be trivial as nobody else seem to have this annoying behaviour wink

Offline

#2 2004-12-27 09:02:22

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: big desktop using gnome

I have the same problem when I use the merged mode with my Matrox G550. I don't think you can solve this one: the X11 system is fooled in having a large desktop spread over 2 displays, without noticing there are two screens. That's where xinerama jumps in: it's an extension so apps know on which screen they are and what size that screen has. Without Xinerama, there is no option to control placement or stretching. Maybe the drivers themselves solve something internal, but I wouldn't count on it.

Offline

#3 2004-12-29 14:39:26

Winkie
Member
Registered: 2004-09-30
Posts: 59

Re: big desktop using gnome

No solution until the next round of drivers at least.

Screw you ATI.

Offline

Board footer

Powered by FluxBB