You are not logged in.

#1 2004-12-29 16:34:41

qwerty
Member
Registered: 2004-12-17
Posts: 183

trouble upgrading to gtk2-2.6.0

Hallo, i had just upgraded libglade and gtk2, during the installation i've had this error:

Targets: gtk2-2.6.0-1

Total Package Size:   6.7 MB

Proceed with upgrade? [Y/n]

checking package integrity... done.
loading package data... done.
checking for file conflicts... done.
upgrading gtk2... done.
usr/bin/gtk-query-immodules-2.0: error while loading shared libraries: libXfixes.so.3: cannot open shared object file: No such file or directory

After the upgrade a lot of apps didn't works anymore (nicotine, downloaderx ecc), everytime giving the same error:

ImportError: libXfixes.so.3: cannot open shared object file: No such file or directory


I've solved downgrading to the old version of gtk2 and libglade, anyway, i've looked for libXfixes.so.3 around and i've found something intresting here:

http://www.webservertalk.com/message661337.html

It seems that libXfixes.so.3 only exist in xorg 6.8.1 but  i cannot upgrade my xorg because of the ati driver, and, probably, xfree86 users will have the same problem.

Does someone know how to solve it??

Offline

#2 2004-12-29 17:57:42

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: trouble upgrading to gtk2-2.6.0

Please see my post about pacman -Syu and the loss of Kde and X.

The fix was to force the install of Xfree86 upgrade.

I suggest the same method will solve your problem....pacman -Sf gtk


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#3 2004-12-29 22:51:55

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

No man, you have not understood me, probably because of my english wink... Anyway, i was able to upgrade to the new version of gtk2 but after the upgrade almost all the gtk2 apps i use were not working anymore giving me the same error message:

ImportError: libXfixes.so.3: cannot open shared object file: No such file or directory

Offline

#4 2004-12-29 23:04:52

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: trouble upgrading to gtk2-2.6.0

querty;

My message after upgrade was similar: libx11.so.6:  cannot open shared object file; no such file or directory

Perhaps the same fix  ...pacman -Sf (gtk) will do the job.

I had the upgrade also but it failed in a different manner than yours but from the same deficiency which might be pacman (latest version).

Best of luck to you and a happy new year! (preview in Asia appalling!)


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#5 2004-12-30 19:20:36

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

i've tried but it didn't work....
I have to wait for the new ati driver hmm

c ya and happy new year

Offline

#6 2004-12-30 19:49:46

morphus
Member
From: Braunschweig
Registered: 2003-08-06
Posts: 145

Re: trouble upgrading to gtk2-2.6.0

it's the same damn thing for me with these ati-drivers. I have a lcd-device connected on the digital output of the graphic card and it won't work on xorg 6.8.1, but works perfectly on 6.7.0.

qwerty: Have you filled a bug report about this stuff?

Offline

#7 2004-12-30 20:53:25

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

Ops... i haven't done it, and i don't know how to do it!  :oops:  :oops:

morphus: have u had trouble with ati-driver upgrading to kernel 2.6.10?? i've just found a patch that  make everything works and i've added it to the PKGBUILD from Link Dupont, you can find that patch and more infos here: http://www.rage3d.com/board/showthread.php?t=33797225

...ok i know... i'm just trying to speak about something else ... roll
Is there a form to fill or i only have to send an email to the package mantainer??? 
Let me know (and sorry for my english)

greetings and happy new year!!

Offline

#8 2004-12-30 21:25:15

morphus
Member
From: Braunschweig
Registered: 2003-08-06
Posts: 145

Re: trouble upgrading to gtk2-2.6.0

bug-report: There should be a link on the main arch-page about bugs, register and fill out a bug-report, describing the xorg and gtk2-problems with ati. That's it

ati: Since I am not using the hardware-acceleration on linux I don't need the binary, closed-source ati-drivers. I have had no problems in upgrading to 2.6.10...It's just that damned dvi-out which won't work in the newer xorg-package...

Oh yeah, happy new year too

Offline

#9 2005-01-01 15:25:53

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: trouble upgrading to gtk2-2.6.0

Use either the latest xfree86 or the latest xorg package. Older packages not current in arch are unsupported and won't work with the new GTK.

I patched up xfree86 4.4.0 to include XFixes, XDamage, XEvie and XComposite libs to avoid the missing library problems. if you want to use Xorg 6.7.0, you are on your own. You can use my patches from abs to patch xorg 6.7.0 up too, but I don't see much advantage in that over the xfree86 package: XFree86 4.4 and xorg 6.7.0 are almost exactly the same.

Offline

#10 2005-01-01 18:14:10

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

ok, i will try, i need to use the old version of xorg because of the ati drivers but they said that new ati drivers should come out in a few days, i'm just taking time waiting for them wink

Seeeee yaaaaaaaaaaa

Offline

#11 2005-01-02 03:19:45

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: trouble upgrading to gtk2-2.6.0

You may be waiting forever if your waiting on ATI. This driver release was scheduled for December and then pushed back to Jan. I'm not hopeful that the new drivers will be out anytime before Jan 12.

Offline

#12 2005-01-02 18:27:31

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

I know, but i don't have another chance...  sad

Offline

#13 2005-01-02 21:43:26

GuyonAsm
Member
Registered: 2004-05-25
Posts: 49

Re: trouble upgrading to gtk2-2.6.0

I have the exact same setup as qwerty. For now Im using the default ATI drivers for xorg and I'll play games on my Windows partition until ATI gets their stuff together smile.

Offline

#14 2005-01-03 07:26:49

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: trouble upgrading to gtk2-2.6.0

Why being stubborn and refusing to install xfree 4.4.0 and have stuff working? Replacing xorg by XFree86 is a breeze and the other way around is also not a problem when ATi releases their stable Xorg 6.8.x (we'll be at 6.9.x then, which is completely different to the current releases) in 2006 or something like that tongue

Offline

#15 2005-01-03 08:14:15

GuyonAsm
Member
Registered: 2004-05-25
Posts: 49

Re: trouble upgrading to gtk2-2.6.0

The ATI Install guide in the wiki says that the binary drivers from the ATI website don't work with xfree, only xorg? Is this information wrong? I've trie d it with xfree and it didn't work for me. I might have done something wrong.

Offline

#16 2005-01-03 09:54:30

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: trouble upgrading to gtk2-2.6.0

Xorg 6.7.x == XFree86 4.4.0 prerelease

If ATi drivers don't work with xfree86, then they are really stupid, because that means they don't support 95% of all linux distro's currently installed on many systems.

Offline

#17 2005-01-03 17:45:03

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: trouble upgrading to gtk2-2.6.0

I agree, they are really stupid, because their drivers don't support both, xfree 4.4.0 and xorg 6.8.1... A new version of ati-drivers working on xorg 6.8.1 should come out in a while (it was annunced to be released in december but nothing has happened till now).

Offline

#18 2005-01-03 20:36:59

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: trouble upgrading to gtk2-2.6.0

ATIs linux website states Xfree as the supported system and not Xorg. They do however only list support for Xfree 4.3. It wouldn't take very long to try it out though.

Offline

Board footer

Powered by FluxBB