You are not logged in.

#1 2010-01-24 14:47:21

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

[solved] kernel panic in kernel26-ck while starting udev

OK I've built newest kernel26-ck (2.6.32.5-1) and now when I try to boot I get this error:

starting udevd
/init: 24: /sbin/udevd not found
/init: 45: replace: not found
/init: 45: replace: not found
export: 45: : bad variable name

I saw this thread: http://bbs.archlinux.org/viewtopic.php?pid=689656 but it doesn't help me at all as I can't boot it hangs at start of booting process.
Before update I did use quick-init script instaed of normal script, so first thing I did was to change back to normal init scripts. it didn't help...
So I did what could turn out to be a stupid thing and deleted everything quick-init related so it wouldn't clash with normal init scripts...

But I think it's not the init scripts that are giving me the trouble...
It has to be something with root as it can't find /sbin/udevd and it is there.

PS.: I'm posting this from LiveCD (mint, it's only GUI LiveCD with ext4 support).
And it's here I did all the repairing / breaking after initial panic...

Last edited by Primoz (2010-01-25 09:43:41)


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#2 2010-01-24 16:28:23

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

I'll try this: http://wiki.archlinux.org/index.php/Kernel_panic
I hope it will work. If not please help.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#3 2010-01-24 17:51:28

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

OK that didn't help really... I've tried it but nothing works...
I removed kernel26-ck and installed kernel26 and kernel still panics. I've downgraded udev from testin to core still nothing works... I've removed udev from mkinitcpio.conf and I still get the cryptic error /init: 45: replace...
I've even reinstalled quickinit nothing worked... so then i've removed it again, but this time correctly, still nothing...
I'm getting out of ideas. And you gusy aren't helpfull either.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#4 2010-01-24 18:00:07

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

Well re-installing initscripts didn't do the trick either...
I out of ideas. I'll probably do one last kernel image and if that doesn't work then onyl thing left is to reinstall and hope for the best.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#5 2010-01-24 18:24:05

MP2E
Member
Registered: 2009-09-05
Posts: 115

Re: [solved] kernel panic in kernel26-ck while starting udev

That's extremely weird... The kernel makes the screen flash for a second at bootup which is kinda odd(it doesn't happen with 2.6.32.4-ck for instance) but other than that it "just works" for me. Sounds like it corrupted something if you can't even get the regular kernel to work now. I'm not too experienced in this sort of thing unfortunately, so I can't offer a solution.. However if there is a fix for my package please post a link to it or tell me what needs to be done and I"ll do it.


17:23 < ConSiGno> yeah baby I release the source code with your mom every night
17:24 < ConSiGno> you could call them nightly builds if you know what I mean

Offline

#6 2010-01-24 18:45:21

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

MP2E wrote:

That's extremely weird... The kernel makes the screen flash for a second at bootup which is kinda odd(it doesn't happen with 2.6.32.4-ck for instance) but other than that it "just works" for me. Sounds like it corrupted something if you can't even get the regular kernel to work now. I'm not too experienced in this sort of thing unfortunately, so I can't offer a solution.. However if there is a fix for my package please post a link to it or tell me what needs to be done and I"ll do it.

Thanks for comment.
I'll inform you if I find something.
Did I mention I use x86_64?
I still think that it's something to do with filesystems as it doesn't find /sbin/udevd...
I think my next move will be to do pacman -Scc and then reinstall kernel26-ck and hope for the best.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#7 2010-01-24 19:33:18

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: [solved] kernel panic in kernel26-ck while starting udev

Your problem is with your boot image. What's in your /etc/mkinitcpio.conf?

Offline

#8 2010-01-24 20:32:02

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

falconindy wrote:

Your problem is with your boot image. What's in your /etc/mkinitcpio.conf?

It's just "standard" mkinitcpio: nothing under modules and files just hooks:

HOOKS="base udev autodetect pata sata filesystems"

As I mentioned I've removed udev from mkinitcpio and it still had the second error:

/init: 45: replace: not found
/init: 45: replace: not found
export: 45: : bad variable name

Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#9 2010-01-24 22:31:31

MP2E
Member
Registered: 2009-09-05
Posts: 115

Re: [solved] kernel panic in kernel26-ck while starting udev

I also use x86_64, and it works by the way.. You've got me a bit worried though, I don't want my PKGBUILD borking up people's Arch systems :S Anyone know what's going on here?


17:23 < ConSiGno> yeah baby I release the source code with your mom every night
17:24 < ConSiGno> you could call them nightly builds if you know what I mean

Offline

#10 2010-01-24 22:40:29

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

MP2E wrote:

I also use x86_64, and it works by the way.. You've got me a bit worried though, I don't want my PKGBUILD borking up people's Arch systems :S Anyone know what's going on here?

It could be just bad coincidence and my system that borked it.
I had testing enabled with newest packages for some time but I disabled after lpibjpeg and libpng upgrade...
I had quickinit which I think states that it has to be rebuilt every time you install a new kernel, which I didn't do (I didn't expect that it can really bork my system that much).
And Kernel26-ck wasn't only thing that was upgraded before my system got borked, there was also few KDEmod packages. But I checked Chakra forums nobody has any troble and well I can't imagine how could bunch of KDE upgrades borked kernel booting.
I'm still going with the idea that kernel somehow can't access my root. I have to check UUID in fstab, and in grub.lst with actual UUID of root.
But I doubt that could be the problem...
It's still the most plausible option.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#11 2010-01-25 09:49:10

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [solved] kernel panic in kernel26-ck while starting udev

I've solved this problem by re-installing base.
I have a lot to re-install and repair, as my ntfs-3g isn't working anymore etc... but At least I can boot.
I'll retry to install kernel26-ck later on, I hope It will work.
I'll probably never know what exactly went wrong and borked my system.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#12 2010-01-25 14:04:15

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: [solved] kernel panic in kernel26-ck while starting udev

x86_64 stuff goes into its own subforum - moved.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

Board footer

Powered by FluxBB