You are not logged in.

#1 2010-01-25 17:13:48

pere
Member
Registered: 2008-09-11
Posts: 23

veelte on arch64

Is someone currently using veetle on arch64?

Since nspluginweapper-i386-1.2.2-1.x86_64.rpm link does not work, the firefox 32bits veetle plugin can't be installed.

I wonder if someone has fixed this problem. Maybe using vlc?

Thanks

Offline

#2 2010-05-02 16:51:41

Howx
Member
Registered: 2010-05-02
Posts: 1

Re: veelte on arch64

This is a very old post, but think that I have the answer if some else need it.

Try to install the plugin with yaourt

#yaourt -S veetle

Offline

#3 2010-05-04 16:01:06

upuaut
Member
Registered: 2006-05-30
Posts: 19

Re: veelte on arch64

That doesn't work for me and Firefox :-(
http://www.veetle.com/ allways says:

Hi, you need the current version of Veetle TV to watch this channel.

Try Chrome but the same using veetle 0.9.17-5.

Any ideas?

Thanks.


Have Fun,

Upuaut

Offline

#4 2010-05-09 12:37:04

Demind
Member
Registered: 2007-07-10
Posts: 111

Re: veelte on arch64

Same problem here

Offline

#5 2010-05-17 00:24:50

zippy
Member
Registered: 2009-02-01
Posts: 54

Re: veelte on arch64

Offline

#6 2010-05-29 02:01:31

tuxfusion
Member
From: Deutschland
Registered: 2007-12-31
Posts: 96

Re: veelte on arch64

zippy, I tried it with no luck like this :
- install veetle by AUR
- nspluginwrapper -i .mozilla/plugins/libveetle-core-plugin.so ( the other .so throw errors )
- when visiting a veetle site firefox prints into console ELF errors , but nothing else :

LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-broadcast-plugin.so [/home/ken/.mozilla/plugins/libveetle-broadcast-plugin.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-core-plugin.so [/home/ken/.mozilla/plugins/libveetle-core-plugin.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-player-plugin.so [/home/ken/.mozilla/plugins/libveetle-player-plugin.so: wrong ELF class: ELFCLASS32]

What's wrong ?

Offline

#7 2010-05-29 02:30:51

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: veelte on arch64

tuxfusion wrote:

zippy, I tried it with no luck like this :
- install veetle by AUR
- nspluginwrapper -i .mozilla/plugins/libveetle-core-plugin.so ( the other .so throw errors )
- when visiting a veetle site firefox prints into console ELF errors , but nothing else :

LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-broadcast-plugin.so [/home/ken/.mozilla/plugins/libveetle-broadcast-plugin.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-core-plugin.so [/home/ken/.mozilla/plugins/libveetle-core-plugin.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/ken/.mozilla/plugins/libveetle-player-plugin.so [/home/ken/.mozilla/plugins/libveetle-player-plugin.so: wrong ELF class: ELFCLASS32]

What's wrong ?

Search the forums for "wrong ELF class". This should give you an idea of what's wrong.

Offline

#8 2010-05-29 03:27:28

tuxfusion
Member
From: Deutschland
Registered: 2007-12-31
Posts: 96

Re: veelte on arch64

I did that, read the first three hits but got no not inlightetd , of course it's trying to run a 32 bit bin in a 64 bit world and errors out.
The guy posted a solution that doesn't not work for me, that's why I asked what's wrong "here" ...
I read on in the off. veetle forums they don't get it to run either , it looks like it worked "at some point" with ndiswrapper but not any more ?
Right now I'm using VirtualBox Windows XP to run it, works pretty good. At least better the any other solution online.

Offline

#9 2010-05-29 15:53:02

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: veelte on arch64

I was going to take a look at this to see why the 64 bit client wasn't working, then I discovered that the package is installing executable files in the user's home directory. This is very, very bad. I'd uninstall it immediately. In fact, I'd remove the executable bit before running pacman -R ( chmod -x <plug-ins> ).

Offline

#10 2011-03-12 20:20:01

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 317

Re: veelte on arch64

does anyone succeded using it under arch x86_64 so?

Offline

#11 2011-03-12 21:21:42

tuxfusion
Member
From: Deutschland
Registered: 2007-12-31
Posts: 96

Re: veelte on arch64

Someone please close this topic as [SOLVED]

off. 64 bit linux clients release thread :

http://forums.veetle.com/forums/viewtop … f=7&t=2312

Direct download links :

http://veetle.com/download.php/veetle-0 … install.sh

http://veetle.com/download.php/veetle-0.9.17plus.tgz

Offline

#12 2011-03-13 20:03:08

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 317

Re: veelte on arch64

tuxfusion wrote:

Someone please close this topic as [SOLVED]

off. 64 bit linux clients release thread :

http://forums.veetle.com/forums/viewtop … f=7&t=2312

Direct download links :

http://veetle.com/download.php/veetle-0 … install.sh

http://veetle.com/download.php/veetle-0.9.17plus.tgz

Thanks but veetle's forum is down neutral

Offline

#13 2011-03-17 09:40:19

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: veelte on arch64

Nice, it works.

But lib32-sdl is still needed...

Offline

#14 2011-03-17 15:28:52

jsadural
Member
Registered: 2010-08-27
Posts: 19

Re: veelte on arch64

I installed lib32-sdl and it still is broken.  My firefox basically freezes up when I go to a channel requiring the plugin. Please help...

Offline

#15 2011-03-17 18:44:45

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 317

Re: veelte on arch64

jsadural wrote:

I installed lib32-sdl and it still is broken.  My firefox basically freezes up when I go to a channel requiring the plugin. Please help...

The same for me also under chromium, i've installed "veetle-0.9.17plus-linux-install.sh" and lib32-sdl but it freezes while opening a channel neutral

Offline

#16 2011-03-19 16:37:34

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: veelte on arch64

Ok, probably missing packages?!

what says:

ldd ~/.veetle_vlc/vlcori

Offline

Board footer

Powered by FluxBB