You are not logged in.

#1 2010-02-01 16:56:05

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

[Solved] phonon conflicts with qt

pyther@tux: sudo pacman -Su                                                   ~
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kdelibs: requires phonon
pyther@tux: sudo pacman -S phonon                                             ~
resolving dependencies...
warning: provider package was selected (phonon-gstreamer provides phonon-backend)
looking for inter-conflicts...
:: phonon conflicts with qt. Remove qt? [Y/n] 
error: failed to prepare transaction (could not satisfy dependencies)
:: phonon-gstreamer: requires qt
:: phonon: requires qt
:: kdelibs: requires qt>=4.5.3-4
:: mythtv-fixes-vdpau: requires qt
:: phonon-xine: requires qt>=4.5.2-3
:: polkit-qt: requires qt
:: soprano: requires qt
:: strigi: requires qt
:: vlc: requires qt

I'm not sure what to do here, phonon says it depends on qt (pacman -Si phonon), but apparently I'm getting an error.

Last edited by pyther (2010-02-01 17:09:26)


Website - Blog - arch-home
Arch User since March 2005

Offline

#2 2010-02-01 17:04:08

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,362
Website

Re: [Solved] phonon conflicts with qt

As a [testing] user, you should really read the arch-dev-public list:

http://mailman.archlinux.org/pipermail/ … 15269.html

Offline

#3 2010-02-01 17:10:18

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: [Solved] phonon conflicts with qt

Woops, I saw the email, but I must have over looked that part. Sorry for the noise!


Website - Blog - arch-home
Arch User since March 2005

Offline

#4 2010-02-05 00:41:00

tigrmesh
IRC Op
From: Florida, US
Registered: 2007-12-11
Posts: 794

Re: [Solved] phonon conflicts with qt

pyther wrote:

Sorry for the noise!

Don't be sorry.  I wouldn't have found Pierre's email without your post.  I just upgraded to testing, and I had forgotten about reading the dev mailing list.

So, uh, actually ... thank you for posting!

Offline

#5 2010-02-09 15:35:06

rochus
Member
Registered: 2007-02-14
Posts: 50

Re: [Solved] phonon conflicts with qt

This should be announced somewhere, as the problem appears for non-testing users now as well.

regards

Offline

#6 2010-02-09 15:41:05

zatricky
Member
From: Cape Town
Registered: 2008-09-03
Posts: 55
Website

Re: [Solved] phonon conflicts with qt

same here, not using [testing]

I haven't noticed anything detrimental except that extra/kdelibs isn't updating automatically.

Whenever I encounter an issue like that I tend to leave it alone for a while.


pacman russian roulette: yes | pacman -Rcs $(pacman -Q | LANG=C sort -R | head -n $((RANDOM % 10)))
(yes, I know its broken)

Offline

#7 2010-02-20 18:24:39

vigohe
Member
From: Concepción, Chile
Registered: 2009-03-24
Posts: 9

Re: [Solved] phonon conflicts with qt

me too! I'm not using [testing]...

Offline

#8 2010-02-21 20:43:54

xduugu
Member
Registered: 2008-10-16
Posts: 280

Re: [Solved] phonon conflicts with qt

Offline

Board footer

Powered by FluxBB