You are not logged in.

#1 2010-02-03 10:31:27

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,281

[SOLVED] Cannot open links from thunderbird in firefox any more

After the last upgrades thunderbird 3.0.1-1 and/or firefox 3.6-2 clicking a link in a mail does not open it in firefox any more.

The setting appears still o.k., however, in ~/.tunderbird/...:

$ grep protocol-handler *.js
prefs.js:user_pref("network.protocol-handler.app.http", "firefox");

Does anybody else experience this? Or have the settings changed?

BTW: mailto in firefox still works properly.

Last edited by bernarcher (2010-02-03 14:20:55)


To know or not to know ...
... the questions remain forever.

Offline

#2 2010-02-03 13:22:22

sweetthdevil
Member
Registered: 2009-10-20
Posts: 374

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

Yes it did the same for me, it's because it's not set as our default browser for some reasons.

Go to "Preferences" in Firefox, in the "Advanced" tab, then General use the "Check Now" to set your newly update firefox as your defaults browser.

And it will work as before.

Offline

#3 2010-02-03 14:19:58

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,281

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

Thanks a lot! big_smile

I would never have thought of that one. Firefox had been default forever even though I often prefer others like elinks or uzbl.


To know or not to know ...
... the questions remain forever.

Offline

#4 2010-02-04 07:46:50

steff
Member
Registered: 2009-01-08
Posts: 54

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

Not solved for me, kde4 + google-chrome, but even trying with firefox no link will open.

Offline

#5 2010-02-05 19:35:41

kgas
Member
From: Qatar
Registered: 2008-11-08
Posts: 718

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

The same issue here but solved by setting the default browser option in firefox(Namoroka) earlier. Tho' the network handler protocol already points to firefox.
network.protocol-handler.app.http", "/usr/bin/firefox
network.protocol-handler.app.https", "/usr/bin/firefox
network.protocol-handler.app.ftp", "/usr/bin/firefox"

Offline

#6 2010-02-08 22:39:49

RobF
Member
Registered: 2006-10-10
Posts: 157

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

I did a big pacman -Syu today which upgraded Thunderbird (3.0-3 -> 3.0.1-1) and Firefox (3.5.6-1 -> 3.6-2).  Like others here, after the upgrade I wasn't able anymore to open browser links in Thunderbird emails in Firefox.

Firefox Namoroka was set to be the default browser (through Edit>Preferences>Advanced>General>System Defaults>Check Now).

My ~/.thunderbird/xxxxxxx.default/pref.js preferences file contains this:

user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");

Regardless of which string I chose for network.protocol-handler.app.xxxx (through Edit>Preferences>Advanced>General>Config Editor), i.e. firefox or /usr/bin/firefox or /usr/lib/firefox-3.6/firefox, it still didn't work.  Any of these settings in Thunderbird and Firefox used to work in the previous versions.

I then installed the Thunderbird add-on ThunderBrowse 3.2.8.1 and went through the quick-config that's part of the install, picking Firefox as the browser.  Still didn't work.  Then in ThunderBrowse Preferences I went to the External Browser tab which said "Configure External Browser Launching - Path to custom browser to launch (leave blank for the system default)" which had indeed been left blank (Firefox was the default browser, right?).  When I put /usr/bin/firefox in that field, I finally was able to get Thunderbird to launch Firefox when I clicked on a web link in TB.   What nonsense!

Offline

#7 2010-02-11 00:46:57

wadsofat
Member
Registered: 2010-02-11
Posts: 1

Re: [SOLVED] Cannot open links from thunderbird in firefox any more

See my comments #11 - #13 in http://code.google.com/p/chromium/issue … =23973#c11  - I had to fully log out and log in again for the changes to take effect.

Offline

Board footer

Powered by FluxBB