You are not logged in.

#1 2010-02-05 11:12:03

clesch
Member
From: Salzburg, Austria
Registered: 2009-07-21
Posts: 18

GT2xx HDMI audio finally working

I finally got the Nvidia HDMI audio fully working with the help of very kind and patient nvidia engineer who helped me solve the issue over the course of 2 days. smile

This is with Arch-2.6.32, alsa-driver-1.0.22.1, nvidia 190.53. My card is a GT210 but I'm 99% sure this works with any GT2xx card.

No patching of snd-hda-intel.ko/snd-hda-codec-nvidia.ko was required in the end so the HD_AUDIO-9.10 package that is floating around is unnecessary.

TLDR: The key is setting the probe_mask for the HDMI card to 0xfff2, else alsa will use the cards Realtek codec instead of the Nvidia code it should be using.

Make sure your system is up-to-date and has the latest version of alsa (1.0.22.1) installed and running.

aplay -l should show you something similar to this, depending on how many sound devices you have in your system:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Card 1 is the Nvidia card in this example.
open /etc/modprobe.d/sound.conf and add this line:

options snd-hda-intel probe_mask=0xffff,0xfff2

If aplay -l shows Nvidia HDMI as card 0 you'll have to use this line:

options snd-hda-intel probe_mask=0xfff2

or for card 2:

options snd-hda-intel probe_mask=0xffff,0xffff,0xfff2

and so on.

Reboot and your HDMI audio out should work now.
You can test it with aplay -D plughw:1,3 aplay -D plughw:1,3 /usr/share/sounds/alsa/Noise.wav

where 1,3 obviously stands for card,device.

Last edited by clesch (2010-02-05 11:45:22)

Offline

#2 2010-02-05 11:41:44

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: GT2xx HDMI audio finally working

That is great to hear. I may be able to verify your results as I will build a htpc myself with the exact same card in the very near future.

Offline

#3 2010-02-05 20:47:13

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Great news, though I can't get it to work on my HTPC.

$ uname -m
x86_64

$ pacman -Q kernel26 nvidia
kernel26 2.6.32.7-1
nvidia 190.53-3

$ lsmod|grep nvhdmi
snd_hda_codec_nvhdmi     4271  0 
snd_hda_codec          63659  2 snd_hda_codec_nvhdmi,snd_hda_intel

$ aplay -l
**** List of PLAYBACK Hardware Devices ****

$ lspci|grep Audio
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

$ cat /etc/modprobe.d/sound.conf 
options snd-hda-intel probe_mask=0xfff2

Though I can see it in alsamixer, but it complains about "This sound device does not have any controls.".

Haven't tried using it in XBMC yet though as I'm using xbmc-svn and am rebuilding it for the new libjpeg. Will post back as soon as it's done.

Last edited by [vEX] (2010-02-05 20:47:29)


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#4 2010-02-05 21:28:55

clesch
Member
From: Salzburg, Austria
Registered: 2009-07-21
Posts: 18

Re: GT2xx HDMI audio finally working

could you check your md5 sums of the following files for me?

/lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko
/lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-codec-nvidia.ko

they should be

82c0b2e81d2761011100626523809b5b
9383cb68f1805393b5ee10edbd279d28

respectively.

I might have patched one of those two files and forgotten about it after all the trying, it was a long night. yikes

Offline

#5 2010-02-05 21:42:37

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Looks alright to me, and xbmc-svn finished compiling but I can't get any sound there.

$ md5sum /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-codec-nvhdmi.ko 
82c0b2e81d2761011100626523809b5b  /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko
9383cb68f1805393b5ee10edbd279d28  /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-codec-nvhdmi.ko

You mentioned "alsa-driver" in the original post, there is no such package and that is probably already merged into the .32.7 kernel, or are you having some package I'm missing?

Do you have any aliases or other options in your /etc/modprobe.d/sound.conf that might be needed? Something in the xorg.conf perhaps?

Last edited by [vEX] (2010-02-05 21:46:45)


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#6 2010-02-05 21:49:33

clesch
Member
From: Salzburg, Austria
Registered: 2009-07-21
Posts: 18

Re: GT2xx HDMI audio finally working

[vEX] wrote:

Looks alright to me, and xbmc-svn finished compiling but I can't get any sound there.

$ md5sum /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-codec-nvhdmi.ko 
82c0b2e81d2761011100626523809b5b  /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko
9383cb68f1805393b5ee10edbd279d28  /lib/modules/2.6.32-ARCH/kernel/sound/pci/hda/snd-hda-codec-nvhdmi.ko

You mentioned "alsa-driver" in the original post, there is no such package and that is probably already merged into the .32.7 kernel, or are you having some package I'm missing?

No, it's part of the kernel — you're not missing anything over me. I've never had the "This sound device does not have any controls." message personally. It's either 4 SPDIF outs with no mask_probe set or one working SPDIF out with the option in place.

//edit: doh, md5s matched. I'm checking my config at the moment to see if there is anything I missed.

Last edited by clesch (2010-02-05 21:51:20)

Offline

#7 2010-02-05 21:57:51

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Well, not that it should make the slightest difference, my card is Gainward G210, passive cooled. I can give lspci output tomorrow if needed, but for now I'm off to sleep. Any help to get this working is greatly appreciated!


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#8 2010-02-05 22:04:43

clesch
Member
From: Salzburg, Austria
Registered: 2009-07-21
Posts: 18

Re: GT2xx HDMI audio finally working

My card is 100% identical to yours - Gainward G210, red color scheme for pcb and cooler.

Maybe you should try compiling the HD_AUDIO-9.10.tar (google) to use those modules.
You'd have to patch two files:

patch_nvhdmi.c: replace all occurrences of 10de000d with 10de000b
hda_intel.c: replace 0x0d97 with 0x0be3

then make, make install, reboot.

I didn't require those steps but then again I always had alsamixer showing 4 (defunct) spdif outputs for my hdmi audio device.

quick update, someone over at the xbmc linux forum created a patch that should help people with cards not showing up at all. thread is here.

Last edited by clesch (2010-02-06 06:57:12)

Offline

#9 2010-02-06 12:38:14

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Tried  the HD_AUDIO-9.10.tar package, I only get kernel oops with those drivers. :-/

Going to try that patch a bit later and see if I can get it to work.


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#10 2010-02-07 10:38:24

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Well, I ended up registering on the XBMC forums, tried his latest patch but sadly it only plays like 1 second of audio and then loops it and the video gets sluggish as well. Oh well, at least that's a lot more than I've gotten so far.


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#11 2010-02-14 18:01:14

Xecuter
Member
Registered: 2009-01-21
Posts: 5

Re: GT2xx HDMI audio finally working

I also got mine working, but aplay -l shows that i have to devices on the card:

**** List of PLAYBACK Hardware Devices ****
card 0: Mia [Mia], device 0: PCM [Mia]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Device 7 works, but device 3 doesn't. How do i get pulseaudio to play to device 7? Or how can i block device 3 somehow?

EDIT: Fixed it! big_smile
I added "load-module module-alsa-sink device=hw:2,7" to the /etc/pulse/default.pa, which then gave me an option to use that in the volume manager!

Last edited by Xecuter (2010-02-14 18:58:11)

Offline

#12 2010-06-01 01:18:50

ould
Member
Registered: 2007-05-22
Posts: 121

Re: GT2xx HDMI audio finally working

Is this still working for you guys with a system that is up to date. I can't get the HDMI audio to work. I have tried the card in both my systems(main and htpc) and have the same results on both. I can see the second audio card in Alsamixer but it says "This sound device does not have any controls". I tried creating a sound.conf with the probe mask but no change there either.

uname -r

2.6.33-ARCH

lspci -vv

06:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 8307
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ee000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4c00 [size=128]
        [virtual] Expansion ROM at e0000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nvidia, nvidiafb

06:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 8307
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fcffc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

pacman -Qs kernel nvidia alsa

local/kernel26 2.6.33.4-1 (base)
    The Linux Kernel and modules
local/kernel26-firmware 2.6.33.4-1 (base)
    The included firmware files of the Linux Kernel
local/kernel26-headers 2.6.33.4-1
    Header files and scripts for building modules for kernel26
local/libvdpau 0.4-1
    Nvidia VDPAU library
local/nvidia 195.36.15-2
    NVIDIA drivers for kernel26.
local/nvidia-utils 195.36.15-1
    NVIDIA drivers utilities and libraries.
local/alsa-lib 1.0.23-1
    An alternative implementation of Linux sound support
local/alsa-utils 1.0.23-2
    An alternative implementation of Linux sound support

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

just my onboard audio shows up

Any ideas?? Even if a modprobe the hdmi module it doesn't help, it doesn't generate errors but doesn't change anything either. I could try to revert back to earlier versions of alsa and nvidia but could be difficult with any dependancies so I will save that for a last resort. :-)

Getting frustrated. lol

Thanks,

Kevin

Last edited by ould (2010-06-01 01:20:45)

Offline

#13 2010-06-01 21:39:12

ould
Member
Registered: 2007-05-22
Posts: 121

Re: GT2xx HDMI audio finally working

I managed to get it sussed out today. I had to download the alsa-driver package from the Alsa site and manually compile and install the kernel modules. The stock Arch kernel modules would not work not matter what I tried, it would not use the snd-hda-codec-nvhdmi module at all and would not show up in an aplay -l output and had no mixer controls.

As soon as I installed the manually built package it worked like a charm. Well, worked is a relative term as I did all this remotely over ssh from work so I won't know until I am physically at home if it worked for sure but I went from no controls to 4 pcm outputs and now to one output after adjusting my sound.conf. Thanks for the original thread and directions and hopefully my solution helps someone else. I did not patch the alsa package at all, just downloaded, untarred, configured and make, make install.  ftp://ftp.alsa-project.org/pub/driver/a … 23.tar.bz2 is what I downloaded just to be clear. And my system is as posted above kernel wise and such.

Thanks, and will report back once I hear some actual audio. :-D

UPDATE, tried it last night and it did work for DTS, DD and MP3. The only thing that didn't work is XBMC navigation sounds, is that what you guys are seeing?

Kevin

Last edited by ould (2010-06-02 21:06:25)

Offline

#14 2010-06-02 20:52:18

brisbin33
Member
From: boston, ma
Registered: 2008-07-24
Posts: 1,796
Website

Re: GT2xx HDMI audio finally working

Great news ould, i'd been putting this off for quite some time. 

I've created a PKGBUILD for alsa-drivers 1.0.23.  I've tested that it builds, but I've yet to install it (i'm a bit leary about the depmod command i put in the post_install() at the instruction of the make output).  anyone who wants to try it* can get it here; i'll be trying it myself tonight.

*no warranties of course.

Offline

#15 2010-06-02 21:05:30

ould
Member
Registered: 2007-05-22
Posts: 121

Re: GT2xx HDMI audio finally working

Great to have a PKGBUILD, I could have used it yesterday. big_smile Haha I just did it the easy way, configure, make, make install. It only installs the kernel modules(i think) so not bad really. Thanks for making this though and I will use it in the future when/if I need it.

I am thinking about trying to get uncompressed PCM working as described in this thread http://forum.xbmc.org/showthread.php?t=59877. Now that we have sound working with these cards it should be as simple as using this guys asound.conf and HDA-intel.conf files. May try it this weekend if I find some time.

Kevin

Offline

#16 2010-06-04 18:00:59

Varakh
Member
Registered: 2010-06-04
Posts: 9

Re: GT2xx HDMI audio finally working

i'm not able to install the related alsa build ...

[alexander@tuxbox alsa-driver]$ makepkg
==> Erstelle Paket: alsa-driver 1.0.23-1 i686 (Fr 4. Jun 19:58:30 CEST 2010)
==> Prüfe Laufzeit-Abhängigkeiten... 
==> Prüfe Buildtime-Abhängigkeiten... 
==> Empfange Quellen...
  -> alsa-driver-1.0.23.tar.bz2 im Build-Verzeichnis gefunden
==> Überprüfe Gültigkeit der Quell-Dateien mit md5sums...
    alsa-driver-1.0.23.tar.bz2 ... Durchgelaufen
==> Entpacke Quellen...
  -> Entpacke alsa-driver-1.0.23.tar.bz2 mit bsdtar 
==> Entferne existierendes pkg/ Verzeichnis ...
==> Betrete fakeroot-Umgebung ...
==> Beginne build()...
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/alexander/downloads/alsa-driver/src/alsa-driver-1.0.23
checking cross compile... 
checking for directory with ALSA kernel sources... ../alsa-kmirror
checking for directory with kernel source... Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).
make all-deps
make[1]: Entering directory `/home/alexander/downloads/alsa-driver/src/alsa-driver-1.0.23'
make[1]: Für das Ziel »all-deps« ist nichts zu tun.
make[1]: Leaving directory `/home/alexander/downloads/alsa-driver/src/alsa-driver-1.0.23'

Please, run the configure script as first...

if [ -L /home/alexander/downloads/alsa-driver/pkg//include/sound ]; then \
        rm -f /home/alexander/downloads/alsa-driver/pkg//include/sound; \
        ln -sf /home/alexander/downloads/alsa-driver/src/alsa-driver-1.0.23/include/sound /home/alexander/downloads/alsa-driver/pkg//include/sound; \
    else \
        rm -rf /home/alexander/downloads/alsa-driver/pkg//include/sound; \
        install -d -m 755 -g root -o root /home/alexander/downloads/alsa-driver/pkg//include/sound; \
        for f in include/sound/*.h; do \
            install -m 644 -g root -o root $f /home/alexander/downloads/alsa-driver/pkg//include/sound; \
        done \
    fi
install: Aufruf von stat für „include/sound/*.h" nicht möglich: Datei oder Verzeichnis nicht gefunden
make: *** [install-headers] Fehler 1
==> FEHLER: Build fehlgeschlagen.
    Breche ab ...
[alexander@tuxbox alsa-driver]$

heres my thread btw: http://bbs.archlinux.org/viewtopic.php?pid=769737

Offline

#17 2010-06-04 20:57:26

[vEX]
Member
From: Sweden
Registered: 2006-11-23
Posts: 450

Re: GT2xx HDMI audio finally working

Well, I took the quick and dirty route on my HTPC. I just downloaded, built and installed 1.0.23 without using any PKGBUILD. Everything works fine with my G210! Though I'm eagerly awaiting 2.6.34 has Alsa 1.0.23 in it so I don't have to feel so dirty about manually installing files. ;-)


PC: Antec P182B | Asus P8Z77-V PRO | Intel i5 3570k | 16GB DDR3 | GeForce 450GTS | 4TB HDD | Pioneer BDR-207D | Asus Xonar DX | Altec Lansing CS21 | Eizo EV2736W-BK | Arch Linux x86_64
HTPC: Antec NSK2480 | ASUS M3A78-EM (AMD 780G) | AMD Athlon X3 425 | 8GB DDR2 | GeForce G210 | 2TB HDD | Arch Linux x86_64
Server: Raspberry Pi (model B) | 512MB RAM | 750GB HDD | Arch Linux ARM

Offline

#18 2010-06-23 19:55:03

mista
Member
Registered: 2010-06-23
Posts: 1

Re: GT2xx HDMI audio finally working

I am running 2.6.34-ARCH

Still not able to get HDMI audio to work through ALSA.

I am however, able to get sound by running

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Left.wav

here is my aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: SN25P [Shuttle SN25P], device 0: ICE1724 [ICE1724]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SN25P [Shuttle SN25P], device 1: ICE1724 IEC958 [ICE1724 IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SN25P [Shuttle SN25P], device 2: ICE1724 Surrounds [ICE1724 Surround PCM]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

my lspci |grep Audio

01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
05:06.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

Should I be doing something specific in ALSA?

Last edited by mista (2010-06-23 19:55:41)

Offline

#19 2010-08-01 18:24:51

irpye
Member
Registered: 2010-08-01
Posts: 5

Re: GT2xx HDMI audio finally working

I finally get Audio on HDMI with a GeForce 210 (MSI VN210-MD512 H) working.

Here is a little feedback.

I use Alsa and Pulseaudio.
I also have a Creative Audigy SE sound card. So for Alsa and Pulse, the GeForce 210 is my second card.

aplay -l give me this :

**** List of PLAYBACK Hardware Devices ****
card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 1: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 2: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 3: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And no sound.... But i see an HDMI output in pulsaudio volume control.


I followed this guide :
http://wiki.xbmc.org/?title=HOW-TO_set_ … ,_or_GT240
Like they said, for my card, i only add enable_msi=0 in my sound.conf.
I didn't use probe_mask, as they only advice to do it  for specific models.
So /etc/modprobe.d/sound.conf looks like this :

alias snd-card-0 snd-ca0106
alias sound-slot-0 snd-ca0106
alias snd-card-1 snd-hda-intel
alias sound-slot-1 snd-hda-intel
options snd-hda-intel enable_msi=0

Still folowing the guide, i add this line in /etc/pulse/default.pa : load-module module-alsa-sink device=plughw:1,7 (plughw:1,7 is the device recommended by this guide for my card.)

Still no sound... A second HDMI output appears in my pulseaudio volume control, but none works.
I didn't want to have unsued output.
So i also declared my first soundcard with load-module module-alsa-sink device=plughw:0,0
And i disabled  the part of the script that automatically detect driver

Here is a part of my new /etc/pulse/default.pa (the thing i modified are underlined):

(...)
### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)
#load-module module-alsa-sink
load-module module-alsa-sink device=plughw:0,0
load-module module-alsa-sink device=plughw:1,7

#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
#.ifexists module-udev-detect.so
#load-module module-udev-detect
#.else
### Alternatively use the static hardware detection module (for systems that
### lack udev support)
#load-module module-detect
#.endif
(...)

But still no sound...

I played a little with alsamixer (in fact i tried before, but no success) annd found that "SPIDF 1" was muted.
I unmuted it... and tadaaa! Sound worked with HDMI !
End of story ? No.... When i reboot, no sound with HDMI again ! I unmuted again SPIDF 1 in alsamixer and it worked again.
I tried to store alsamixer setting with

alsactl store

but everytime i reboot, SPIDF 1 is muted.

Here is a workaround to unmute SPIDF 1 at the end of the boot.
Just add a line in /etc/rc.local
My new rc.local :

#!/bin/bash
#
# /etc/rc.local: Local multi-user startup script.
#
amixer -c 1 set IEC958,1 unmute

Hope this helps someone.

Offline

#20 2010-10-11 20:17:33

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 772
Website

Re: GT2xx HDMI audio finally working

Im having the same problem with a GT 240.... desperate... since the alsa version im currently using is .23... so, the latest one......
Should i just edit /etc/modprobe.d/sound.conf? What should i put?

BTW: I have an integrated nvidia video card on the motherboard... with hdmi.......

Help please!!

Offline

#21 2010-10-12 14:32:29

brisbin33
Member
From: boston, ma
Registered: 2008-07-24
Posts: 1,796
Website

Re: GT2xx HDMI audio finally working

mista wrote:

I am running 2.6.34-ARCH

Still not able to get HDMI audio to work through ALSA.

I am however, able to get sound by running

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Left.wav

here is my aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: SN25P [Shuttle SN25P], device 0: ICE1724 [ICE1724]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SN25P [Shuttle SN25P], device 1: ICE1724 IEC958 [ICE1724 IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SN25P [Shuttle SN25P], device 2: ICE1724 Surrounds [ICE1724 Surround PCM]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

my lspci |grep Audio

01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
05:06.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

Should I be doing something specific in ALSA?

maybe you (all) could try this?  replacing plug 1,7 with 1,3 or whatever works for you with aplay...?

Offline

#22 2010-10-12 14:57:20

Xi0N
Member
From: Bilbao - Spain
Registered: 2007-11-29
Posts: 772
Website

Re: GT2xx HDMI audio finally working

This is what actually worked for me:

edit your files as below:
Quote:
>more /etc/modprobe.d/sound.conf 
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

> more ~/.asoundrc (I actually did not touch this file)
pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia
Reboot (altho tux might insist its not needed ) (btw, I was wondering the same thing, and asked in the alsa thread. I got this answer: http://ubuntuforums.org/showpost.php...&postcount=803 .. above my expertise level...

At this point (after reboot, or a successful alsa restart), run
Quote:
sudo alsaconf
and then
Quote:
alsamixer
switch to card 1 (with F6) and un-mute (m) your nvidia hdmi port, after which
Quote:
speaker-test -c6 -twav -Dplughw:1,3
should work.



http://www.avsforum.com/avs-vb/showthread.php?t=1225332

Last edited by Xi0N (2010-10-12 15:01:02)

Offline

Board footer

Powered by FluxBB